Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция Индекс и ПОИСКПОЗ и повторяющиеся значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Функция Индекс и ПОИСКПОЗ и повторяющиеся значения
kmihaylovich Дата: Четверг, 04.05.2023, 16:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Ребята, всем привет!

Не могу никак победить повторяющиеся значения для извлечения необходимой информации из предоставленных данных.

В листе 3 мне необходима конкретная информация из листа 4 где ее очень много. Выведение информации нужно исходя из номера смены и фио сотрудника. Как вы уже понимайте, в одной смене есть еще сотрудники. Извлечь мне необходимо строго "ФД". Много перечитал ну никак не могу справиться с решением данной задачи, легко и удобно.

Хотелось бы чтоб это выглядело так:

в лист 4 я вставляю сводные данные с разными сменами и с разными сотрудниками (данные всегда ассиметричны). В лист 3 хочу выбрать нужную смену и нужного сотрудника и по этому вывести "ФД" в таблицу, ну а дальше все просто.

На данном этапе, сделал сцепку фио по нумерациям (ну это сложно) неужели нельзя это упростить?
Формула сейчас:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист4!$D$2:$D$310;ПОИСКПОЗ(1;(Лист3!J12=ОФДИмя)*(Лист3!$F$8=Лист4!$A$2:$A$310);0));"")
К сообщению приложен файл: test.xlsx (123.7 Kb)


Сообщение отредактировал Serge_007 - Четверг, 04.05.2023, 17:19
 
Ответить
СообщениеРебята, всем привет!

Не могу никак победить повторяющиеся значения для извлечения необходимой информации из предоставленных данных.

В листе 3 мне необходима конкретная информация из листа 4 где ее очень много. Выведение информации нужно исходя из номера смены и фио сотрудника. Как вы уже понимайте, в одной смене есть еще сотрудники. Извлечь мне необходимо строго "ФД". Много перечитал ну никак не могу справиться с решением данной задачи, легко и удобно.

Хотелось бы чтоб это выглядело так:

в лист 4 я вставляю сводные данные с разными сменами и с разными сотрудниками (данные всегда ассиметричны). В лист 3 хочу выбрать нужную смену и нужного сотрудника и по этому вывести "ФД" в таблицу, ну а дальше все просто.

На данном этапе, сделал сцепку фио по нумерациям (ну это сложно) неужели нельзя это упростить?
Формула сейчас:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист4!$D$2:$D$310;ПОИСКПОЗ(1;(Лист3!J12=ОФДИмя)*(Лист3!$F$8=Лист4!$A$2:$A$310);0));"")

Автор - kmihaylovich
Дата добавления - 04.05.2023 в 16:35
Nic70y Дата: Четверг, 04.05.2023, 17:05 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8821
Репутация: 2298 ±
Замечаний: 0% ±

Excel 2010
если в реале все упорядочено, как в файле:
К сообщению приложен файл: 19.xlsx (126.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеесли в реале все упорядочено, как в файле:

Автор - Nic70y
Дата добавления - 04.05.2023 в 17:05
kmihaylovich Дата: Четверг, 04.05.2023, 17:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Да, действительно все работает, спасибо!
Очень грустно, что я никак не могу понять, почему так сложно и не могу разобрать вашу формулу.

Обратил внимание, что в столбце ФД 2 разные формулы и зачем формула в B10?
К сообщению приложен файл: 6610965.png (88.2 Kb)
 
Ответить
СообщениеДа, действительно все работает, спасибо!
Очень грустно, что я никак не могу понять, почему так сложно и не могу разобрать вашу формулу.

Обратил внимание, что в столбце ФД 2 разные формулы и зачем формула в B10?

Автор - kmihaylovich
Дата добавления - 04.05.2023 в 17:46
Nic70y Дата: Среда, 10.05.2023, 07:51 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8821
Репутация: 2298 ±
Замечаний: 0% ±

Excel 2010
B10
определяет нижнюю границу номера смены и соот. упрощает формулы ниже.
2 разные формулы
с 13 строки формулы ссылаются на строку выше, т.е предыдущий ФД №
В12 не может сослаться на предыдущий.


ЮMoney 41001841029809
 
Ответить
Сообщение
B10
определяет нижнюю границу номера смены и соот. упрощает формулы ниже.
2 разные формулы
с 13 строки формулы ссылаются на строку выше, т.е предыдущий ФД №
В12 не может сослаться на предыдущий.

Автор - Nic70y
Дата добавления - 10.05.2023 в 07:51
kmihaylovich Дата: Среда, 10.05.2023, 16:53 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Подскажи, пожалуйста, зачем : между формулами и какую она играет роль? - B14-ПОИСКПОЗ(C$8;ИНДЕКС(Лист4!AB:AB;ПОИСКПОЗ(B14;Лист4!D:D;)+1):ИНДЕКС(Лист4!AB:AB;B$10);)
 
Ответить
СообщениеNic70y, Подскажи, пожалуйста, зачем : между формулами и какую она играет роль? - B14-ПОИСКПОЗ(C$8;ИНДЕКС(Лист4!AB:AB;ПОИСКПОЗ(B14;Лист4!D:D;)+1):ИНДЕКС(Лист4!AB:AB;B$10);)

Автор - kmihaylovich
Дата добавления - 10.05.2023 в 16:53
Nic70y Дата: Среда, 10.05.2023, 17:03 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 8821
Репутация: 2298 ±
Замечаний: 0% ±

Excel 2010
ИНДЕКС дает ссылку на одну ячейку, : между ними создает диапазон от одной до другой ячейки


ЮMoney 41001841029809
 
Ответить
СообщениеИНДЕКС дает ссылку на одну ячейку, : между ними создает диапазон от одной до другой ячейки

Автор - Nic70y
Дата добавления - 10.05.2023 в 17:03
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!