Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Весь диапазон для ИНДЕКС, но со второй строки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Весь диапазон для ИНДЕКС, но со второй строки
soniclord Дата: Четверг, 18.05.2023, 03:38 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 20% ±

Всем здравствуйте!

Не могу указать индексу весь диапазон но со второй строки, выдает ошибку. Т.е., вот так работает:
Код
=ЕСЛИОШИБКА(ИНДЕКС(segment1!C:C; ПОИСКПОЗ(0; ИНДЕКС(СЧЁТЕСЛИ($A$1:A25; segment1!C:C); 0; 0); 0)); "")


а так уже нет:
Код
=ЕСЛИОШИБКА(ИНДЕКС(segment1!C2:C; ПОИСКПОЗ(0; ИНДЕКС(СЧЁТЕСЛИ($A$1:A25; segment1!C2:C); 0; 0); 0)); "")
 
Ответить
СообщениеВсем здравствуйте!

Не могу указать индексу весь диапазон но со второй строки, выдает ошибку. Т.е., вот так работает:
Код
=ЕСЛИОШИБКА(ИНДЕКС(segment1!C:C; ПОИСКПОЗ(0; ИНДЕКС(СЧЁТЕСЛИ($A$1:A25; segment1!C:C); 0; 0); 0)); "")


а так уже нет:
Код
=ЕСЛИОШИБКА(ИНДЕКС(segment1!C2:C; ПОИСКПОЗ(0; ИНДЕКС(СЧЁТЕСЛИ($A$1:A25; segment1!C2:C); 0; 0); 0)); "")

Автор - soniclord
Дата добавления - 18.05.2023 в 03:38
Gustav Дата: Четверг, 18.05.2023, 06:13 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2759
Репутация: 1140 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Насколько я помню, ссылку на открытый диапазон типа C2:C можно указывать в формулах Таблиц Google. В Excel же строку у второй координаты нужно указывать в явном виде, т.е. C2:C1048576. Но, вроде, в последних версиях для подобных случаев был замечен синтаксис типа C2# (сам не пользовался, но погуглите!)

[p.s.]Увы, что-то не могу найти нигде "синтаксис типа C2#"... Приснилось, что-ли?.. "Желаемое за действительное"?..[/p.s.]
Если кто-то всё-таки видел нечто подобное, отзовитесь!


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Четверг, 18.05.2023, 14:41
 
Ответить
СообщениеНасколько я помню, ссылку на открытый диапазон типа C2:C можно указывать в формулах Таблиц Google. В Excel же строку у второй координаты нужно указывать в явном виде, т.е. C2:C1048576. Но, вроде, в последних версиях для подобных случаев был замечен синтаксис типа C2# (сам не пользовался, но погуглите!)

[p.s.]Увы, что-то не могу найти нигде "синтаксис типа C2#"... Приснилось, что-ли?.. "Желаемое за действительное"?..[/p.s.]
Если кто-то всё-таки видел нечто подобное, отзовитесь!

Автор - Gustav
Дата добавления - 18.05.2023 в 06:13
soniclord Дата: Четверг, 18.05.2023, 07:57 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 20% ±

в последних версиях

извиняюсь, а 2013 считается одним из последних? ) Если нет, то не подойдет
 
Ответить
Сообщение
в последних версиях

извиняюсь, а 2013 считается одним из последних? ) Если нет, то не подойдет

Автор - soniclord
Дата добавления - 18.05.2023 в 07:57
elovkov Дата: Четверг, 18.05.2023, 07:58 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
одним из последних?

Нет)))
Тогда как писал Gustav,

нужно указывать в явном виде, т.е. C2:C1048576


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
одним из последних?

Нет)))
Тогда как писал Gustav,

нужно указывать в явном виде, т.е. C2:C1048576

Автор - elovkov
Дата добавления - 18.05.2023 в 07:58
soniclord Дата: Четверг, 18.05.2023, 08:19 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 20% ±

всем спасибо, можно закрывать
 
Ответить
Сообщениевсем спасибо, можно закрывать

Автор - soniclord
Дата добавления - 18.05.2023 в 08:19
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!