Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение значений из столбца 1 которых нет в столбце 2 - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Нахождение значений из столбца 1 которых нет в столбце 2
anger13rivel Дата: Пятница, 19.05.2023, 21:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2010
Добрый день, помогите прописать формулу чтоб в столбце K появились все значения из столбца J которых нету в столбце I
К сообщению приложен файл: 3906816.xlsx (9.8 Kb)


Rivel
 
Ответить
СообщениеДобрый день, помогите прописать формулу чтоб в столбце K появились все значения из столбца J которых нету в столбце I

Автор - anger13rivel
Дата добавления - 19.05.2023 в 21:01
bigorq Дата: Пятница, 19.05.2023, 22:08 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 197
Репутация: 47 ±
Замечаний: 0% ±

Нет
Добрый
Попробуйте в К2
Код
=INDEX($J$2:$J$4;SMALL(IF(COUNTIF($J$2:$J$4;$I$2:$I$4)=0;ROW($J$2:$J$4)-1;"");ROW(A1)))

массивная и протянуть вниз
 
Ответить
СообщениеДобрый
Попробуйте в К2
Код
=INDEX($J$2:$J$4;SMALL(IF(COUNTIF($J$2:$J$4;$I$2:$I$4)=0;ROW($J$2:$J$4)-1;"");ROW(A1)))

массивная и протянуть вниз

Автор - bigorq
Дата добавления - 19.05.2023 в 22:08
DrMini Дата: Суббота, 20.05.2023, 05:54 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Вариант с доп столбцом в колонке L:
Код
=ЕСЛИОШИБКА(ИНДЕКС($J$2:$J$4;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($I$2:$I$4;$J$2:$J$4)=0;СТРОКА($J$2:$J$4));L2)-1);"")

Массивная.
Подправил формулы в колонках I и J. У Вас anger13rivel, после некоторых имён и фамилий в колонках С и D стоят пробелы.
К сообщению приложен файл: 3906816_1.xlsx (10.3 Kb)


Сообщение отредактировал DrMini - Суббота, 20.05.2023, 08:03
 
Ответить
СообщениеВариант с доп столбцом в колонке L:
Код
=ЕСЛИОШИБКА(ИНДЕКС($J$2:$J$4;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($I$2:$I$4;$J$2:$J$4)=0;СТРОКА($J$2:$J$4));L2)-1);"")

Массивная.
Подправил формулы в колонках I и J. У Вас anger13rivel, после некоторых имён и фамилий в колонках С и D стоят пробелы.

Автор - DrMini
Дата добавления - 20.05.2023 в 05:54
DrMini Дата: Суббота, 20.05.2023, 06:20 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
У bigorq, лучше (без доп столбца) но наверное нужно её чуть подправить.
Код
=ЕСЛИОШИБКА(ИНДЕКС($J$2:$J$4;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($I$2:$I$4;$J$2:$J$4)=0;СТРОКА($J$2:$J$4));СТРОКА(A1))-1);"")
 
Ответить
СообщениеУ bigorq, лучше (без доп столбца) но наверное нужно её чуть подправить.
Код
=ЕСЛИОШИБКА(ИНДЕКС($J$2:$J$4;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($I$2:$I$4;$J$2:$J$4)=0;СТРОКА($J$2:$J$4));СТРОКА(A1))-1);"")

Автор - DrMini
Дата добавления - 20.05.2023 в 06:20
Nic70y Дата: Суббота, 20.05.2023, 07:55 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8831
Репутация: 2300 ±
Замечаний: 0% ±

Excel 2010
с доп.столбцом
K:
Код
=ЕСЛИОШИБКА(ИНДЕКС(J:J;ПОИСКПОЗ(СТРОКА(K1);L:L;));"")
L:
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(J2;I:I;));L1+1;L1)
+ изменил формулы в I:J
К сообщению приложен файл: 215.xlsx (10.0 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Суббота, 20.05.2023, 07:56
 
Ответить
Сообщениес доп.столбцом
K:
Код
=ЕСЛИОШИБКА(ИНДЕКС(J:J;ПОИСКПОЗ(СТРОКА(K1);L:L;));"")
L:
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(J2;I:I;));L1+1;L1)
+ изменил формулы в I:J

Автор - Nic70y
Дата добавления - 20.05.2023 в 07:55
anger13rivel Дата: Суббота, 20.05.2023, 17:48 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2010
спасибо большое за решеие


Rivel
 
Ответить
Сообщениеспасибо большое за решеие

Автор - anger13rivel
Дата добавления - 20.05.2023 в 17:48
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!