Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать дни определенного месяца из диапазона дат - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Выбрать дни определенного месяца из диапазона дат
Dend1 Дата: Понедельник, 29.05.2023, 21:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

2010
В графике работ указаны работы с продолжительностью по декадам месяца
Мне нужно написать формулу которая покажет сколько дней в каждом месяце проходят работы
Сам график рисуется условным форматированием
Во вложении файл
Всю голову сломал,не получается
К сообщению приложен файл: 2448884.xlsx (44.0 Kb)


Сообщение отредактировал Dend1 - Понедельник, 29.05.2023, 21:27
 
Ответить
СообщениеВ графике работ указаны работы с продолжительностью по декадам месяца
Мне нужно написать формулу которая покажет сколько дней в каждом месяце проходят работы
Сам график рисуется условным форматированием
Во вложении файл
Всю голову сломал,не получается

Автор - Dend1
Дата добавления - 29.05.2023 в 21:26
Dend1 Дата: Понедельник, 29.05.2023, 22:32 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

2010
Код
=СУММПРОИЗВ(C15:D15>=F20)*(C15:D15<=G20)
пробую так, показывает 0, где C15:D15 начало:конец, F20 01.06.2023, g20 30.06.2023

Код
=ЕСЛИ(ИЛИ(И(--ЛЕВБ(C15;10)>=F20;--ЛЕВБ(D15;10)<=G20);И(--ПРАВБ(C7;10)>=F20;--ПРАВБ(D15;10)<=G20));"да";"нет")
тут #знач! только получается


Сообщение отредактировал Serge_007 - Вторник, 30.05.2023, 09:04
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(C15:D15>=F20)*(C15:D15<=G20)
пробую так, показывает 0, где C15:D15 начало:конец, F20 01.06.2023, g20 30.06.2023

Код
=ЕСЛИ(ИЛИ(И(--ЛЕВБ(C15;10)>=F20;--ЛЕВБ(D15;10)<=G20);И(--ПРАВБ(C7;10)>=F20;--ПРАВБ(D15;10)<=G20));"да";"нет")
тут #знач! только получается

Автор - Dend1
Дата добавления - 29.05.2023 в 22:32
Gustav Дата: Понедельник, 29.05.2023, 23:05 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2763
Репутация: 1140 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Погуглите по фразе "Пересечение интервалов дат в Excel"

[p.s.]Погреюсь в лучах чужой славы - Николая Павлова и Михаила (MCH). Процитирую две формулы от них - для расчёта кол-ва дней пересечения двух интервалов дат (из известной статьи, одной из первых находящейся при погугливании).[/p.s.]

Итак, пусть есть два интервала дат:
первый - с датой начала в ячейке H1 и датой окончания в ячейке K1,
второй - с датой начала в ячейке H2 и датой окончания в ячейке K2.

Буквы в адресах ячеек, естественно, латинские, но в рамках данной задачи удобно их воспринимать как русские. Т.е. буква H (эйч), выглядящая как русская Н (эн), символизирует "начало", а буква K (кей), выглядящая как русская К (ка) - "конец". Числа в адресах ячеек (номера строк) символизируют "первый" и "второй" интервалы дат.

Тогда кол-во дней пересечения двух интервалов можно определить (результат 0 означает, что интервалы не пересекаются):

либо по формуле Николая Павлова (очень изящная):
Код
=МЕДИАНА(H1;K1+1;K2+1)-МЕДИАНА(H1;K1+1;H2)


либо по формуле Михаила (MCH) (очень компактная):
Код
=МАКС(МИН(K2+1;K1+1)-МАКС(H2;H1);)


Наконец, пользователи самых современных версий Excel могут записать формулу более наглядно и, кроме того, включить в неё сразу оба алгоритма и устанавливать формулу окончательного вычисления в зависимости, например, от настроения :) :
[vba]
Код
=LET(
начало1;    H1;
конец1;     K1;
начало2;    H2;
конец2;     K2;

формулаНП;  МЕДИАНА(начало1;конец1+1;конец2+1)-МЕДИАНА(начало1;конец1+1;начало2);
формулаMCH; МАКС(МИН(конец2+1;конец1+1)-МАКС(начало2;начало1););

формулаMCH
)
[/vba]
В данном случае выбрана формулаMCH (перед заключительной скобкой), но ее можно в любой момент поменять на другую.


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Вторник, 30.05.2023, 02:29
 
Ответить
СообщениеПогуглите по фразе "Пересечение интервалов дат в Excel"

[p.s.]Погреюсь в лучах чужой славы - Николая Павлова и Михаила (MCH). Процитирую две формулы от них - для расчёта кол-ва дней пересечения двух интервалов дат (из известной статьи, одной из первых находящейся при погугливании).[/p.s.]

Итак, пусть есть два интервала дат:
первый - с датой начала в ячейке H1 и датой окончания в ячейке K1,
второй - с датой начала в ячейке H2 и датой окончания в ячейке K2.

Буквы в адресах ячеек, естественно, латинские, но в рамках данной задачи удобно их воспринимать как русские. Т.е. буква H (эйч), выглядящая как русская Н (эн), символизирует "начало", а буква K (кей), выглядящая как русская К (ка) - "конец". Числа в адресах ячеек (номера строк) символизируют "первый" и "второй" интервалы дат.

Тогда кол-во дней пересечения двух интервалов можно определить (результат 0 означает, что интервалы не пересекаются):

либо по формуле Николая Павлова (очень изящная):
Код
=МЕДИАНА(H1;K1+1;K2+1)-МЕДИАНА(H1;K1+1;H2)


либо по формуле Михаила (MCH) (очень компактная):
Код
=МАКС(МИН(K2+1;K1+1)-МАКС(H2;H1);)


Наконец, пользователи самых современных версий Excel могут записать формулу более наглядно и, кроме того, включить в неё сразу оба алгоритма и устанавливать формулу окончательного вычисления в зависимости, например, от настроения :) :
[vba]
Код
=LET(
начало1;    H1;
конец1;     K1;
начало2;    H2;
конец2;     K2;

формулаНП;  МЕДИАНА(начало1;конец1+1;конец2+1)-МЕДИАНА(начало1;конец1+1;начало2);
формулаMCH; МАКС(МИН(конец2+1;конец1+1)-МАКС(начало2;начало1););

формулаMCH
)
[/vba]
В данном случае выбрана формулаMCH (перед заключительной скобкой), но ее можно в любой момент поменять на другую.

Автор - Gustav
Дата добавления - 29.05.2023 в 23:05
elovkov Дата: Вторник, 30.05.2023, 07:37 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 385
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
либо по формуле Михаила (MCH) (очень компактная)

В части компактности, видел темы, где соревнуются спецы кто короче формулу придумает. В этом свете вопрос - зачем точка с запятой перед последней скобкой?


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
либо по формуле Михаила (MCH) (очень компактная)

В части компактности, видел темы, где соревнуются спецы кто короче формулу придумает. В этом свете вопрос - зачем точка с запятой перед последней скобкой?

Автор - elovkov
Дата добавления - 30.05.2023 в 07:37
прохожий2019 Дата: Вторник, 30.05.2023, 07:57 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1264
Репутация: 322 ±
Замечаний: 0% ±

365 Beta Channel
зачем точка с запятой перед последней скобкой
это разделитель аргументов, после него ничего нет, эксель это воспримет как ноль, поэтому вычисляется максимум между разницей и нулём, при отрицательной разнице будет возвращён ноль )))
 
Ответить
Сообщение
зачем точка с запятой перед последней скобкой
это разделитель аргументов, после него ничего нет, эксель это воспримет как ноль, поэтому вычисляется максимум между разницей и нулём, при отрицательной разнице будет возвращён ноль )))

Автор - прохожий2019
Дата добавления - 30.05.2023 в 07:57
elovkov Дата: Вторник, 30.05.2023, 08:16 | Сообщение № 6
Группа: Друзья
Ранг: Обитатель
Сообщений: 385
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Ага, про отрицательную разницу не подумал) Понял)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеАга, про отрицательную разницу не подумал) Понял)

Автор - elovkov
Дата добавления - 30.05.2023 в 08:16
Dend1 Дата: Вторник, 30.05.2023, 08:57 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

2010
Не совсем пересечение дат мне нужно))
Я должен понимать, сколько каждая из работ занимает дней в определенном месяце.
Грубо говоря есть работа которая длится с 01.06.23 по 30.08.23, так вот мне нужно вычислить сколько дней в каждом из месяцев производится работа
 
Ответить
СообщениеНе совсем пересечение дат мне нужно))
Я должен понимать, сколько каждая из работ занимает дней в определенном месяце.
Грубо говоря есть работа которая длится с 01.06.23 по 30.08.23, так вот мне нужно вычислить сколько дней в каждом из месяцев производится работа

Автор - Dend1
Дата добавления - 30.05.2023 в 08:57
elovkov Дата: Вторник, 30.05.2023, 10:04 | Сообщение № 8
Группа: Друзья
Ранг: Обитатель
Сообщений: 385
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Начал писать формулу, но работать надо, часть прописал, попробуйте в таком направлении
Код
=ЕСЛИОШИБКА(ЕСЛИ(И(МЕСЯЦ(C16)=МЕСЯЦ(H$10);МЕСЯЦ(D16)=МЕСЯЦ(H$10));D16-C16+1;ЕСЛИ(И(МЕСЯЦ(C16)=МЕСЯЦ(H$10);МЕСЯЦ(D16)>МЕСЯЦ(H$10));КОНМЕСЯЦА(H10;0)-C16;0));)

Надо условий еще добить
К сообщению приложен файл: 5278625.xlsx (43.1 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Вторник, 30.05.2023, 10:04
 
Ответить
СообщениеНачал писать формулу, но работать надо, часть прописал, попробуйте в таком направлении
Код
=ЕСЛИОШИБКА(ЕСЛИ(И(МЕСЯЦ(C16)=МЕСЯЦ(H$10);МЕСЯЦ(D16)=МЕСЯЦ(H$10));D16-C16+1;ЕСЛИ(И(МЕСЯЦ(C16)=МЕСЯЦ(H$10);МЕСЯЦ(D16)>МЕСЯЦ(H$10));КОНМЕСЯЦА(H10;0)-C16;0));)

Надо условий еще добить

Автор - elovkov
Дата добавления - 30.05.2023 в 10:04
elovkov Дата: Вторник, 30.05.2023, 10:10 | Сообщение № 9
Группа: Друзья
Ранг: Обитатель
Сообщений: 385
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
но вообще наверняка можно это сделать проще...


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщениено вообще наверняка можно это сделать проще...

Автор - elovkov
Дата добавления - 30.05.2023 в 10:10
Pelena Дата: Вторник, 30.05.2023, 10:37 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 19242
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
сколько дней в каждом из месяцев производится работа

по формуле Михаила (MCH) (очень компактная)

адаптировала формулу под Вашу задачу
К сообщению приложен файл: 0502812.xlsx (27.8 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
сколько дней в каждом из месяцев производится работа

по формуле Михаила (MCH) (очень компактная)

адаптировала формулу под Вашу задачу

Автор - Pelena
Дата добавления - 30.05.2023 в 10:37
Gustav Дата: Вторник, 30.05.2023, 11:44 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2763
Репутация: 1140 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Не совсем пересечение дат мне нужно))
Я должен понимать, сколько каждая из работ занимает дней в определенном месяце.

Очень жаль, что Вы не увидели в своей задаче серии подзадач на пересечение двух интервалов дат.

И большое спасибо Елене (Pelena), что показала Вам эту серию подзадач на практике в сообщении №10.

Ну, и спасибо мне, что я (как чувствовал!) не ограничился первым предложением "погуглите" и добавил подбробный "p.s." в своем сообщении №3 :)


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
Не совсем пересечение дат мне нужно))
Я должен понимать, сколько каждая из работ занимает дней в определенном месяце.

Очень жаль, что Вы не увидели в своей задаче серии подзадач на пересечение двух интервалов дат.

И большое спасибо Елене (Pelena), что показала Вам эту серию подзадач на практике в сообщении №10.

Ну, и спасибо мне, что я (как чувствовал!) не ограничился первым предложением "погуглите" и добавил подбробный "p.s." в своем сообщении №3 :)

Автор - Gustav
Дата добавления - 30.05.2023 в 11:44
alexa1965 Дата: Вторник, 30.05.2023, 12:52 | Сообщение № 12
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 56 ±
Замечаний: 0% ±

2003> 2019 >2016
Добрый день! Если привести даты месяцев в графике в порядок то решение Елены можно отобразить прямо на графике. И еще в столбце Е надо плюсовать 1. Файл приложил.
К сообщению приложен файл: 1564659.xlsx (42.5 Kb)


Главное не быть балабастиком
 
Ответить
СообщениеДобрый день! Если привести даты месяцев в графике в порядок то решение Елены можно отобразить прямо на графике. И еще в столбце Е надо плюсовать 1. Файл приложил.

Автор - alexa1965
Дата добавления - 30.05.2023 в 12:52
Dend1 Дата: Вторник, 30.05.2023, 13:55 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

2010
ВСе сделал, коллега помог
Код
=ЕСЛИ(И(J$12>=$C15;J$12<=$D15);$F15;"")
 
Ответить
СообщениеВСе сделал, коллега помог
Код
=ЕСЛИ(И(J$12>=$C15;J$12<=$D15);$F15;"")

Автор - Dend1
Дата добавления - 30.05.2023 в 13:55
alexa1965 Дата: Вторник, 30.05.2023, 14:13 | Сообщение № 14
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 56 ±
Замечаний: 0% ±

2003> 2019 >2016
ВСе сделал,
Это вы вытащили стоимость работы в день


Главное не быть балабастиком

Сообщение отредактировал alexa1965 - Вторник, 30.05.2023, 14:15
 
Ответить
Сообщение
ВСе сделал,
Это вы вытащили стоимость работы в день

Автор - alexa1965
Дата добавления - 30.05.2023 в 14:13
Gustav Дата: Вторник, 30.05.2023, 15:10 | Сообщение № 15
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2763
Репутация: 1140 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
=ЕСЛИ(И(J$12>=$C15;J$12<=$D15);$F15;"")

"Круто взнуздано!" (с) если еще расскажете, куда и с какой целью собираетесь поместить эту формулу, будет совсем хорошо :)

"Куда" - видимо, в каждую дневную ячейку. И что потом? СЧЁТЕСЛИ? Покажите, пожалуйста, в файле окончательную картину, которая Вас в итоге устроила, ок?


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
=ЕСЛИ(И(J$12>=$C15;J$12<=$D15);$F15;"")

"Круто взнуздано!" (с) если еще расскажете, куда и с какой целью собираетесь поместить эту формулу, будет совсем хорошо :)

"Куда" - видимо, в каждую дневную ячейку. И что потом? СЧЁТЕСЛИ? Покажите, пожалуйста, в файле окончательную картину, которая Вас в итоге устроила, ок?

Автор - Gustav
Дата добавления - 30.05.2023 в 15:10
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!