Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Схлопнуть строки в одну по двум параметрам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Схлопнуть строки в одну по двум параметрам
segamega Дата: Четверг, 08.06.2023, 18:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Всех приветствую.
Есть отчет по продажам ВБ, там каждый размер разбит по складам.
Как слить/схлопнуть все склады в одну строку? Все действия на второй странице таблицы.

Сам прикинул, нужно две формулы ВПР с условием И, плюс суммирование. Вот как это реализовать, не могу сообразить.
Есть артикул 167805, есть размер 36 и они на трех складах с остатками 1, 1 и 3. Нужно в одну строку суммировать, что бы было 5.
Помогите пожалуйста.
 
Ответить
СообщениеВсех приветствую.
Есть отчет по продажам ВБ, там каждый размер разбит по складам.
Как слить/схлопнуть все склады в одну строку? Все действия на второй странице таблицы.

Сам прикинул, нужно две формулы ВПР с условием И, плюс суммирование. Вот как это реализовать, не могу сообразить.
Есть артикул 167805, есть размер 36 и они на трех складах с остатками 1, 1 и 3. Нужно в одну строку суммировать, что бы было 5.
Помогите пожалуйста.

Автор - segamega
Дата добавления - 08.06.2023 в 18:00
Pelena Дата: Четверг, 08.06.2023, 20:51 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19260
Репутация: 4436 ±
Замечаний: ±

Excel 365 & Mac Excel
Файл с небольшим примером помог бы в понимании проблемы


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеФайл с небольшим примером помог бы в понимании проблемы

Автор - Pelena
Дата добавления - 08.06.2023 в 20:51
elovkov Дата: Пятница, 09.06.2023, 07:37 | Сообщение № 3
Группа: Друзья
Ранг: Обитатель
Сообщений: 394
Репутация: 53 ±
Замечаний: 0% ±

Excel 2013
Что-то вроде если И впр по артикулу И впр по размеру совпадают на первом складе, плюс то же повторить на втором, плюс на третьем
Как-то так без примера)))


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеЧто-то вроде если И впр по артикулу И впр по размеру совпадают на первом складе, плюс то же повторить на втором, плюс на третьем
Как-то так без примера)))

Автор - elovkov
Дата добавления - 09.06.2023 в 07:37
DrMini Дата: Пятница, 09.06.2023, 08:58 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
нужно две формулы ВПР с условием И, плюс суммирование

Как нибудь так.

[offtop]забыл "доллары" поставить[/offtop]
К сообщению приложен файл: 230609.xlsx (9.7 Kb)


Сообщение отредактировал DrMini - Пятница, 09.06.2023, 13:52
 
Ответить
Сообщение
нужно две формулы ВПР с условием И, плюс суммирование

Как нибудь так.

[offtop]забыл "доллары" поставить[/offtop]

Автор - DrMini
Дата добавления - 09.06.2023 в 08:58
DrMini Дата: Пятница, 09.06.2023, 09:20 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Кажется не правильно понял ТС.
Наверное так:
Код
=СУММ(СУММПРОИЗВ(($A$3:$A$8=M3)*($B$3:$B$8=N3)*($C$3:$C$8));СУММПРОИЗВ(($E$3:$E$8=M3)*($F$3:$F$8=N3)*($G$3:$G$8));СУММПРОИЗВ(($I$3:$I$8=M3)*($J$3:$J$8=N3)*($K$3:$K$8)))

или так:
Код
=ИНДЕКС($C$3:$C$8; ПОИСКПОЗ(1; (Q3=$A$3:$A$8)*(R3=$B$3:$B$8); 0))+ИНДЕКС($G$3:$G$8; ПОИСКПОЗ(1; (Q3=$E$3:$E$8)*(R3=$F$3:$F$8); 0))+ИНДЕКС($K$3:$K$8; ПОИСКПОЗ(1; (Q3=$I$3:$I$8)*(R3=$J$3:$J$8); 0))
К сообщению приложен файл: 230609_2.xlsx (10.8 Kb)


Сообщение отредактировал DrMini - Пятница, 09.06.2023, 13:49
 
Ответить
СообщениеКажется не правильно понял ТС.
Наверное так:
Код
=СУММ(СУММПРОИЗВ(($A$3:$A$8=M3)*($B$3:$B$8=N3)*($C$3:$C$8));СУММПРОИЗВ(($E$3:$E$8=M3)*($F$3:$F$8=N3)*($G$3:$G$8));СУММПРОИЗВ(($I$3:$I$8=M3)*($J$3:$J$8=N3)*($K$3:$K$8)))

или так:
Код
=ИНДЕКС($C$3:$C$8; ПОИСКПОЗ(1; (Q3=$A$3:$A$8)*(R3=$B$3:$B$8); 0))+ИНДЕКС($G$3:$G$8; ПОИСКПОЗ(1; (Q3=$E$3:$E$8)*(R3=$F$3:$F$8); 0))+ИНДЕКС($K$3:$K$8; ПОИСКПОЗ(1; (Q3=$I$3:$I$8)*(R3=$J$3:$J$8); 0))

Автор - DrMini
Дата добавления - 09.06.2023 в 09:20
segamega Дата: Пятница, 09.06.2023, 15:26 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Файл с небольшим примером помог бы в понимании проблемы

прикреплял, похоже слетел
дублирую
К сообщению приложен файл: WB.xlsx (13.9 Kb)
 
Ответить
Сообщение
Файл с небольшим примером помог бы в понимании проблемы

прикреплял, похоже слетел
дублирую

Автор - segamega
Дата добавления - 09.06.2023 в 15:26
Pelena Дата: Пятница, 09.06.2023, 16:42 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 19260
Репутация: 4436 ±
Замечаний: ±

Excel 365 & Mac Excel
Вариант со сводной таблицей
К сообщению приложен файл: 6578931.xlsx (20.0 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеВариант со сводной таблицей

Автор - Pelena
Дата добавления - 09.06.2023 в 16:42
segamega Дата: Вторник, 13.06.2023, 15:05 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Вариант со сводной таблицей


Круто, спасибо. Всё работает, но не понятно как ))
Есть где нормальный урок по сводным таблицам?
 
Ответить
Сообщение
Вариант со сводной таблицей


Круто, спасибо. Всё работает, но не понятно как ))
Есть где нормальный урок по сводным таблицам?

Автор - segamega
Дата добавления - 13.06.2023 в 15:05
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!