Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ЕСЛИ (ИЛИ) с несколькими условиями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
ЕСЛИ (ИЛИ) с несколькими условиями
demidova3110 Дата: Суббота, 17.06.2023, 12:36 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2013
1. Как в колонке К настроить формулу (условие), чтобы проверялись следующие параметры:
1) если в колонке А выходной или праздник, то в колонке К должно быть значение из колонки Е;
2) также, если в колонке А НЕ выходной или НЕ праздник, а число из колонки Е>8, то Е24 (например) - $Е$8, а иначе 0

То есть, если сотрудник работал в празник или выходной, то "переработка".
А если сотрудник работал в будни, но кол-во часов >8, то 8 "норма", а дельта "переработка".
Я попробовала в К3, но не получается.
Код
=ЕСЛИ(И(ИЛИ(A3="праздник";A3="выходной");E3;0);ЕСЛИ(И(ИЛИ(A3<>"праздник";A3<>"выходной");E3>8;E3-$E$1);0))


2. связанный вопрос
если сотрудник в один день отработал на 2-х проектах, например, 8 часов на проекте 3, и 2 часа на проекте 4, то можно ли задать условие, чтобы система 8 часов относила на норму, а 2 на переработку и это касается только работы в будни, т.к. выходные и праздники это всегда переработка
К сообщению приложен файл: excel_funkcija_esli_ili_s_nesk.xlsx (18.1 Kb)


Daria

Сообщение отредактировал Serge_007 - Понедельник, 19.06.2023, 09:10
 
Ответить
Сообщение1. Как в колонке К настроить формулу (условие), чтобы проверялись следующие параметры:
1) если в колонке А выходной или праздник, то в колонке К должно быть значение из колонки Е;
2) также, если в колонке А НЕ выходной или НЕ праздник, а число из колонки Е>8, то Е24 (например) - $Е$8, а иначе 0

То есть, если сотрудник работал в празник или выходной, то "переработка".
А если сотрудник работал в будни, но кол-во часов >8, то 8 "норма", а дельта "переработка".
Я попробовала в К3, но не получается.
Код
=ЕСЛИ(И(ИЛИ(A3="праздник";A3="выходной");E3;0);ЕСЛИ(И(ИЛИ(A3<>"праздник";A3<>"выходной");E3>8;E3-$E$1);0))


2. связанный вопрос
если сотрудник в один день отработал на 2-х проектах, например, 8 часов на проекте 3, и 2 часа на проекте 4, то можно ли задать условие, чтобы система 8 часов относила на норму, а 2 на переработку и это касается только работы в будни, т.к. выходные и праздники это всегда переработка

Автор - demidova3110
Дата добавления - 17.06.2023 в 12:36
cmivadwot Дата: Суббота, 17.06.2023, 14:11 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 481
Репутация: 88 ±
Замечаний: 0% ±

365
demidova3110,
Код
=ЕСЛИ(ИЛИ(A3="праздник";A3="выходной");E3;ЕСЛИ(E3>8;E3-$E$1;0))


Сообщение отредактировал cmivadwot - Суббота, 17.06.2023, 14:16
 
Ответить
Сообщениеdemidova3110,
Код
=ЕСЛИ(ИЛИ(A3="праздник";A3="выходной");E3;ЕСЛИ(E3>8;E3-$E$1;0))

Автор - cmivadwot
Дата добавления - 17.06.2023 в 14:11
i691198 Дата: Суббота, 17.06.2023, 14:41 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 237
Репутация: 88 ±
Замечаний: 0% ±

demidova3110, В первом вопросе вы перемудрили с формулой, наверное нужно так (для I3)
Код
=ЕСЛИ(ИЛИ(A3="праздник";A3="выходной");E3;ЕСЛИ(E3>8;E3-$E$1;0))

Второй вопрос формулами сложно решить, лучше это делать макросом.
 
Ответить
Сообщениеdemidova3110, В первом вопросе вы перемудрили с формулой, наверное нужно так (для I3)
Код
=ЕСЛИ(ИЛИ(A3="праздник";A3="выходной");E3;ЕСЛИ(E3>8;E3-$E$1;0))

Второй вопрос формулами сложно решить, лучше это делать макросом.

Автор - i691198
Дата добавления - 17.06.2023 в 14:41
demidova3110 Дата: Суббота, 17.06.2023, 14:47 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2013
i691198, Большое спасибо за помощь!


Daria
 
Ответить
Сообщениеi691198, Большое спасибо за помощь!

Автор - demidova3110
Дата добавления - 17.06.2023 в 14:47
cmivadwot Дата: Суббота, 17.06.2023, 14:50 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 481
Репутация: 88 ±
Замечаний: 0% ±

365
demidova3110, и по 2 вопросу направление...
К сообщению приложен файл: 7462538.xlsx (18.4 Kb)
 
Ответить
Сообщениеdemidova3110, и по 2 вопросу направление...

Автор - cmivadwot
Дата добавления - 17.06.2023 в 14:50
cmivadwot Дата: Суббота, 17.06.2023, 18:28 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 481
Репутация: 88 ±
Замечаний: 0% ±

365
demidova3110, столбец L. переработка по 2 условию ..при условии.. если 1 сотрудник участвует не более чем в 2 проектах за день.... далее надо все сложить в кучу))) чтоб в 1 формуле было..
К сообщению приложен файл: 4860069.xlsx (19.1 Kb)
 
Ответить
Сообщениеdemidova3110, столбец L. переработка по 2 условию ..при условии.. если 1 сотрудник участвует не более чем в 2 проектах за день.... далее надо все сложить в кучу))) чтоб в 1 формуле было..

Автор - cmivadwot
Дата добавления - 17.06.2023 в 18:28
demidova3110 Дата: Суббота, 17.06.2023, 21:30 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2013
Спасибо большое!


Daria
 
Ответить
СообщениеСпасибо большое!

Автор - demidova3110
Дата добавления - 17.06.2023 в 21:30
cmivadwot Дата: Воскресенье, 18.06.2023, 23:22 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 481
Репутация: 88 ±
Замечаний: 0% ±

365
demidova3110, вроде так работает со всеми условиями...
Код
=ЕСЛИ(ИЛИ(A3="праздник";A3="выходной");ЕСЛИ(СУММЕСЛИМН(E:E;F:F;F3;B:B;B3)=СУММЕСЛИМН(E:E;F:F;F4;B:B;B4);ЕСЛИ(И(F4=F3;B3=B4);0;E3);СУММЕСЛИМН(E:E;F:F;F3;B:B;B3));ЕСЛИ(ЕСЛИ(СУММЕСЛИМН(E:E;F:F;F3;B:B;B3)=СУММЕСЛИМН(E:E;F:F;F4;B:B;B4);ЕСЛИ(И(F4=F3;B3=B4);0;E3);СУММЕСЛИМН(E:E;F:F;F3;B:B;B3))>$E$1;ЕСЛИ(СУММЕСЛИМН(E:E;F:F;F3;B:B;B3)=СУММЕСЛИМН(E:E;F:F;F4;B:B;B4);ЕСЛИ(И(F4=F3;B3=B4);0;E3);СУММЕСЛИМН(E:E;F:F;F3;B:B;B3))-$E$1;0))
К сообщению приложен файл: 4860069_1.xlsx (20.7 Kb)
 
Ответить
Сообщениеdemidova3110, вроде так работает со всеми условиями...
Код
=ЕСЛИ(ИЛИ(A3="праздник";A3="выходной");ЕСЛИ(СУММЕСЛИМН(E:E;F:F;F3;B:B;B3)=СУММЕСЛИМН(E:E;F:F;F4;B:B;B4);ЕСЛИ(И(F4=F3;B3=B4);0;E3);СУММЕСЛИМН(E:E;F:F;F3;B:B;B3));ЕСЛИ(ЕСЛИ(СУММЕСЛИМН(E:E;F:F;F3;B:B;B3)=СУММЕСЛИМН(E:E;F:F;F4;B:B;B4);ЕСЛИ(И(F4=F3;B3=B4);0;E3);СУММЕСЛИМН(E:E;F:F;F3;B:B;B3))>$E$1;ЕСЛИ(СУММЕСЛИМН(E:E;F:F;F3;B:B;B3)=СУММЕСЛИМН(E:E;F:F;F4;B:B;B4);ЕСЛИ(И(F4=F3;B3=B4);0;E3);СУММЕСЛИМН(E:E;F:F;F3;B:B;B3))-$E$1;0))

Автор - cmivadwot
Дата добавления - 18.06.2023 в 23:22
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!