Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск предпоследего значения в столбце - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Поиск предпоследего значения в столбце
Alex_kh Дата: Понедельник, 26.06.2023, 21:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

2016
Добрый вечер. Опять к старшим товарищам за помощью) По предпоследнему совпадению в столбце нужно получить значение из массива. Хочу в прогрессе считать доход по менеджеру.
В столбце В необходимо найти предпоследние совпадение, взять значение из E этой строки и прибавить последнее совпадения значение из столбца D. Т.е. по менеджеру Сергей найти предпоследнее значение и из "Суммы в прогрессии" прибавить последнее совпадение по Сергей из "Сумма за месяц". Я так понимаю это должно быть примерно как последняя позиция -1. Но как не крутил не получается собрать формулу. Спасибо.
К сообщению приложен файл: predposlednee_pozicija.xlsx (9.5 Kb)


Сообщение отредактировал Alex_kh - Понедельник, 26.06.2023, 21:04
 
Ответить
СообщениеДобрый вечер. Опять к старшим товарищам за помощью) По предпоследнему совпадению в столбце нужно получить значение из массива. Хочу в прогрессе считать доход по менеджеру.
В столбце В необходимо найти предпоследние совпадение, взять значение из E этой строки и прибавить последнее совпадения значение из столбца D. Т.е. по менеджеру Сергей найти предпоследнее значение и из "Суммы в прогрессии" прибавить последнее совпадение по Сергей из "Сумма за месяц". Я так понимаю это должно быть примерно как последняя позиция -1. Но как не крутил не получается собрать формулу. Спасибо.

Автор - Alex_kh
Дата добавления - 26.06.2023 в 21:03
DrMini Дата: Понедельник, 26.06.2023, 21:38 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Хочу в прогрессе считать доход по менеджеру.

А вот такой вариант не подойдёт?
К сообщению приложен файл: 2391963.xlsx (10.6 Kb)
 
Ответить
Сообщение
Хочу в прогрессе считать доход по менеджеру.

А вот такой вариант не подойдёт?

Автор - DrMini
Дата добавления - 26.06.2023 в 21:38
Alex_kh Дата: Понедельник, 26.06.2023, 21:54 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

2016
Спасибо, но не подходит. Таблица динамическая строки добавляются и необходимо видеть помесячный прогресс. Т.е.через n-строк может быть опять Сергей и нужно считать след. месяц плюс предыдущие значение.


Сообщение отредактировал Alex_kh - Понедельник, 26.06.2023, 21:55
 
Ответить
СообщениеСпасибо, но не подходит. Таблица динамическая строки добавляются и необходимо видеть помесячный прогресс. Т.е.через n-строк может быть опять Сергей и нужно считать след. месяц плюс предыдущие значение.

Автор - Alex_kh
Дата добавления - 26.06.2023 в 21:54
DrMini Дата: Понедельник, 26.06.2023, 21:59 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
нужно считать след. месяц плюс предыдущие значение.

Дык там можно в формуле прописать сколько нужно строк. Я сделал на 24. Надо больше так измените диапазон и всё.
 
Ответить
Сообщение
нужно считать след. месяц плюс предыдущие значение.

Дык там можно в формуле прописать сколько нужно строк. Я сделал на 24. Надо больше так измените диапазон и всё.

Автор - DrMini
Дата добавления - 26.06.2023 в 21:59
msi2102 Дата: Понедельник, 26.06.2023, 22:09 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 414
Репутация: 129 ±
Замечаний: 0% ±

Excel 2007
Как вариант Сводная таблица + срез
Можете ещё почитать про функцию ПРОСМОТРX (XLOOKUP) , в ней поиск можно организовать в обратную сторону, только офис должен быть подходящим
К сообщению приложен файл: 8059858.xlsx (15.1 Kb)


Сообщение отредактировал msi2102 - Понедельник, 26.06.2023, 22:13
 
Ответить
СообщениеКак вариант Сводная таблица + срез
Можете ещё почитать про функцию ПРОСМОТРX (XLOOKUP) , в ней поиск можно организовать в обратную сторону, только офис должен быть подходящим

Автор - msi2102
Дата добавления - 26.06.2023 в 22:09
Alex_kh Дата: Понедельник, 26.06.2023, 22:25 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

2016
ПРОСМОТРX (XLOOKUP)

ПРОСМОТРX (XLOOKUP), по последнему можно, но не предпоследнее. Все должно быть на одном листе.
 
Ответить
Сообщение
ПРОСМОТРX (XLOOKUP)

ПРОСМОТРX (XLOOKUP), по последнему можно, но не предпоследнее. Все должно быть на одном листе.

Автор - Alex_kh
Дата добавления - 26.06.2023 в 22:25
msi2102 Дата: Понедельник, 26.06.2023, 22:37 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 414
Репутация: 129 ±
Замечаний: 0% ±

Excel 2007
Пробуйте так
Код
=СУММЕСЛИ($B$2:B2;B2;$D$2:D2)
К сообщению приложен файл: 1172930.xlsx (15.3 Kb)


Сообщение отредактировал msi2102 - Понедельник, 26.06.2023, 23:03
 
Ответить
СообщениеПробуйте так
Код
=СУММЕСЛИ($B$2:B2;B2;$D$2:D2)

Автор - msi2102
Дата добавления - 26.06.2023 в 22:37
Pelena Дата: Понедельник, 26.06.2023, 22:42 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 19238
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
Вариант
Код
=СУММ(ЕСЛИОШИБКА(ПРОСМОТР(;-1/($B$1:B1=B2);$E$1:E1);0);D2)
К сообщению приложен файл: 6810845.xlsx (10.6 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеВариант
Код
=СУММ(ЕСЛИОШИБКА(ПРОСМОТР(;-1/($B$1:B1=B2);$E$1:E1);0);D2)

Автор - Pelena
Дата добавления - 26.06.2023 в 22:42
DrMini Дата: Вторник, 27.06.2023, 04:25 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Таблица динамическая строки добавляются и необходимо видеть помесячный прогресс.

Вчерашняя формула из сообщения №2 — чуть изменённая + умная таблица.
Код
=ЕСЛИ(B2="";"";СУММЕСЛИ($B$2:$B2;B2;$D$2:$D2))
К сообщению приложен файл: 230627.xlsx (11.4 Kb)


Сообщение отредактировал DrMini - Вторник, 27.06.2023, 05:09
 
Ответить
Сообщение
Таблица динамическая строки добавляются и необходимо видеть помесячный прогресс.

Вчерашняя формула из сообщения №2 — чуть изменённая + умная таблица.
Код
=ЕСЛИ(B2="";"";СУММЕСЛИ($B$2:$B2;B2;$D$2:$D2))

Автор - DrMini
Дата добавления - 27.06.2023 в 04:25
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!