Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проставить нумерацию строк снизу вверх (по блокам) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Проставить нумерацию строк снизу вверх (по блокам)
SG7420 Дата: Четверг, 29.06.2023, 16:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2019
Подскажите, как или какую формулу нужно прописать чтобы пронумеровать позиции (столбец D), с учётом что нумерация по позиции идет снизу вверх? В настоящий момент все приходится делать в ручную, а таких позиций на деле 1000...Голубым выделил как должно выглядеть


Сообщение отредактировал SG7420 - Четверг, 29.06.2023, 16:29
 
Ответить
СообщениеПодскажите, как или какую формулу нужно прописать чтобы пронумеровать позиции (столбец D), с учётом что нумерация по позиции идет снизу вверх? В настоящий момент все приходится делать в ручную, а таких позиций на деле 1000...Голубым выделил как должно выглядеть

Автор - SG7420
Дата добавления - 29.06.2023 в 16:10
Nic70y Дата: Четверг, 29.06.2023, 16:18 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8831
Репутация: 2300 ±
Замечаний: 0% ±

Excel 2010
так
Код
=ЕСЛИ(A2<>A1;"";ПОИСКПОЗ(A2;A:A)-СТРОКА(A1))
наверно
К сообщению приложен файл: 0746207.xlsx (12.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениетак
Код
=ЕСЛИ(A2<>A1;"";ПОИСКПОЗ(A2;A:A)-СТРОКА(A1))
наверно

Автор - Nic70y
Дата добавления - 29.06.2023 в 16:18
SG7420 Дата: Четверг, 29.06.2023, 16:28 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2019
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - SG7420
Дата добавления - 29.06.2023 в 16:28
Serge_007 Дата: Четверг, 29.06.2023, 16:48 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Ещё вариант:
Код
=СУММПРОИЗВ((C2&A2=C2:C$61&A2:A$61)*(C2<>""))
К сообщению приложен файл: 20230629_sg7420.xls (42.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЕщё вариант:
Код
=СУММПРОИЗВ((C2&A2=C2:C$61&A2:A$61)*(C2<>""))

Автор - Serge_007
Дата добавления - 29.06.2023 в 16:48
Egyptian Дата: Пятница, 30.06.2023, 00:31 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 515
Репутация: 186 ±
Замечаний: 0% ±

Excel 2013/2016
В С2 и вниз.
Нули спрятать пользовательским форматом ;;;
Код
=SUMPRODUCT(COUNTIFS(A2;A2:A$100;C2;C2:C$100))

или можно так:
Код
=TEXT(SUMPRODUCT(COUNTIFS(A2;A2:A$100;C2;C2:C$100));"0;-0;;@")
 
Ответить
СообщениеВ С2 и вниз.
Нули спрятать пользовательским форматом ;;;
Код
=SUMPRODUCT(COUNTIFS(A2;A2:A$100;C2;C2:C$100))

или можно так:
Код
=TEXT(SUMPRODUCT(COUNTIFS(A2;A2:A$100;C2;C2:C$100));"0;-0;;@")

Автор - Egyptian
Дата добавления - 30.06.2023 в 00:31
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!