Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Впр по части текста - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Впр по части текста
NPS50 Дата: Понедельник, 03.07.2023, 03:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!

Можно ли с помощью впр или других функций , вытащить из таблицы значения ячеек ,которые содержат определенную часть текста? (соль в том что столбцов слишком много)

Сорри если вопрос был, ответ не нашел
К сообщению приложен файл: 6118608.xlsx (8.3 Kb)
 
Ответить
СообщениеДобрый день!

Можно ли с помощью впр или других функций , вытащить из таблицы значения ячеек ,которые содержат определенную часть текста? (соль в том что столбцов слишком много)

Сорри если вопрос был, ответ не нашел

Автор - NPS50
Дата добавления - 03.07.2023 в 03:46
Nic70y Дата: Понедельник, 03.07.2023, 07:46 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8857
Репутация: 2308 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$1:H$6;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(F$13;C$3:H$6));СТОЛБЕЦ(C$3:H$6)+СТРОКА(C$3:H$6)/1000);E15);1)*1000;);НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(F$13;C$3:H$6));СТОЛБЕЦ(C$3:H$6));E15));"")
К сообщению приложен файл: 6365803.xlsx (8.9 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеформула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$1:H$6;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(F$13;C$3:H$6));СТОЛБЕЦ(C$3:H$6)+СТРОКА(C$3:H$6)/1000);E15);1)*1000;);НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(F$13;C$3:H$6));СТОЛБЕЦ(C$3:H$6));E15));"")

Автор - Nic70y
Дата добавления - 03.07.2023 в 07:46
Pelena Дата: Понедельник, 03.07.2023, 08:30 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 19262
Репутация: 4436 ±
Замечаний: ±

Excel 365 & Mac Excel
Для новых версий Excel
Код
=ФИЛЬТР(ПОСТОЛБЦ(C3:H6;1;1);ЕЧИСЛО(ПОИСК(F13;ПОСТОЛБЦ(C3:H6;1;1))))
К сообщению приложен файл: 2298813.xlsx (9.8 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеДля новых версий Excel
Код
=ФИЛЬТР(ПОСТОЛБЦ(C3:H6;1;1);ЕЧИСЛО(ПОИСК(F13;ПОСТОЛБЦ(C3:H6;1;1))))

Автор - Pelena
Дата добавления - 03.07.2023 в 08:30
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!