Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Простой автотранспорта - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Простой автотранспорта
Liza9314 Дата: Вторник, 04.07.2023, 13:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, форумчане. Помогите, пожалуйста, с формулой простоев.
Есть Транспорт, есть дата начала и окончания ездки. В разрывах между датами рейсов надо узнать сколько дней был простой и получить дату начала простоя и окончания. Автомобили разные, у каждой своя дата ездки.
Пример прикрепляю.
Формула в примере не учитывает конец месяца, например:
Если машина(833-в примере) ездила с 11.05.2023 по 19.05.2023, а потом выехала в следующий рейс с 19.05.2023 по 05.06.2023,то количество дней простоев-24,но дата простоя ставится с 25.04.2023 по 18.05.2023, хотя должно быть с 06.06.2023 по 30.06.2023, возможно можно формулу улучшить/исправить, чтобы по машине показывало корректное кол-во простоя и даты начала и окончания простоя.
Заранее спасибо!
К сообщению приложен файл: tabel_prostoev_primer.xlsx (48.7 Kb)
 
Ответить
СообщениеДобрый день, форумчане. Помогите, пожалуйста, с формулой простоев.
Есть Транспорт, есть дата начала и окончания ездки. В разрывах между датами рейсов надо узнать сколько дней был простой и получить дату начала простоя и окончания. Автомобили разные, у каждой своя дата ездки.
Пример прикрепляю.
Формула в примере не учитывает конец месяца, например:
Если машина(833-в примере) ездила с 11.05.2023 по 19.05.2023, а потом выехала в следующий рейс с 19.05.2023 по 05.06.2023,то количество дней простоев-24,но дата простоя ставится с 25.04.2023 по 18.05.2023, хотя должно быть с 06.06.2023 по 30.06.2023, возможно можно формулу улучшить/исправить, чтобы по машине показывало корректное кол-во простоя и даты начала и окончания простоя.
Заранее спасибо!

Автор - Liza9314
Дата добавления - 04.07.2023 в 13:06
alexa1965 Дата: Вторник, 04.07.2023, 14:40 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 347
Репутация: 56 ±
Замечаний: 0% ±

2003> 2019 >2016
Не знаю, как понял для ячейки G3
Код
=ЕСЛИ(F3>0;C2+1;0)
и протянуть вниз, для ячейки Н3
Код
=ЕСЛИ(F3=0;0;G3+F3)
и тоже протянуть


Главное не быть балабастиком

Сообщение отредактировал alexa1965 - Вторник, 04.07.2023, 14:41
 
Ответить
СообщениеНе знаю, как понял для ячейки G3
Код
=ЕСЛИ(F3>0;C2+1;0)
и протянуть вниз, для ячейки Н3
Код
=ЕСЛИ(F3=0;0;G3+F3)
и тоже протянуть

Автор - alexa1965
Дата добавления - 04.07.2023 в 14:40
Liza9314 Дата: Вторник, 04.07.2023, 15:00 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

alexa1965, не то, но спасибо за попытку) формула не вытягивает фактическую дату простоя в примере автомобиля 833, она аналогична уже имеющейся, а мне надо, чтобы дата простоя отражалась корректно, то есть этот автомобиль закончил свою последнюю ездку в квартале 05.06. значит с 06.06 по 30.06 даты простоя по этому автомобилю. То есть надо учитывать дату конца ездки автомобиля и дату конца квартала, а формула отматывает назад.
 
Ответить
Сообщениеalexa1965, не то, но спасибо за попытку) формула не вытягивает фактическую дату простоя в примере автомобиля 833, она аналогична уже имеющейся, а мне надо, чтобы дата простоя отражалась корректно, то есть этот автомобиль закончил свою последнюю ездку в квартале 05.06. значит с 06.06 по 30.06 даты простоя по этому автомобилю. То есть надо учитывать дату конца ездки автомобиля и дату конца квартала, а формула отматывает назад.

Автор - Liza9314
Дата добавления - 04.07.2023 в 15:00
Liza9314 Дата: Вторник, 04.07.2023, 16:47 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Вопрос решен. Нашла выход.
 
Ответить
СообщениеВопрос решен. Нашла выход.

Автор - Liza9314
Дата добавления - 04.07.2023 в 16:47
DrMini Дата: Вторник, 04.07.2023, 20:25 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Нашла выход

Если не трудно — выложите здесь Ваш вариант решения проблемы. Вдруг кому пригодится.
 
Ответить
Сообщение
Нашла выход

Если не трудно — выложите здесь Ваш вариант решения проблемы. Вдруг кому пригодится.

Автор - DrMini
Дата добавления - 04.07.2023 в 20:25
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!