Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/расчёт переработок с разл. коэфф. для расчета ЗП - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
расчёт переработок с разл. коэфф. для расчета ЗП
demidova3110 Дата: Среда, 05.07.2023, 17:40 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2013
Здравствуйте!

Подскажите, пожалуйста, как в эксель автоматизировать расчёт переработок с различными коэфф. для корректного расчета ЗП. Например, в будни сотрудник отработал 10 часов, то 8 - норма, 2 переработка с коэф.1,25, а если в будни отработал 12 часов, то 8 - норма, 2 переработка с коэф.1,25, а ещё 2 переработка с коэф. 1,5, а в вс. и праздники коэф.2.
Файл прикладываю (интересует автоматизация в ячейках AV, AW, AX).

Большое спасибо за помощь!
К сообщению приложен файл: raschjot_pererabotki_dlja_oper.xlsx (70.6 Kb)


Daria
 
Ответить
СообщениеЗдравствуйте!

Подскажите, пожалуйста, как в эксель автоматизировать расчёт переработок с различными коэфф. для корректного расчета ЗП. Например, в будни сотрудник отработал 10 часов, то 8 - норма, 2 переработка с коэф.1,25, а если в будни отработал 12 часов, то 8 - норма, 2 переработка с коэф.1,25, а ещё 2 переработка с коэф. 1,5, а в вс. и праздники коэф.2.
Файл прикладываю (интересует автоматизация в ячейках AV, AW, AX).

Большое спасибо за помощь!

Автор - demidova3110
Дата добавления - 05.07.2023 в 17:40
elovkov Дата: Четверг, 06.07.2023, 08:16 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте,
Для AV,
Код
=СУММЕСЛИМН(C8:AR8;C$6:AR$6;"";C8:AR8;"<=10";C8:AR8;">8")-СЧЁТЕСЛИМН(C$6:AR$6;"";C8:AR8;"<=10";C8:AR8;">8")*8

AW,
Код
=СУММЕСЛИМН(C8:AR8;C$6:AR$6;"";C8:AR8;">10")-СЧЁТЕСЛИМН(C$6:AR$6;"";C8:AR8;">10")*10

AX
Код
=СУММЕСЛИ(C$6:AR$6;"выходной";C8:AR8)+СУММЕСЛИ(C$6:AR$6;"праздник";C8:AR8)

Наверняка можно короче, но так тоже работает вроде)
К сообщению приложен файл: 3575491.xlsx (68.9 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Четверг, 06.07.2023, 08:33
 
Ответить
СообщениеЗдравствуйте,
Для AV,
Код
=СУММЕСЛИМН(C8:AR8;C$6:AR$6;"";C8:AR8;"<=10";C8:AR8;">8")-СЧЁТЕСЛИМН(C$6:AR$6;"";C8:AR8;"<=10";C8:AR8;">8")*8

AW,
Код
=СУММЕСЛИМН(C8:AR8;C$6:AR$6;"";C8:AR8;">10")-СЧЁТЕСЛИМН(C$6:AR$6;"";C8:AR8;">10")*10

AX
Код
=СУММЕСЛИ(C$6:AR$6;"выходной";C8:AR8)+СУММЕСЛИ(C$6:AR$6;"праздник";C8:AR8)

Наверняка можно короче, но так тоже работает вроде)

Автор - elovkov
Дата добавления - 06.07.2023 в 08:16
demidova3110 Дата: Четверг, 06.07.2023, 10:35 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2013
Здравствуйте!
Огромное спасибо за помощь!
У меня небольшой вопрос по AV - если считать в ручном режиме, то с коэф.1,25 получается 30 часов, а в файле всего 4. По AW и AX все корректно работает)
Посмотрите, пожалуйста.
К сообщению приложен файл: kniga3.xlsx (70.1 Kb)


Daria
 
Ответить
СообщениеЗдравствуйте!
Огромное спасибо за помощь!
У меня небольшой вопрос по AV - если считать в ручном режиме, то с коэф.1,25 получается 30 часов, а в файле всего 4. По AW и AX все корректно работает)
Посмотрите, пожалуйста.

Автор - demidova3110
Дата добавления - 06.07.2023 в 10:35
elovkov Дата: Четверг, 06.07.2023, 10:37 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Да, уже сам заметил, получается что у меня там где больше 10, 2 часа от 8 до 10 не учитываются, сейчас поправлю


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеДа, уже сам заметил, получается что у меня там где больше 10, 2 часа от 8 до 10 не учитываются, сейчас поправлю

Автор - elovkov
Дата добавления - 06.07.2023 в 10:37
elovkov Дата: Четверг, 06.07.2023, 10:40 | Сообщение № 5
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
вот так
Код
=СУММЕСЛИМН(C8:AR8;$C$6:$AR$6;"";C8:AR8;"<=10";C8:AR8;">8")-СЧЁТЕСЛИМН($C$6:$AR$6;"";C8:AR8;"<=10";C8:AR8;">8")*8+СЧЁТЕСЛИМН(C$6:AR$6;"";C8:AR8;">10")*2


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщениевот так
Код
=СУММЕСЛИМН(C8:AR8;$C$6:$AR$6;"";C8:AR8;"<=10";C8:AR8;">8")-СЧЁТЕСЛИМН($C$6:$AR$6;"";C8:AR8;"<=10";C8:AR8;">8")*8+СЧЁТЕСЛИМН(C$6:AR$6;"";C8:AR8;">10")*2

Автор - elovkov
Дата добавления - 06.07.2023 в 10:40
elovkov Дата: Четверг, 06.07.2023, 10:46 | Сообщение № 6
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Теперь AY 166 получается, так как 05.06 6 часов только отработал человек, то что он недоработал где-то как-то учесть надо
К сообщению приложен файл: 4486008.xlsx (69.3 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Четверг, 06.07.2023, 10:47
 
Ответить
СообщениеТеперь AY 166 получается, так как 05.06 6 часов только отработал человек, то что он недоработал где-то как-то учесть надо

Автор - elovkov
Дата добавления - 06.07.2023 в 10:46
demidova3110 Дата: Четверг, 06.07.2023, 11:13 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2013
Огромное спасибо! А мне кажется 6 часов просто должны идти в норму и всё, ну просто человек отработал не 8, а 6. Или я неправильно понимаю?


Daria
 
Ответить
СообщениеОгромное спасибо! А мне кажется 6 часов просто должны идти в норму и всё, ну просто человек отработал не 8, а 6. Или я неправильно понимаю?

Автор - demidova3110
Дата добавления - 06.07.2023 в 11:13
elovkov Дата: Четверг, 06.07.2023, 11:33 | Сообщение № 8
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Ну просто он нормативных 2 часа не доработал, их наверное из переработки вычесть, или оклад начислить на 166/168
Тут как в организации заведено


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеНу просто он нормативных 2 часа не доработал, их наверное из переработки вычесть, или оклад начислить на 166/168
Тут как в организации заведено

Автор - elovkov
Дата добавления - 06.07.2023 в 11:33
elovkov Дата: Четверг, 06.07.2023, 11:52 | Сообщение № 9
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
У Вас, кстати, в BF вот такой расчет
Код
СУММ(AV8*AV7+AW8*AW7+AX8*AX7)*BE8/$AV$2*2

получается Вы суммируете часы переработки помноженные на повышающий коэффицинет, потом умножаете на часовую ставку (BE8/$AV$2), а потом еще раз на 2 умножаете, мне кажется перебор)
и проверка ЕСЛИ>0 тут не нужна, можно просто ограничиться этой формулой


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Четверг, 06.07.2023, 11:56
 
Ответить
СообщениеУ Вас, кстати, в BF вот такой расчет
Код
СУММ(AV8*AV7+AW8*AW7+AX8*AX7)*BE8/$AV$2*2

получается Вы суммируете часы переработки помноженные на повышающий коэффицинет, потом умножаете на часовую ставку (BE8/$AV$2), а потом еще раз на 2 умножаете, мне кажется перебор)
и проверка ЕСЛИ>0 тут не нужна, можно просто ограничиться этой формулой

Автор - elovkov
Дата добавления - 06.07.2023 в 11:52
demidova3110 Дата: Четверг, 06.07.2023, 11:56 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2013
ой, согласна с Вами - перебор), конечно, умножать на 2 не надо, уже же всё с коэф.


Daria
 
Ответить
Сообщениеой, согласна с Вами - перебор), конечно, умножать на 2 не надо, уже же всё с коэф.

Автор - demidova3110
Дата добавления - 06.07.2023 в 11:56
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!