Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка по нескольким критериям, как из базы данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по нескольким критериям, как из базы данных (Формулы/Formulas)
Выборка по нескольким критериям, как из базы данных
supercelt Дата: Четверг, 20.07.2023, 20:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Помогите пожалуйста. Файл приложил. Нужно в ячейку D19 вынуть результат по критериям левее из таблицы выше.
То есть дано название - строчка 11, цикл 2, процент 60. Циклы находятся в первой строке, проценты в третьей. Покрасил жёлтым то что надо вынуть. И рядом со значением уже отдельной формулой получить адрес ячейки исходя из тех же критериев, то есть результат должен быть O14.
К сообщению приложен файл: kniga1.xlsx (11.3 Kb)
 
Ответить
СообщениеДобрый день! Помогите пожалуйста. Файл приложил. Нужно в ячейку D19 вынуть результат по критериям левее из таблицы выше.
То есть дано название - строчка 11, цикл 2, процент 60. Циклы находятся в первой строке, проценты в третьей. Покрасил жёлтым то что надо вынуть. И рядом со значением уже отдельной формулой получить адрес ячейки исходя из тех же критериев, то есть результат должен быть O14.

Автор - supercelt
Дата добавления - 20.07.2023 в 20:54
Egyptian Дата: Четверг, 20.07.2023, 21:11 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 514
Репутация: 185 ±
Замечаний: 0% ±

Excel 2013/2016
Такой вариант.
Результат
Код
=INDEX($H$4:$O$14;MATCH($A$19;$A$4:$A$14;);MATCH(1;INDEX(($B$19=$H$1:$O$1)*($C$19=$H$3:$O$3););))

или
Код
=VLOOKUP($A$19;$A$4:$O$14;MATCH(1;INDEX(($B$19=$A$1:$O$1)*($C$19=$A$3:$O$3);););0)

Адрес:
Код
=ADDRESS(MATCH($A$19;$A:$A;);MATCH(1;INDEX(($B$19=$1:$1)*($C$19=$3:$3);););4)
К сообщению приложен файл: 0431536.xlsx (11.5 Kb)
 
Ответить
СообщениеТакой вариант.
Результат
Код
=INDEX($H$4:$O$14;MATCH($A$19;$A$4:$A$14;);MATCH(1;INDEX(($B$19=$H$1:$O$1)*($C$19=$H$3:$O$3););))

или
Код
=VLOOKUP($A$19;$A$4:$O$14;MATCH(1;INDEX(($B$19=$A$1:$O$1)*($C$19=$A$3:$O$3);););0)

Адрес:
Код
=ADDRESS(MATCH($A$19;$A:$A;);MATCH(1;INDEX(($B$19=$1:$1)*($C$19=$3:$3);););4)

Автор - Egyptian
Дата добавления - 20.07.2023 в 21:11
supercelt Дата: Четверг, 20.07.2023, 21:26 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое!
 
Ответить
СообщениеСпасибо большое!

Автор - supercelt
Дата добавления - 20.07.2023 в 21:26
i691198 Дата: Четверг, 20.07.2023, 21:30 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 85 ±
Замечаний: 0% ±

Здравствуйте.
для D19
Код
=ВПР(A19;A4:O14;ПОИСКПОЗ(B19&C19;A1:O1&A3:O3;0);0)

для E10
Код
=АДРЕС(ПОИСКПОЗ(A19;A1:A14;0);ПОИСКПОЗ(B19&C19;A1:O1&A3:O3;0);4)

Обе формулы массивные.
К сообщению приложен файл: kniga2.xlsx (11.4 Kb)
 
Ответить
СообщениеЗдравствуйте.
для D19
Код
=ВПР(A19;A4:O14;ПОИСКПОЗ(B19&C19;A1:O1&A3:O3;0);0)

для E10
Код
=АДРЕС(ПОИСКПОЗ(A19;A1:A14;0);ПОИСКПОЗ(B19&C19;A1:O1&A3:O3;0);4)

Обе формулы массивные.

Автор - i691198
Дата добавления - 20.07.2023 в 21:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по нескольким критериям, как из базы данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!