Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Зависимость одной ячейки с числом от другой ячейки с текстом - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Зависимость одной ячейки с числом от другой ячейки с текстом
Игорь_Ванюшин Дата: Четверг, 27.07.2023, 15:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 40% ±

2016
Доброго дня форумчане.
Есть задача понять и написать формулу "зависимость одной числовой ячейки, от другой текстовой ячейки". При изменении ячейки с текстом ( там простой выпадающий список) в другой ячейке меняются числа, и при этом сама ячейка с числом также зависит от числа в соседней ячейке.

Словами: Есть закупочная стоимость материала (С2) и чтобы получить продажную стоимость (D2), нужно закупочную стоимость материала умножить на коэффициент надбавки (С2*B2). При этом коэффициент надбавки зависит напрямую от закупочной стоимости материала ( если закупка менее 100 рублей, то коэф.=2.5, а если более 100р, то коэф=1.6)
Тут разобрался сам по коэффициентам:
Код
=ЕСЛИ(C2>100;"1,6";ЕСЛИ(C2<=100;"2,5"))

Но тут появляется новая вводная: коэффициенты надбавки тоже нужно менять в зависимости от того, кто покупает материал. Создал выпадающий список A8, в котором есть возможность выбрать покупателя, а в столбцах I2:J4 есть данные по соответствующим коэффициентам.
Вопрос: как при смене покупателя в ячейке A8, автоматом менялись коэф. в ячейке B2, B3....?

Что-то подобное
Код
B2= Если А8 "Дилер", то B2 "1,3" ( при условии С2>100) или B2 "2" (при условии С2<100); Если А8 "ООО "Атмосфера"
..... и так далее
К сообщению приложен файл: zamena_chislovogo_znachenija_p.xlsx (10.9 Kb)


Истина где-то рядом

Сообщение отредактировал Serge_007 - Четверг, 27.07.2023, 15:47
 
Ответить
СообщениеДоброго дня форумчане.
Есть задача понять и написать формулу "зависимость одной числовой ячейки, от другой текстовой ячейки". При изменении ячейки с текстом ( там простой выпадающий список) в другой ячейке меняются числа, и при этом сама ячейка с числом также зависит от числа в соседней ячейке.

Словами: Есть закупочная стоимость материала (С2) и чтобы получить продажную стоимость (D2), нужно закупочную стоимость материала умножить на коэффициент надбавки (С2*B2). При этом коэффициент надбавки зависит напрямую от закупочной стоимости материала ( если закупка менее 100 рублей, то коэф.=2.5, а если более 100р, то коэф=1.6)
Тут разобрался сам по коэффициентам:
Код
=ЕСЛИ(C2>100;"1,6";ЕСЛИ(C2<=100;"2,5"))

Но тут появляется новая вводная: коэффициенты надбавки тоже нужно менять в зависимости от того, кто покупает материал. Создал выпадающий список A8, в котором есть возможность выбрать покупателя, а в столбцах I2:J4 есть данные по соответствующим коэффициентам.
Вопрос: как при смене покупателя в ячейке A8, автоматом менялись коэф. в ячейке B2, B3....?

Что-то подобное
Код
B2= Если А8 "Дилер", то B2 "1,3" ( при условии С2>100) или B2 "2" (при условии С2<100); Если А8 "ООО "Атмосфера"
..... и так далее

Автор - Игорь_Ванюшин
Дата добавления - 27.07.2023 в 15:31
Serge_007 Дата: Четверг, 27.07.2023, 15:44 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Здравствуйте

Код
=ВПР(A$8;G$2:J$4;(C2<=100)+3;)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ВПР(A$8;G$2:J$4;(C2<=100)+3;)

Автор - Serge_007
Дата добавления - 27.07.2023 в 15:44
Игорь_Ванюшин Дата: Четверг, 27.07.2023, 16:33 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 40% ±

2016
Огромное спасибо за помощь. Всё работает.


Истина где-то рядом

Сообщение отредактировал Serge_007 - Четверг, 27.07.2023, 16:40
 
Ответить
СообщениеОгромное спасибо за помощь. Всё работает.

Автор - Игорь_Ванюшин
Дата добавления - 27.07.2023 в 16:33
elovkov Дата: Четверг, 27.07.2023, 16:51 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Цитата Игорь_Ванюшин, 27.07.2023 в 15:31, в сообщении № 1 ()
Тут разобрался сам по коэффициентам:

Тут можно несколько упростить
Код
=ЕСЛИ(C2>100;"1,6";"2,5")


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
Цитата Игорь_Ванюшин, 27.07.2023 в 15:31, в сообщении № 1 ()
Тут разобрался сам по коэффициентам:

Тут можно несколько упростить
Код
=ЕСЛИ(C2>100;"1,6";"2,5")

Автор - elovkov
Дата добавления - 27.07.2023 в 16:51
Serge_007 Дата: Четверг, 27.07.2023, 17:13 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Кавычки лишние ;)

упростить
Код
=(C2<=100)*0,9+1,6


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеКавычки лишние ;)

упростить
Код
=(C2<=100)*0,9+1,6

Автор - Serge_007
Дата добавления - 27.07.2023 в 17:13
elovkov Дата: Пятница, 28.07.2023, 08:09 | Сообщение № 6
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Кавычки лишние

Ну а может специально надо человеку чтобы текст был)))

Код
=(C2<=100)*0,9+1,6

Ну это уже по-профивски упрощение)))


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
Кавычки лишние

Ну а может специально надо человеку чтобы текст был)))

Код
=(C2<=100)*0,9+1,6

Ну это уже по-профивски упрощение)))

Автор - elovkov
Дата добавления - 28.07.2023 в 08:09
Serge_007 Дата: Пятница, 28.07.2023, 09:03 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
может специально надо человеку чтобы текст был)
Ну да, а потом этот текст в другой формуле как числа используется :D


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
может специально надо человеку чтобы текст был)
Ну да, а потом этот текст в другой формуле как числа используется :D

Автор - Serge_007
Дата добавления - 28.07.2023 в 09:03
Игорь_Ванюшин Дата: Среда, 16.08.2023, 13:30 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 40% ±

2016
Ну да, а потом этот текст в другой формуле как числа используется

Добрый день. Нужна еще раз Ваша помощь.
По итогу добавили еще одну вводную в формулу:

Если ранее было, что от текста в ячейке А8, менялись коэффициенты в столбце В ( менее 100р, то один коэф.. если более 100р, то другой)
Код
B2= Если А8 "Дилер", то B2 "1,3" ( при условии С2>100) или B2 "2" (при условии С2<100); Если А8 "ООО "Атмосфера" и тд.


То теперь нужно, чтобы было 3 разных коэффициента при сумме до 100р, от 101 до 500р, от 501 и выше...
Код
B2= Если А8 "Дилер", то B2 "3" ( при условии С2>100) или B2 "2" (при условии С2<101 до 500) или B2 "1,3" (при условии С2<501) ; Если А8 "ООО "Атмосфера" и тд.


Заранее спасибо большое
К сообщению приложен файл: 3863561.xlsx (11.1 Kb)


Истина где-то рядом

Сообщение отредактировал Игорь_Ванюшин - Среда, 16.08.2023, 14:59
 
Ответить
Сообщение
Ну да, а потом этот текст в другой формуле как числа используется

Добрый день. Нужна еще раз Ваша помощь.
По итогу добавили еще одну вводную в формулу:

Если ранее было, что от текста в ячейке А8, менялись коэффициенты в столбце В ( менее 100р, то один коэф.. если более 100р, то другой)
Код
B2= Если А8 "Дилер", то B2 "1,3" ( при условии С2>100) или B2 "2" (при условии С2<100); Если А8 "ООО "Атмосфера" и тд.


То теперь нужно, чтобы было 3 разных коэффициента при сумме до 100р, от 101 до 500р, от 501 и выше...
Код
B2= Если А8 "Дилер", то B2 "3" ( при условии С2>100) или B2 "2" (при условии С2<101 до 500) или B2 "1,3" (при условии С2<501) ; Если А8 "ООО "Атмосфера" и тд.


Заранее спасибо большое

Автор - Игорь_Ванюшин
Дата добавления - 16.08.2023 в 13:30
Serge_007 Дата: Среда, 16.08.2023, 16:17 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Цитата Игорь_Ванюшин, 16.08.2023 в 13:30, в сообщении № 8 ()
до 100р, от 101
100,5 куда относить?

Код
=ВПР(A$8;G$2:K$4;ПОИСКПОЗ(C2;{0:100:500})+2)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Цитата Игорь_Ванюшин, 16.08.2023 в 13:30, в сообщении № 8 ()
до 100р, от 101
100,5 куда относить?

Код
=ВПР(A$8;G$2:K$4;ПОИСКПОЗ(C2;{0:100:500})+2)

Автор - Serge_007
Дата добавления - 16.08.2023 в 16:17
Игорь_Ванюшин Дата: Среда, 16.08.2023, 17:46 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 40% ±

2016
100,5 куда относить?


логичный вопрос))- спасибо. до 100, от 100 до 500, от 500 и выше : так наверное правильнее будет


Истина где-то рядом
 
Ответить
Сообщение
100,5 куда относить?


логичный вопрос))- спасибо. до 100, от 100 до 500, от 500 и выше : так наверное правильнее будет

Автор - Игорь_Ванюшин
Дата добавления - 16.08.2023 в 17:46
Игорь_Ванюшин Дата: Среда, 16.08.2023, 17:48 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 40% ±

2016
Спасибо большое, всё работает.


Истина где-то рядом

Сообщение отредактировал Serge_007 - Среда, 16.08.2023, 17:54
 
Ответить
СообщениеСпасибо большое, всё работает.

Автор - Игорь_Ванюшин
Дата добавления - 16.08.2023 в 17:48
Игорь_Ванюшин Дата: Четверг, 24.08.2023, 13:04 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 40% ±

2016
Всё понял. Создал тему отдельную на поставленный вопрос. Спасибо


Истина где-то рядом

Сообщение отредактировал Игорь_Ванюшин - Четверг, 24.08.2023, 13:41
 
Ответить
СообщениеВсё понял. Создал тему отдельную на поставленный вопрос. Спасибо

Автор - Игорь_Ванюшин
Дата добавления - 24.08.2023 в 13:04
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!