Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Авторейтинг в ячейках исходя из веса и направления - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Авторейтинг в ячейках исходя из веса и направления
vv@maxflightpro Дата: Пятница, 28.07.2023, 19:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

3
Добрый день уважаемые участники форума,

Передо мной такая задача:

Есть направления (столбец B), куда отправляются грузы, есть вес груза (столбец Е), есть тариф (Столбец F)
Тариф определяется исходя из направления и исходя из веса (Разбивка по весу такая: 100 кг+, 500 кг+, 1000 кг+)
Каким образом я могу использовать данные из таблицы с тарифами, чтобы тариф автоматически определялся и указывался в столбце F исходя из указанного направления столбец В и веса в столбце E?

Таблица с тарифами находится на этом же листе


Основная таблица


Спасибо за ваши советы
К сообщению приложен файл: REPORT.xlsx (10.5 Kb)


Сообщение отредактировал vv@maxflightpro - Пятница, 28.07.2023, 20:22
 
Ответить
СообщениеДобрый день уважаемые участники форума,

Передо мной такая задача:

Есть направления (столбец B), куда отправляются грузы, есть вес груза (столбец Е), есть тариф (Столбец F)
Тариф определяется исходя из направления и исходя из веса (Разбивка по весу такая: 100 кг+, 500 кг+, 1000 кг+)
Каким образом я могу использовать данные из таблицы с тарифами, чтобы тариф автоматически определялся и указывался в столбце F исходя из указанного направления столбец В и веса в столбце E?

Таблица с тарифами находится на этом же листе


Основная таблица


Спасибо за ваши советы

Автор - vv@maxflightpro
Дата добавления - 28.07.2023 в 19:47
прохожий2019 Дата: Пятница, 28.07.2023, 20:10 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1263
Репутация: 321 ±
Замечаний: 0% ±

365 Beta Channel
Цитата vv@maxflightpro, 28.07.2023 в 19:47, в сообщении № 1 ()
Каким образом я могу использовать данные из таблицы с тарифами
уберите в ней плюсы и пользуйтесь связкой ИНДЕКС+ПОИСКПОЗ
 
Ответить
Сообщение
Цитата vv@maxflightpro, 28.07.2023 в 19:47, в сообщении № 1 ()
Каким образом я могу использовать данные из таблицы с тарифами
уберите в ней плюсы и пользуйтесь связкой ИНДЕКС+ПОИСКПОЗ

Автор - прохожий2019
Дата добавления - 28.07.2023 в 20:10
vv@maxflightpro Дата: Пятница, 28.07.2023, 20:11 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

3
прохожий2019, а можно поподробнее пожалуйста как связку осуществить? спасибо
 
Ответить
Сообщениепрохожий2019, а можно поподробнее пожалуйста как связку осуществить? спасибо

Автор - vv@maxflightpro
Дата добавления - 28.07.2023 в 20:11
прохожий2019 Дата: Пятница, 28.07.2023, 20:17 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1263
Репутация: 321 ±
Замечаний: 0% ±

365 Beta Channel
Цитата vv@maxflightpro, 28.07.2023 в 20:11, в сообщении № 3 ()
а можно поподробнее
можно - всё в п. 3 правил
 
Ответить
Сообщение
Цитата vv@maxflightpro, 28.07.2023 в 20:11, в сообщении № 3 ()
а можно поподробнее
можно - всё в п. 3 правил

Автор - прохожий2019
Дата добавления - 28.07.2023 в 20:17
vv@maxflightpro Дата: Пятница, 28.07.2023, 20:21 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

3
прохожий2019, глибоко извиняюсь, исправился
 
Ответить
Сообщениепрохожий2019, глибоко извиняюсь, исправился

Автор - vv@maxflightpro
Дата добавления - 28.07.2023 в 20:21
прохожий2019 Дата: Пятница, 28.07.2023, 20:25 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1263
Репутация: 321 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ЕСЛИОШИБКА(ИНДЕКС($X$3:$AA$5;ПОИСКПОЗ([@CW];$W$3:$W$5;1);ПОИСКПОЗ([@DES];$X$2:$AA$2;));"")
К сообщению приложен файл: 7620173.xlsx (11.0 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС($X$3:$AA$5;ПОИСКПОЗ([@CW];$W$3:$W$5;1);ПОИСКПОЗ([@DES];$X$2:$AA$2;));"")

Автор - прохожий2019
Дата добавления - 28.07.2023 в 20:25
i691198 Дата: Пятница, 28.07.2023, 21:12 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 234
Репутация: 88 ±
Замечаний: 0% ±

Вариант с функцией ГПР.
Код
=ЕСЛИОШИБКА(ГПР([@DES];$X$2:$AA$5;ЕСЛИ([@CW]<=500;2;ЕСЛИ([@CW]<=1000;3;4));0);"")
К сообщению приложен файл: report_1.xlsx (10.5 Kb)
 
Ответить
СообщениеВариант с функцией ГПР.
Код
=ЕСЛИОШИБКА(ГПР([@DES];$X$2:$AA$5;ЕСЛИ([@CW]<=500;2;ЕСЛИ([@CW]<=1000;3;4));0);"")

Автор - i691198
Дата добавления - 28.07.2023 в 21:12
Pelena Дата: Пятница, 28.07.2023, 21:25 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 19234
Репутация: 4431 ±
Замечаний: ±

Excel 365 & Mac Excel
Гибрид первой и второй формул
Код
=ЕСЛИОШИБКА(ГПР([@DES];$X$2:$AA$5;ПОИСКПОЗ([@CW];$W$2:$W$5;1);0);"")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеГибрид первой и второй формул
Код
=ЕСЛИОШИБКА(ГПР([@DES];$X$2:$AA$5;ПОИСКПОЗ([@CW];$W$2:$W$5;1);0);"")

Автор - Pelena
Дата добавления - 28.07.2023 в 21:25
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!