Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула которая суммирует числа в ячейках с условием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Формула которая суммирует числа в ячейках с условием
muratzh81 Дата: Понедельник, 31.07.2023, 13:35 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 60% ±

2108 сборка 14332.20303
Прописал формулу которая суммирует числа в ячейках в текстовом формате включая пустые с A по C до знака "/"
Код
=СУММ(ЕСЛИОШИБКА(ЛЕВСИМВ(A1:C1; ПОИСК("/"; A1:C1)-1)<>""; ЗНАЧЕН(ЛЕВСИМВ(A1:C1; ПОИСК("/"; A1:C1)-1)); 0))
, выдает ошибку "вы ввели слишком много аргументов для этой функции"


Сообщение отредактировал muratzh81 - Понедельник, 31.07.2023, 13:50
 
Ответить
СообщениеПрописал формулу которая суммирует числа в ячейках в текстовом формате включая пустые с A по C до знака "/"
Код
=СУММ(ЕСЛИОШИБКА(ЛЕВСИМВ(A1:C1; ПОИСК("/"; A1:C1)-1)<>""; ЗНАЧЕН(ЛЕВСИМВ(A1:C1; ПОИСК("/"; A1:C1)-1)); 0))
, выдает ошибку "вы ввели слишком много аргументов для этой функции"

Автор - muratzh81
Дата добавления - 31.07.2023 в 13:35
Nic70y Дата: Понедельник, 31.07.2023, 13:42 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8802
Репутация: 2295 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММ(ЕСЛИОШИБКА(ЗНАЧЕН(ЛЕВСИМВ(A1:C1; ПОИСК("/"; A1:C1)-1));0))


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 31.07.2023, 13:52
 
Ответить
Сообщение
Код
=СУММ(ЕСЛИОШИБКА(ЗНАЧЕН(ЛЕВСИМВ(A1:C1; ПОИСК("/"; A1:C1)-1));0))

Автор - Nic70y
Дата добавления - 31.07.2023 в 13:42
muratzh81 Дата: Понедельник, 31.07.2023, 14:13 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 60% ±

2108 сборка 14332.20303
Благодарю

Теперь после "/"
Код
=СУММ(ЕСЛИОШИБКА(ПРАВСИМВ(R[-2]C[-15]:R[-2]C[-1]; ДЛСТР(R[-2]C[-15]:R[-2]C[-1])-ПОИСК("/"; R[-2]C[-15]:R[-2]C[-1]))<>""; ЗНАЧЕН(ПРАВСИМВ(R[-2]C[-15]:R[-2]C[-1]; ДЛСТР(R[-2]C[-15]:R[-2]C[-1])-ПОИСК("/"; R[-2]C[-15]:R[-2]C[-1]))); 0))
тоже самая ошибка


Сообщение отредактировал muratzh81 - Понедельник, 31.07.2023, 14:28
 
Ответить
СообщениеБлагодарю

Теперь после "/"
Код
=СУММ(ЕСЛИОШИБКА(ПРАВСИМВ(R[-2]C[-15]:R[-2]C[-1]; ДЛСТР(R[-2]C[-15]:R[-2]C[-1])-ПОИСК("/"; R[-2]C[-15]:R[-2]C[-1]))<>""; ЗНАЧЕН(ПРАВСИМВ(R[-2]C[-15]:R[-2]C[-1]; ДЛСТР(R[-2]C[-15]:R[-2]C[-1])-ПОИСК("/"; R[-2]C[-15]:R[-2]C[-1]))); 0))
тоже самая ошибка

Автор - muratzh81
Дата добавления - 31.07.2023 в 14:13
Nic70y Дата: Понедельник, 31.07.2023, 16:29 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8802
Репутация: 2295 ±
Замечаний: 0% ±

Excel 2010
muratzh81, Вы используете ЕСЛИОШИБКА как ЕСЛИ, это:
ПРАВСИМВ(R[-2]C[-15]:R[-2]C[-1]; ДЛСТР(R[-2]C[-15]:R[-2]C[-1])-ПОИСК("/"; R[-2]C[-15]:R[-2]C[-1]))<>"";
лишнее


ЮMoney 41001841029809
 
Ответить
Сообщениеmuratzh81, Вы используете ЕСЛИОШИБКА как ЕСЛИ, это:
ПРАВСИМВ(R[-2]C[-15]:R[-2]C[-1]; ДЛСТР(R[-2]C[-15]:R[-2]C[-1])-ПОИСК("/"; R[-2]C[-15]:R[-2]C[-1]))<>"";
лишнее

Автор - Nic70y
Дата добавления - 31.07.2023 в 16:29
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!