Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор последнего значения из таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Выбор последнего значения из таблицы
roman1403 Дата: Четверг, 03.08.2023, 11:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Имеется таблица в Лист1, где собираются значения из таблицы Лист2. Нужно выбрать из таблицы в Лист2 последнее значение концентрации указанного вещества в текущем месяце месяца. А по окончанию месяца на 31 или 30 число, смотря сколько дней в месяце. Например за май, июнь, июль - последнее значение в каждом месяце. А в текущем месяце - на текущую дату.

Возможно ли написать такую универсальную формулу?
К сообщению приложен файл: 0633983.xlsx (13.4 Kb)
 
Ответить
СообщениеДобрый день!
Имеется таблица в Лист1, где собираются значения из таблицы Лист2. Нужно выбрать из таблицы в Лист2 последнее значение концентрации указанного вещества в текущем месяце месяца. А по окончанию месяца на 31 или 30 число, смотря сколько дней в месяце. Например за май, июнь, июль - последнее значение в каждом месяце. А в текущем месяце - на текущую дату.

Возможно ли написать такую универсальную формулу?

Автор - roman1403
Дата добавления - 03.08.2023 в 11:54
Serge_007 Дата: Четверг, 03.08.2023, 12:02 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Здравствуйте

В файле на 31.05.2023 во всех столбцах исходных данных - #Н/Д #Н/Д #Н/Д
Что должно попадать в итоговую таблицу?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

В файле на 31.05.2023 во всех столбцах исходных данных - #Н/Д #Н/Д #Н/Д
Что должно попадать в итоговую таблицу?

Автор - Serge_007
Дата добавления - 03.08.2023 в 12:02
Nic70y Дата: Четверг, 03.08.2023, 12:02 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 8856
Репутация: 2308 ±
Замечаний: 0% ±

Excel 2010
так
Код
=ЕСЛИОШИБКА(ВПР(9E+307;ИНДЕКС(Лист2!F:F;ПОИСКПОЗ($A3;Лист2!$E:$E;)):ИНДЕКС(Лист2!F:F;ПОИСКПОЗ(ЕСЛИОШИБКА(КОНМЕСЯЦА($A3;0);СЕГОДНЯ());Лист2!$E:$E;));1);"")
наверное
К сообщению приложен файл: 17.xlsx (12.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениетак
Код
=ЕСЛИОШИБКА(ВПР(9E+307;ИНДЕКС(Лист2!F:F;ПОИСКПОЗ($A3;Лист2!$E:$E;)):ИНДЕКС(Лист2!F:F;ПОИСКПОЗ(ЕСЛИОШИБКА(КОНМЕСЯЦА($A3;0);СЕГОДНЯ());Лист2!$E:$E;));1);"")
наверное

Автор - Nic70y
Дата добавления - 03.08.2023 в 12:02
roman1403 Дата: Четверг, 03.08.2023, 12:56 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Все правильно поняли, спасибо!
 
Ответить
СообщениеВсе правильно поняли, спасибо!

Автор - roman1403
Дата добавления - 03.08.2023 в 12:56
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!