Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск по критерии одновременно по столбам и строкам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
поиск по критерии одновременно по столбам и строкам
nikaluka1 Дата: Пятница, 04.08.2023, 17:58 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 74
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
Добрый день,
есть календарь на весь год (лист " 1 " ) там водится данные каждый день: время прихода и ухода сотрудников, командировка, отпуск, бюллетень и т. д.
не получается суммировать и изобразить эти данные на определенный период (лист " 2 ")
надо найти функцию чтобы искала по столбам и строкам по критерий по определенным дням (лист " 2 " A1-B1)
К сообщению приложен файл: 0257203.xlsx (114.5 Kb)


Сообщение отредактировал nikaluka1 - Пятница, 04.08.2023, 19:03
 
Ответить
СообщениеДобрый день,
есть календарь на весь год (лист " 1 " ) там водится данные каждый день: время прихода и ухода сотрудников, командировка, отпуск, бюллетень и т. д.
не получается суммировать и изобразить эти данные на определенный период (лист " 2 ")
надо найти функцию чтобы искала по столбам и строкам по критерий по определенным дням (лист " 2 " A1-B1)

Автор - nikaluka1
Дата добавления - 04.08.2023 в 17:58
прохожий2019 Дата: Пятница, 04.08.2023, 18:24 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1263
Репутация: 321 ±
Замечаний: 0% ±

365 Beta Channel
надо найти функцию
ИНДЕКС+ПОИСКПОЗ
дни
Код
=СЧЁТ(ИНДЕКС('1'!$B$5:$ABC$54;ПОИСКПОЗ(A3;'1'!$A$5:$A$54;);))/2
командировки/бюллетени/отпуска
Код
=СЧЁТЕСЛИ(ИНДЕКС('1'!$B$5:$ABC$54;ПОИСКПОЗ($A3;'1'!$A$5:$A$54;););D$2)/2
часы
Код
=СУММ(ЕСЛИОШИБКА(ИНДЕКС('1'!$C$5:$ABC$54;ПОИСКПОЗ(A3;'1'!$A$5:$A$54;);)*ЕНЕЧЁТ(СТОЛБЕЦ($C$1:$ABC$1))-ИНДЕКС('1'!$B$5:$ABB$54;ПОИСКПОЗ(A3;'1'!$A$5:$A$54;);)*ЕЧЁТН((СТОЛБЕЦ($B$1:$ABB$1)));0))*24
К сообщению приложен файл: 9284037.xlsx (115.2 Kb)


Сообщение отредактировал прохожий2019 - Пятница, 04.08.2023, 18:33
 
Ответить
Сообщение
надо найти функцию
ИНДЕКС+ПОИСКПОЗ
дни
Код
=СЧЁТ(ИНДЕКС('1'!$B$5:$ABC$54;ПОИСКПОЗ(A3;'1'!$A$5:$A$54;);))/2
командировки/бюллетени/отпуска
Код
=СЧЁТЕСЛИ(ИНДЕКС('1'!$B$5:$ABC$54;ПОИСКПОЗ($A3;'1'!$A$5:$A$54;););D$2)/2
часы
Код
=СУММ(ЕСЛИОШИБКА(ИНДЕКС('1'!$C$5:$ABC$54;ПОИСКПОЗ(A3;'1'!$A$5:$A$54;);)*ЕНЕЧЁТ(СТОЛБЕЦ($C$1:$ABC$1))-ИНДЕКС('1'!$B$5:$ABB$54;ПОИСКПОЗ(A3;'1'!$A$5:$A$54;);)*ЕЧЁТН((СТОЛБЕЦ($B$1:$ABB$1)));0))*24

Автор - прохожий2019
Дата добавления - 04.08.2023 в 18:24
nikaluka1 Дата: Пятница, 04.08.2023, 18:46 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 74
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
Цитата прохожий2019, 04.08.2023 в 18:24, в сообщении № 2 ()
часы

к сожалению не работает, функция вычисляет весь период но не определённый период (лист " 2 " A1-B1)


Сообщение отредактировал nikaluka1 - Пятница, 04.08.2023, 19:03
 
Ответить
Сообщение
Цитата прохожий2019, 04.08.2023 в 18:24, в сообщении № 2 ()
часы

к сожалению не работает, функция вычисляет весь период но не определённый период (лист " 2 " A1-B1)

Автор - nikaluka1
Дата добавления - 04.08.2023 в 18:46
прохожий2019 Дата: Пятница, 04.08.2023, 20:53 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1263
Репутация: 321 ±
Замечаний: 0% ±

365 Beta Channel
функция вычисляет весь период
точняк, тогда так для дней:
Код
=СУММ(ЕЧИСЛО(ИНДЕКС('1'!$B$5:$ABC$54;ПОИСКПОЗ(A3;'1'!$A$5:$A$54;);))*('1'!$B$3:$ABC$3>='2'!$A$1)*('1'!$B$3:$ABC$3<='2'!$B$1))
комадировки/отпуска
Код
=СУММ((ИНДЕКС('1'!$B$5:$ABC$54;ПОИСКПОЗ($A3;'1'!$A$5:$A$54;);)=D$2)*('1'!$B$3:$ABC$3>='2'!$A$1)*('1'!$B$3:$ABC$3<='2'!$B$1))
К сообщению приложен файл: 928.xlsx (115.4 Kb)


Сообщение отредактировал прохожий2019 - Пятница, 04.08.2023, 21:03
 
Ответить
Сообщение
функция вычисляет весь период
точняк, тогда так для дней:
Код
=СУММ(ЕЧИСЛО(ИНДЕКС('1'!$B$5:$ABC$54;ПОИСКПОЗ(A3;'1'!$A$5:$A$54;);))*('1'!$B$3:$ABC$3>='2'!$A$1)*('1'!$B$3:$ABC$3<='2'!$B$1))
комадировки/отпуска
Код
=СУММ((ИНДЕКС('1'!$B$5:$ABC$54;ПОИСКПОЗ($A3;'1'!$A$5:$A$54;);)=D$2)*('1'!$B$3:$ABC$3>='2'!$A$1)*('1'!$B$3:$ABC$3<='2'!$B$1))

Автор - прохожий2019
Дата добавления - 04.08.2023 в 20:53
nikaluka1 Дата: Пятница, 04.08.2023, 21:05 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 74
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
Цитата прохожий2019, 04.08.2023 в 20:53, в сообщении № 4 ()
точняк, тогда так для дней:

Большое спасибо Извините за неточность, надо ещё чтобы вычислял количество рабочих час по дням,

"время работы час" надо показать разницу времени ( пришёл ушёл, из лист 1, по дням) и суммировать по определённый период,
К сообщению приложен файл: 55.xlsx (115.7 Kb)


Сообщение отредактировал nikaluka1 - Пятница, 04.08.2023, 21:22
 
Ответить
Сообщение
Цитата прохожий2019, 04.08.2023 в 20:53, в сообщении № 4 ()
точняк, тогда так для дней:

Большое спасибо Извините за неточность, надо ещё чтобы вычислял количество рабочих час по дням,

"время работы час" надо показать разницу времени ( пришёл ушёл, из лист 1, по дням) и суммировать по определённый период,

Автор - nikaluka1
Дата добавления - 04.08.2023 в 21:05
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!