Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск непустых ячеек в столбце и создание из них списка - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Поиск непустых ячеек в столбце и создание из них списка
Trytosleep Дата: Понедельник, 07.08.2023, 16:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, друзья. К сожалению, потерял доступ, пришлось региться заново. Всем привет еще раз.

Проблема такая: Имеется полный список сотрудников в столбце А.
В столбце B я ставлю любое значение.
В столбце С вставляются отмеченные фамилии из А.

Необходимо создать список в столбце D без пустых строк.
А в столбце Е создать пронумерованный список из этих фамилий. Спасибо огромное заранее. Моих знаний не хватило.

Пример прилагаю.
П.С. Может ошибка в концепции и можно сделать это проще. Благодарю
К сообщению приложен файл: primer.xlsx (8.9 Kb)
 
Ответить
СообщениеДобрый день, друзья. К сожалению, потерял доступ, пришлось региться заново. Всем привет еще раз.

Проблема такая: Имеется полный список сотрудников в столбце А.
В столбце B я ставлю любое значение.
В столбце С вставляются отмеченные фамилии из А.

Необходимо создать список в столбце D без пустых строк.
А в столбце Е создать пронумерованный список из этих фамилий. Спасибо огромное заранее. Моих знаний не хватило.

Пример прилагаю.
П.С. Может ошибка в концепции и можно сделать это проще. Благодарю

Автор - Trytosleep
Дата добавления - 07.08.2023 в 16:46
elovkov Дата: Понедельник, 07.08.2023, 16:53 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Я сегодня уже делился этой формулой (для D - массивная)
Код
=ЕСЛИОШИБКА(ДВССЫЛ("C"&НАИМЕНЬШИЙ(ЕСЛИ($C$2:$C$100<>"";СТРОКА($C$2:$C$100);"");СТРОКА(A1)));"")

И для Е
Код
=ЕСЛИ(D2<>"";СТРОКА(A1)&". "&D2;"")
К сообщению приложен файл: 1163523.xlsx (9.6 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Понедельник, 07.08.2023, 16:58
 
Ответить
СообщениеЯ сегодня уже делился этой формулой (для D - массивная)
Код
=ЕСЛИОШИБКА(ДВССЫЛ("C"&НАИМЕНЬШИЙ(ЕСЛИ($C$2:$C$100<>"";СТРОКА($C$2:$C$100);"");СТРОКА(A1)));"")

И для Е
Код
=ЕСЛИ(D2<>"";СТРОКА(A1)&". "&D2;"")

Автор - elovkov
Дата добавления - 07.08.2023 в 16:53
Nic70y Дата: Понедельник, 07.08.2023, 17:07 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 8801
Репутация: 2295 ±
Замечаний: 0% ±

Excel 2010
не массивная
Код
=ЕСЛИОШИБКА(ВПР("?*";ИНДЕКС(C$1:C$9999;ПОИСКПОЗ(D1;C$1:C$9999;)+1):C$9999;1;);"")
при условиях - фио не повторяется, текст D1 равен C1

апдэйт + файл "проще"
К сообщению приложен файл: 14.xlsx (9.6 Kb) · 17.xlsx (9.3 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 07.08.2023, 17:13
 
Ответить
Сообщениене массивная
Код
=ЕСЛИОШИБКА(ВПР("?*";ИНДЕКС(C$1:C$9999;ПОИСКПОЗ(D1;C$1:C$9999;)+1):C$9999;1;);"")
при условиях - фио не повторяется, текст D1 равен C1

апдэйт + файл "проще"

Автор - Nic70y
Дата добавления - 07.08.2023 в 17:07
прохожий2019 Дата: Понедельник, 07.08.2023, 17:29 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1260
Репутация: 320 ±
Замечаний: 0% ±

365 Beta Channel
[vba]
Код
=LET(x;ФИЛЬТР(C2:C7;C2:C7<>"");ПОСЛЕД(СЧЁТЗ(x))&". "&x)
[/vba][vba]
Код
=LET(x;ФИЛЬТР(A2:A7;B2:B7<>"");ПОСЛЕД(СЧЁТЗ(x))&". "&x)
[/vba]
К сообщению приложен файл: 67801.xlsx (9.9 Kb)


Сообщение отредактировал прохожий2019 - Понедельник, 07.08.2023, 18:17
 
Ответить
Сообщение[vba]
Код
=LET(x;ФИЛЬТР(C2:C7;C2:C7<>"");ПОСЛЕД(СЧЁТЗ(x))&". "&x)
[/vba][vba]
Код
=LET(x;ФИЛЬТР(A2:A7;B2:B7<>"");ПОСЛЕД(СЧЁТЗ(x))&". "&x)
[/vba]

Автор - прохожий2019
Дата добавления - 07.08.2023 в 17:29
jakim Дата: Понедельник, 07.08.2023, 17:41 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Power Query

[vba]
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    #"Filtered Rows" = Table.SelectRows(Source, each ([#"отметка:"] <> null)),
    #"Removed Columns" = Table.RemoveColumns(#"Filtered Rows",{"отметка:"})
in
    #"Removed Columns"
[/vba]
К сообщению приложен файл: 2799077.xlsx (15.5 Kb)


Сообщение отредактировал jakim - Понедельник, 07.08.2023, 17:46
 
Ответить
Сообщение
Power Query

[vba]
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    #"Filtered Rows" = Table.SelectRows(Source, each ([#"отметка:"] <> null)),
    #"Removed Columns" = Table.RemoveColumns(#"Filtered Rows",{"отметка:"})
in
    #"Removed Columns"
[/vba]

Автор - jakim
Дата добавления - 07.08.2023 в 17:41
DrMini Дата: Понедельник, 07.08.2023, 18:14 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1679
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Просто попробовал на сколько хватает знаний:
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$11;НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$11<>"";СТРОКА($B$2:$B$11)-1);СТРОКА()-1))&". "&ИНДЕКС($A$2:$A$11;НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$11<>"";СТРОКА($A$2:$A$11)-1);СТРОКА()-1));"")
 
Ответить
СообщениеПросто попробовал на сколько хватает знаний:
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$11;НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$11<>"";СТРОКА($B$2:$B$11)-1);СТРОКА()-1))&". "&ИНДЕКС($A$2:$A$11;НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$11<>"";СТРОКА($A$2:$A$11)-1);СТРОКА()-1));"")

Автор - DrMini
Дата добавления - 07.08.2023 в 18:14
jakim Дата: Понедельник, 07.08.2023, 18:41 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IFERROR(INDEX(A$2:A$20;AGGREGATE(15;6;ROW($1:$20)/(B$2:B$19<>"");ROWS($2:2)));"")
К сообщению приложен файл: primer_1.xlsx (8.6 Kb)
 
Ответить
Сообщение
Формула

Код
=IFERROR(INDEX(A$2:A$20;AGGREGATE(15;6;ROW($1:$20)/(B$2:B$19<>"");ROWS($2:2)));"")

Автор - jakim
Дата добавления - 07.08.2023 в 18:41
Trytosleep Дата: Вторник, 08.08.2023, 18:24 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Спасибо всем, друзья! буду пробовать все, как выйдет, всех еще раз обнимаю.
 
Ответить
СообщениеСпасибо всем, друзья! буду пробовать все, как выйдет, всех еще раз обнимаю.

Автор - Trytosleep
Дата добавления - 08.08.2023 в 18:24
Trytosleep Дата: Вторник, 08.08.2023, 18:38 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, CПАСИБО. А можно сделать так, чтобы список начинался с цифры 2, а не 1?
 
Ответить
СообщениеNic70y, CПАСИБО. А можно сделать так, чтобы список начинался с цифры 2, а не 1?

Автор - Trytosleep
Дата добавления - 08.08.2023 в 18:38
jakim Дата: Вторник, 08.08.2023, 19:22 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Пожалуйста.
Формула.

Код
=IFERROR(CONCATENATE(ROWS($2:2)+1;".";" ";INDEX(A$2:A$20;AGGREGATE(15;6;ROW($1:$20)/(B$2:B$19<>"");ROWS($2:2))));"")
К сообщению приложен файл: 3431898.xlsx (8.7 Kb)
 
Ответить
Сообщение
Пожалуйста.
Формула.

Код
=IFERROR(CONCATENATE(ROWS($2:2)+1;".";" ";INDEX(A$2:A$20;AGGREGATE(15;6;ROW($1:$20)/(B$2:B$19<>"");ROWS($2:2))));"")

Автор - jakim
Дата добавления - 08.08.2023 в 19:22
прохожий2019 Дата: Вторник, 08.08.2023, 19:29 | Сообщение № 11
Группа: Проверенные
Ранг: Старожил
Сообщений: 1260
Репутация: 320 ±
Замечаний: 0% ±

365 Beta Channel
с цифры 2
[vba]
Код
=LET(x;ФИЛЬТР(A2:A7;B2:B7<>"");ПОСЛЕД(СЧЁТЗ(x);;2)&". "&x)
[/vba]
 
Ответить
Сообщение
с цифры 2
[vba]
Код
=LET(x;ФИЛЬТР(A2:A7;B2:B7<>"");ПОСЛЕД(СЧЁТЗ(x);;2)&". "&x)
[/vba]

Автор - прохожий2019
Дата добавления - 08.08.2023 в 19:29
DrMini Дата: Вторник, 08.08.2023, 19:34 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 1679
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Nic70y, CПАСИБО. А можно сделать так, чтобы список начинался с цифры 2

Измените в первой части формулу с D1 на D2:
Код
=ЕСЛИОШИБКА(СТРОКА(D2)&". "&ИНДЕКС(A:A;ПОИСКПОЗ(СТРОКА(D1);C:C;));"")

или так:
Код
=ЕСЛИОШИБКА(СТРОКА(D1)+1&". "&ИНДЕКС(A:A;ПОИСКПОЗ(СТРОКА(D1);C:C;));"")
 
Ответить
Сообщение
Nic70y, CПАСИБО. А можно сделать так, чтобы список начинался с цифры 2

Измените в первой части формулу с D1 на D2:
Код
=ЕСЛИОШИБКА(СТРОКА(D2)&". "&ИНДЕКС(A:A;ПОИСКПОЗ(СТРОКА(D1);C:C;));"")

или так:
Код
=ЕСЛИОШИБКА(СТРОКА(D1)+1&". "&ИНДЕКС(A:A;ПОИСКПОЗ(СТРОКА(D1);C:C;));"")

Автор - DrMini
Дата добавления - 08.08.2023 в 19:34
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!