Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать количество одинаковых ячеек по критерию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Как посчитать количество одинаковых ячеек по критерию
h1dex Дата: Вторник, 08.08.2023, 08:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
добрый день!

подскажите как посчитать количество одинаковых ячеек по критерию уникальных значений см. вложение

в ячейке C2 просчитывается общее количество заявок из столбца B
теперь нужно в ячейке D2 посчитать количество заявок АВИА, а в ячейке E2 посчитать количество заявок МОРЕ т.е. всего имеем 235 заявок и теперь нужно из этого количества раскидать на авиа и море
можно конечно это отфильтровать и через удаление дубликатов вычислить данные т.е. получится 213 заявок морем и 22 заявки авиа..но как это автоматизированно через формулы посчитать?
какая формула будет использоваться?
К сообщению приложен файл: zajavki.xlsx (30.3 Kb)
 
Ответить
Сообщениедобрый день!

подскажите как посчитать количество одинаковых ячеек по критерию уникальных значений см. вложение

в ячейке C2 просчитывается общее количество заявок из столбца B
теперь нужно в ячейке D2 посчитать количество заявок АВИА, а в ячейке E2 посчитать количество заявок МОРЕ т.е. всего имеем 235 заявок и теперь нужно из этого количества раскидать на авиа и море
можно конечно это отфильтровать и через удаление дубликатов вычислить данные т.е. получится 213 заявок морем и 22 заявки авиа..но как это автоматизированно через формулы посчитать?
какая формула будет использоваться?

Автор - h1dex
Дата добавления - 08.08.2023 в 08:44
китин Дата: Вторник, 08.08.2023, 08:53 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 7020
Репутация: 1075 ±
Замечаний: 0% ±

Excel 2007;2010;2016
так?
Код
=СЧЁТ(ЕСЛИ($A$3:$A$1672=D$1;$B$3:$B$1672))

формула массива

не так


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениетак?
Код
=СЧЁТ(ЕСЛИ($A$3:$A$1672=D$1;$B$3:$B$1672))

формула массива

не так

Автор - китин
Дата добавления - 08.08.2023 в 08:53
Nic70y Дата: Вторник, 08.08.2023, 09:20 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 8857
Репутация: 2308 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=СЧЁТ(ЕСЛИ(ПОИСКПОЗ(ЕСЛИ($A3:$A5001=D1;$B3:$B5001);$B3:$B5001;)=СТРОКА(B3:B5001)-2;СТРОКА(B3:B5001)))
К сообщению приложен файл: 27.xlsx (30.6 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеформула массива
Код
=СЧЁТ(ЕСЛИ(ПОИСКПОЗ(ЕСЛИ($A3:$A5001=D1;$B3:$B5001);$B3:$B5001;)=СТРОКА(B3:B5001)-2;СТРОКА(B3:B5001)))

Автор - Nic70y
Дата добавления - 08.08.2023 в 09:20
Светлый Дата: Вторник, 08.08.2023, 11:07 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1837
Репутация: 516 ±
Замечаний: 0% ±

Excel 2013, 2016
Формулы массива ВСЕГО:
Код
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(B3:B5000;B3:B5000);))
Код
=СЧЁТ(1/(ПОИСКПОЗ(B3:B5000;B3:B5000;)=СТРОКА(B1:B5000)))
АВИА:
Код
=СЧЁТ(1/(ПОИСКПОЗ($B1:$B5000;$B1:$B5000;)=СТРОКА(B1:B5000))/($A1:$A5000=D1))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 08.08.2023, 11:42
 
Ответить
СообщениеФормулы массива ВСЕГО:
Код
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(B3:B5000;B3:B5000);))
Код
=СЧЁТ(1/(ПОИСКПОЗ(B3:B5000;B3:B5000;)=СТРОКА(B1:B5000)))
АВИА:
Код
=СЧЁТ(1/(ПОИСКПОЗ($B1:$B5000;$B1:$B5000;)=СТРОКА(B1:B5000))/($A1:$A5000=D1))

Автор - Светлый
Дата добавления - 08.08.2023 в 11:07
Egyptian Дата: Вторник, 08.08.2023, 21:13 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 515
Репутация: 186 ±
Замечаний: 0% ±

Excel 2013/2016
Ну и для полноты ощущений:
Код
=SUM(SIGN(FREQUENCY(IF(CHOOSE(COLUMN(A1);($B$3:$B$5000<>"");($A$3:$A$5000=$D$1);($A$3:$A$5000=$E$1));MATCH($B$3:$B$5000;$B$3:$B$5000;0));ROW($B$3:$B$5000)-2)))

В С2 и тянем вправо.
З.Ы. Формула массива есс-но.
 
Ответить
СообщениеНу и для полноты ощущений:
Код
=SUM(SIGN(FREQUENCY(IF(CHOOSE(COLUMN(A1);($B$3:$B$5000<>"");($A$3:$A$5000=$D$1);($A$3:$A$5000=$E$1));MATCH($B$3:$B$5000;$B$3:$B$5000;0));ROW($B$3:$B$5000)-2)))

В С2 и тянем вправо.
З.Ы. Формула массива есс-но.

Автор - Egyptian
Дата добавления - 08.08.2023 в 21:13
h1dex Дата: Вторник, 08.08.2023, 21:17 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
спасибо огромное всем!
 
Ответить
Сообщениеспасибо огромное всем!

Автор - h1dex
Дата добавления - 08.08.2023 в 21:17
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!