Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма ячеек до ячеек до активной ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Сумма ячеек до ячеек до активной ячейки
dishatalov Дата: Среда, 09.08.2023, 08:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

16
Нужна помощь
Есть таблица, в которую каждый месяц заносятся данные.
Есть в каждом месяце ячейка, в которой большой формулой делается расчет.
Один из параметров для расчета - это сумма значений всех ячеек, находящихся до нее в этой строке.
Подскажите, как посчитать сумму ячеек до активной, а то каждый раз применять автосумму как-то уже стремно ))
 
Ответить
СообщениеНужна помощь
Есть таблица, в которую каждый месяц заносятся данные.
Есть в каждом месяце ячейка, в которой большой формулой делается расчет.
Один из параметров для расчета - это сумма значений всех ячеек, находящихся до нее в этой строке.
Подскажите, как посчитать сумму ячеек до активной, а то каждый раз применять автосумму как-то уже стремно ))

Автор - dishatalov
Дата добавления - 09.08.2023 в 08:40
Nic70y Дата: Среда, 09.08.2023, 08:44 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8821
Репутация: 2298 ±
Замечаний: 0% ±

Excel 2010
файл-пример-excel приложите
не совсем понятно


ЮMoney 41001841029809
 
Ответить
Сообщениефайл-пример-excel приложите
не совсем понятно

Автор - Nic70y
Дата добавления - 09.08.2023 в 08:44
elovkov Дата: Среда, 09.08.2023, 08:44 | Сообщение № 3
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Файл с примером облегчил бы понимание задачи


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеФайл с примером облегчил бы понимание задачи

Автор - elovkov
Дата добавления - 09.08.2023 в 08:44
elovkov Дата: Среда, 09.08.2023, 08:52 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Вот такая формула
Код
=СУММ(ДВССЫЛ("RC1";0):ДВССЫЛ("RC[-1]";0))

просуммирует строку от столбца А до столбца левее от текущей ячейки


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеВот такая формула
Код
=СУММ(ДВССЫЛ("RC1";0):ДВССЫЛ("RC[-1]";0))

просуммирует строку от столбца А до столбца левее от текущей ячейки

Автор - elovkov
Дата добавления - 09.08.2023 в 08:52
dishatalov Дата: Среда, 09.08.2023, 08:59 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

16
Есть две кассы
По ним берется сумма чеков на нужное число
В последней строке эти чеки суммируются по следующему принципу
Кол-во с кассы 1 + кол-во с кассы 2 - кол-во дней*4 (отбрасываются чеки открытия смены и закрытия смены)
Но есть проблема! Строка кол-во чеков она идет по возрастанию. Т.е каждая следующая ячейка содержит в себе данные предыдущей, плюс новые.
Мне нужно, что в строке 5 из формулы описанной выше вычитались все значения в этой строке до ячейки с формулой
Пример:
=СУММ(F4:G4)-B5-D5-F3*4, где сродственно B5 и D5 минусуемые значения
Чтобы не делать это вручную, а копировать формулу на всю строку сразу
К сообщению приложен файл: 8670857.xlsx (9.9 Kb)
 
Ответить
СообщениеЕсть две кассы
По ним берется сумма чеков на нужное число
В последней строке эти чеки суммируются по следующему принципу
Кол-во с кассы 1 + кол-во с кассы 2 - кол-во дней*4 (отбрасываются чеки открытия смены и закрытия смены)
Но есть проблема! Строка кол-во чеков она идет по возрастанию. Т.е каждая следующая ячейка содержит в себе данные предыдущей, плюс новые.
Мне нужно, что в строке 5 из формулы описанной выше вычитались все значения в этой строке до ячейки с формулой
Пример:
=СУММ(F4:G4)-B5-D5-F3*4, где сродственно B5 и D5 минусуемые значения
Чтобы не делать это вручную, а копировать формулу на всю строку сразу

Автор - dishatalov
Дата добавления - 09.08.2023 в 08:59
dishatalov Дата: Среда, 09.08.2023, 09:10 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

16
elovkov, Спасибо, работает отлично!
 
Ответить
Сообщениеelovkov, Спасибо, работает отлично!

Автор - dishatalov
Дата добавления - 09.08.2023 в 09:10
elovkov Дата: Среда, 09.08.2023, 09:37 | Сообщение № 7
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
работает отлично!

Учтите, у функции ДВССЫЛ есть недостаток - она пересчивывается каждый раз когда что-то меняется на листе, даже в независящих ячейках, так что если их будет много, томожет подтормаживать сильно.
Может кто-то что-то полегче предложит)))


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
работает отлично!

Учтите, у функции ДВССЫЛ есть недостаток - она пересчивывается каждый раз когда что-то меняется на листе, даже в независящих ячейках, так что если их будет много, томожет подтормаживать сильно.
Может кто-то что-то полегче предложит)))

Автор - elovkov
Дата добавления - 09.08.2023 в 09:37
DrMini Дата: Среда, 09.08.2023, 09:46 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1722
Репутация: 235 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Чёт не совсем понял.
Код
=СУММ(D4:E4)-B5-СУММ($B3:D$3)*4

Вдруг так?
К сообщению приложен файл: 1259992.xlsx (10.1 Kb)
 
Ответить
СообщениеЧёт не совсем понял.
Код
=СУММ(D4:E4)-B5-СУММ($B3:D$3)*4

Вдруг так?

Автор - DrMini
Дата добавления - 09.08.2023 в 09:46
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!