Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Обратное равенство - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Обратное равенство (Формулы/Formulas)
Обратное равенство
Vladislav_9Q Дата: Суббота, 12.08.2023, 22:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
В Excel есть совершенно потрясающая функция, которая копирует данные из одной ячейки в другую через знак равенства. А можно ли сделать обратное действие? Т.е. указать ячейку, в которую вставят текст и в той ячейке появится текст. Пример в прикрепленном файле.
К сообщению приложен файл: obratnoe_ravenstvo.xlsx (8.8 Kb)
 
Ответить
СообщениеВ Excel есть совершенно потрясающая функция, которая копирует данные из одной ячейки в другую через знак равенства. А можно ли сделать обратное действие? Т.е. указать ячейку, в которую вставят текст и в той ячейке появится текст. Пример в прикрепленном файле.

Автор - Vladislav_9Q
Дата добавления - 12.08.2023 в 22:07
прохожий2019 Дата: Суббота, 12.08.2023, 23:04 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1239
Репутация: 316 ±
Замечаний: 0% ±

365 Beta Channel
и вам здрасьте, такое только макросом
 
Ответить
Сообщениеи вам здрасьте, такое только макросом

Автор - прохожий2019
Дата добавления - 12.08.2023 в 23:04
cmivadwot Дата: Воскресенье, 13.08.2023, 01:02 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 385
Репутация: 80 ±
Замечаний: 0% ±

365
Vladislav_9Q, колхозный сырой вариант....может кто допилит...сделает без лишнего...
К сообщению приложен файл: 0772846_1.xlsx (24.6 Kb)


Сообщение отредактировал cmivadwot - Воскресенье, 13.08.2023, 01:14
 
Ответить
СообщениеVladislav_9Q, колхозный сырой вариант....может кто допилит...сделает без лишнего...

Автор - cmivadwot
Дата добавления - 13.08.2023 в 01:02
прохожий2019 Дата: Воскресенье, 13.08.2023, 02:04 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1239
Репутация: 316 ±
Замечаний: 0% ±

365 Beta Channel
сделает без лишнего
дык если формулами тянем, почему не просто
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(ЯЧЕЙКА("адрес";A1);"$";"");ВЫБОР({1;2};Данные!$B$2:$B$18;Данные!$A$2:$A$18;);2;);"")
К сообщению приложен файл: 3998558.xlsx (17.3 Kb)
 
Ответить
Сообщение
сделает без лишнего
дык если формулами тянем, почему не просто
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(ЯЧЕЙКА("адрес";A1);"$";"");ВЫБОР({1;2};Данные!$B$2:$B$18;Данные!$A$2:$A$18;);2;);"")

Автор - прохожий2019
Дата добавления - 13.08.2023 в 02:04
cmivadwot Дата: Воскресенье, 13.08.2023, 02:50 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 385
Репутация: 80 ±
Замечаний: 0% ±

365
прохожий2019, изначально так и планировалось... с использованием =адрес, но наличе $ увели в нагородить....
 
Ответить
Сообщениепрохожий2019, изначально так и планировалось... с использованием =адрес, но наличе $ увели в нагородить....

Автор - cmivadwot
Дата добавления - 13.08.2023 в 02:50
Vladislav_9Q Дата: Понедельник, 14.08.2023, 10:21 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
cmivadwot, спасибо
 
Ответить
Сообщениеcmivadwot, спасибо

Автор - Vladislav_9Q
Дата добавления - 14.08.2023 в 10:21
Vladislav_9Q Дата: Понедельник, 14.08.2023, 10:22 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
прохожий2019, спасибо
 
Ответить
Сообщениепрохожий2019, спасибо

Автор - Vladislav_9Q
Дата добавления - 14.08.2023 в 10:22
Nic70y Дата: Понедельник, 14.08.2023, 10:53 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 8510
Репутация: 2149 ±
Замечаний: 0% ±

Excel 2010
еще вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(Данные!$A:$A;ПОИСКПОЗ(АДРЕС(СТРОКА();СТОЛБЕЦ();4);Данные!$B:$B;));"")


ЮMoney 41001841029809
 
Ответить
Сообщениееще вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(Данные!$A:$A;ПОИСКПОЗ(АДРЕС(СТРОКА();СТОЛБЕЦ();4);Данные!$B:$B;));"")

Автор - Nic70y
Дата добавления - 14.08.2023 в 10:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Обратное равенство (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!