Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вопросу про соединение - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
вопросу про соединение
Krapi Дата: Пятница, 18.08.2023, 16:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Доброго всем, форумчане!
Ищу возможность массового соединения из разных столбцов преумножением БЕЗ использования функции "мгновенное заполнение". Хотелось бы подсказать по формуле.

У меня есть 3 столбца:
1 - тип фруктов: яблоко, груша
2 - цвет товара: желтый, зеленый, красный
3 - поставщик: Европа, Азия

Т.е. всего 2 варианта в первом типе, 3 варианта во втором типе и 2 варианта в третьем типе.
Итого 2х3х2=12 вариантов

Я хотел бы найти возможность собрать все варианта в таблицу (каждый в отдельную строку) о всех из них.
Т.е. должно получиться 12 строк начинающихся с типа фруктов:

Что-то похожее на:
Яблоко Желтый Европа
Яблоко Желтый Азия
Яблоко Зеленый Европа
..... до
Груша Красный Азия.

Если не получится в одном столбце, то можно в нескольких (я потом соединю).
Прошу вашего совета
 
Ответить
СообщениеДоброго всем, форумчане!
Ищу возможность массового соединения из разных столбцов преумножением БЕЗ использования функции "мгновенное заполнение". Хотелось бы подсказать по формуле.

У меня есть 3 столбца:
1 - тип фруктов: яблоко, груша
2 - цвет товара: желтый, зеленый, красный
3 - поставщик: Европа, Азия

Т.е. всего 2 варианта в первом типе, 3 варианта во втором типе и 2 варианта в третьем типе.
Итого 2х3х2=12 вариантов

Я хотел бы найти возможность собрать все варианта в таблицу (каждый в отдельную строку) о всех из них.
Т.е. должно получиться 12 строк начинающихся с типа фруктов:

Что-то похожее на:
Яблоко Желтый Европа
Яблоко Желтый Азия
Яблоко Зеленый Европа
..... до
Груша Красный Азия.

Если не получится в одном столбце, то можно в нескольких (я потом соединю).
Прошу вашего совета

Автор - Krapi
Дата добавления - 18.08.2023 в 16:27
cmivadwot Дата: Пятница, 18.08.2023, 16:34 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 478
Репутация: 87 ±
Замечаний: 0% ±

365
Krapi,
Код
=СЦЕПИТЬ(A1;" ";B1;" ";C1)
К сообщению приложен файл: kekekekesasapaperpr.xlsx (10.6 Kb)


Сообщение отредактировал cmivadwot - Пятница, 18.08.2023, 16:39
 
Ответить
СообщениеKrapi,
Код
=СЦЕПИТЬ(A1;" ";B1;" ";C1)

Автор - cmivadwot
Дата добавления - 18.08.2023 в 16:34
Krapi Дата: Пятница, 18.08.2023, 17:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

У меня они в след. виде

https://i.ibb.co/tzWqKjT/Clipboard0122.gif

т.е. вариант наверху не подходит, так как нужно производить копирование в ручную
Мне нужно понять, как перемножать их по формуле (все варианты сами на себя) и сцеплять их


Сообщение отредактировал Krapi - Пятница, 18.08.2023, 17:17
 
Ответить
СообщениеУ меня они в след. виде

https://i.ibb.co/tzWqKjT/Clipboard0122.gif

т.е. вариант наверху не подходит, так как нужно производить копирование в ручную
Мне нужно понять, как перемножать их по формуле (все варианты сами на себя) и сцеплять их

Автор - Krapi
Дата добавления - 18.08.2023 в 17:14
cmivadwot Дата: Пятница, 18.08.2023, 17:52 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 478
Репутация: 87 ±
Замечаний: 0% ±

365
Krapi, т.е задача найти все варианты сочетания? Из имеющихся данных на картинке?
 
Ответить
СообщениеKrapi, т.е задача найти все варианты сочетания? Из имеющихся данных на картинке?

Автор - cmivadwot
Дата добавления - 18.08.2023 в 17:52
Krapi Дата: Пятница, 18.08.2023, 18:40 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Задача сгенерировать все возможные словосочетаний из столбцов с соблюдением последовательности.
Т.е. Сначала Тип, потом Цвет, потом Поставщик. И только в такой последовательности.

Я нашел тему на форуме: http://www.excelworld.ru/forum/2-16735-1
Там предлагают решить через
=@INDEX(A:A,RANDBETWEEN(1,COUNTA(A:A)-1)+1) & " " &@ INDEX(B:B,RANDBETWEEN(1,COUNTA(B:B)-1)+1) & " " &@ INDEX(C:C,RANDBETWEEN(1,COUNTA(C:C)-1)+1)

Вроде работает


Сообщение отредактировал Krapi - Пятница, 18.08.2023, 19:07
 
Ответить
СообщениеЗадача сгенерировать все возможные словосочетаний из столбцов с соблюдением последовательности.
Т.е. Сначала Тип, потом Цвет, потом Поставщик. И только в такой последовательности.

Я нашел тему на форуме: http://www.excelworld.ru/forum/2-16735-1
Там предлагают решить через
=@INDEX(A:A,RANDBETWEEN(1,COUNTA(A:A)-1)+1) & " " &@ INDEX(B:B,RANDBETWEEN(1,COUNTA(B:B)-1)+1) & " " &@ INDEX(C:C,RANDBETWEEN(1,COUNTA(C:C)-1)+1)

Вроде работает

Автор - Krapi
Дата добавления - 18.08.2023 в 18:40
Pelena Дата: Пятница, 18.08.2023, 19:26 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 19234
Репутация: 4431 ±
Замечаний: ±

Excel 365 & Mac Excel
Сначала Тип, потом Цвет, потом Поставщик. И только в такой последовательности.

вариант
Код
=ЕСЛИ(СТРОКА()>СЧЁТЗ(A:A)*СЧЁТЗ(B:B)*СЧЁТЗ(C:C);"";ИНДЕКС(A:A;ОСТАТ((СТРОКА()-1)/СЧЁТЗ(B:B)/СЧЁТЗ(C:C);СЧЁТЗ(A:A))+1) & " " &ИНДЕКС(B:B;ОСТАТ((СТРОКА()-1)/СЧЁТЗ(C:C);СЧЁТЗ(B:B))+1) & " " &ИНДЕКС(C:C;ОСТАТ((СТРОКА()-1);СЧЁТЗ(C:C))+1))
К сообщению приложен файл: Krapi.xlsx (12.4 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
Сначала Тип, потом Цвет, потом Поставщик. И только в такой последовательности.

вариант
Код
=ЕСЛИ(СТРОКА()>СЧЁТЗ(A:A)*СЧЁТЗ(B:B)*СЧЁТЗ(C:C);"";ИНДЕКС(A:A;ОСТАТ((СТРОКА()-1)/СЧЁТЗ(B:B)/СЧЁТЗ(C:C);СЧЁТЗ(A:A))+1) & " " &ИНДЕКС(B:B;ОСТАТ((СТРОКА()-1)/СЧЁТЗ(C:C);СЧЁТЗ(B:B))+1) & " " &ИНДЕКС(C:C;ОСТАТ((СТРОКА()-1);СЧЁТЗ(C:C))+1))

Автор - Pelena
Дата добавления - 18.08.2023 в 19:26
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!