Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для разных вариантов (дашборд) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для разных вариантов (дашборд) (Формулы/Formulas)
Формула для разных вариантов (дашборд)
ymarkelova Дата: Понедельник, 21.08.2023, 12:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 40% ±

2019
Пожалуйста, помогите с формулой:
есть таблица с уставным капиталом разным компаний. Хочу сделать интерактивный дашборд для наглядности - в каком году какие были данные.
в ячейки, которые выделила желтым цветом, нужно заполнить формулу со следующими условиями:
- если выбран Статус "актуально", то в ячейку K2 подтягиваются данные из Таблицы 1, столбец С со статусом "Актуально". В данном случае это 75%

А если статус "не актуально", то в ячейку K2 должны подтянутся данные из столбца А таблицы 1:
- если выбрана дата 12.12.2016, то из столбца С Таблицы 1 должно подтянутся значение С2 (50%)
- если выбрана дата 03.04.2017, то из столбца С Таблицы 1 должно подтянутся значение С7 (58%)

Как можно сделать, что бы вычислялось автоматически?
Какую формулу лучше использовать?
К сообщению приложен файл: formula_s_variantami2.xlsx (23.5 Kb)


Сообщение отредактировал ymarkelova - Понедельник, 21.08.2023, 13:05
 
Ответить
СообщениеПожалуйста, помогите с формулой:
есть таблица с уставным капиталом разным компаний. Хочу сделать интерактивный дашборд для наглядности - в каком году какие были данные.
в ячейки, которые выделила желтым цветом, нужно заполнить формулу со следующими условиями:
- если выбран Статус "актуально", то в ячейку K2 подтягиваются данные из Таблицы 1, столбец С со статусом "Актуально". В данном случае это 75%

А если статус "не актуально", то в ячейку K2 должны подтянутся данные из столбца А таблицы 1:
- если выбрана дата 12.12.2016, то из столбца С Таблицы 1 должно подтянутся значение С2 (50%)
- если выбрана дата 03.04.2017, то из столбца С Таблицы 1 должно подтянутся значение С7 (58%)

Как можно сделать, что бы вычислялось автоматически?
Какую формулу лучше использовать?

Автор - ymarkelova
Дата добавления - 21.08.2023 в 12:45
Serge_007 Дата: Понедельник, 21.08.2023, 12:55 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Код
=ЕСЛИ(W2="актуально";СУММПРОИЗВ((H2:H10=W2)*(A2:A10=J2)*C2:C10);СУММПРОИЗВ((H2:H10=W2)*(A2:A10=J2)*C2:C10*(R2=G2:G10)))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ЕСЛИ(W2="актуально";СУММПРОИЗВ((H2:H10=W2)*(A2:A10=J2)*C2:C10);СУММПРОИЗВ((H2:H10=W2)*(A2:A10=J2)*C2:C10*(R2=G2:G10)))

Автор - Serge_007
Дата добавления - 21.08.2023 в 12:55
ymarkelova Дата: Понедельник, 21.08.2023, 13:09 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 40% ±

2019
Со второй частью формулы непонятно где и как выбираются даты

Спасибо!

Даты должны выбираться из таблицы для срезов (немного поменяла файл)
Вот я выбрала "Не актуально", у меня осталось 2 компании: Ромашка и Тест.

Затем выбираю Ромашку и остается 2 даты: 2016 и 2017 год. Выбираю 2016 - и должно подтянутся значение из ячейки С2
Выбираю 2017 - и должно подтянутся значение из ячейки С7.
По идее, можно сделать так, что бы данные зависели от тех значений, что в ячейках N2 и Q2, но не могу сообразить, как это сделать
К сообщению приложен файл: 1717996.xlsx (23.5 Kb)
 
Ответить
Сообщение
Со второй частью формулы непонятно где и как выбираются даты

Спасибо!

Даты должны выбираться из таблицы для срезов (немного поменяла файл)
Вот я выбрала "Не актуально", у меня осталось 2 компании: Ромашка и Тест.

Затем выбираю Ромашку и остается 2 даты: 2016 и 2017 год. Выбираю 2016 - и должно подтянутся значение из ячейки С2
Выбираю 2017 - и должно подтянутся значение из ячейки С7.
По идее, можно сделать так, что бы данные зависели от тех значений, что в ячейках N2 и Q2, но не могу сообразить, как это сделать

Автор - ymarkelova
Дата добавления - 21.08.2023 в 13:09
Serge_007 Дата: Понедельник, 21.08.2023, 13:19 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Отредактировал свой пост вместе с Вашим ответом)
Формулу выложил в предыдущем
К сообщению приложен файл: 20230821_ymarkelova.xls (36.5 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеОтредактировал свой пост вместе с Вашим ответом)
Формулу выложил в предыдущем

Автор - Serge_007
Дата добавления - 21.08.2023 в 13:19
ymarkelova Дата: Вторник, 22.08.2023, 05:45 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 40% ±

2019
Огромное спасибо!!
То, что нужно!


Сообщение отредактировал Serge_007 - Вторник, 22.08.2023, 09:34
 
Ответить
СообщениеОгромное спасибо!!
То, что нужно!

Автор - ymarkelova
Дата добавления - 22.08.2023 в 05:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для разных вариантов (дашборд) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!