Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проставить только одно значение в итоговом столбце - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Проставить только одно значение в итоговом столбце
dmitriyaleksandrovichni Дата: Вторник, 22.08.2023, 19:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

13
Коллеги, привет! Помогите, пожалуйста!
Задачка такая:
есть столбец условно с названиями растений, напротив каждого наименования некая цифра, нужно сделать так, чтобы цифра эта проставилась в итоговом столбце только один раз и более не повторялась (см. пример во вложении)
То есть в моём примере:
у "одуванчика" циферка 1 повторяется 4 раза, а надо, чтобы в итоговой столбец попала только первая цифра 1
у "ромашки" сначала циферка 0, затем 1, затем снова 0 и снова 1, а итогом должно стать только циферка 1 напротив второй позиции ромашки в списке
у "подорожника" порядок цифер: 0,1,1, а итогом должен стать 0,1,0
и так далее.
Короче говоря, находим первое число больше 0, выносим его в итоговый столбец, а дальше по списку должны быть только нули у этого наименования растения.
Помогите, пожалуйста! Кажется, что формула должна быть не очень сложная, несколько вложений ЕСЛИ и всё, но никак не могу допереть. Может быть кто-то с похожей задачкой сталкивался?
Большая просьба - без макросов.
Заранее всем спасибо!
К сообщению приложен файл: vopros_dlja_foruma.xlsx (9.2 Kb)


Шлюхогон42
 
Ответить
СообщениеКоллеги, привет! Помогите, пожалуйста!
Задачка такая:
есть столбец условно с названиями растений, напротив каждого наименования некая цифра, нужно сделать так, чтобы цифра эта проставилась в итоговом столбце только один раз и более не повторялась (см. пример во вложении)
То есть в моём примере:
у "одуванчика" циферка 1 повторяется 4 раза, а надо, чтобы в итоговой столбец попала только первая цифра 1
у "ромашки" сначала циферка 0, затем 1, затем снова 0 и снова 1, а итогом должно стать только циферка 1 напротив второй позиции ромашки в списке
у "подорожника" порядок цифер: 0,1,1, а итогом должен стать 0,1,0
и так далее.
Короче говоря, находим первое число больше 0, выносим его в итоговый столбец, а дальше по списку должны быть только нули у этого наименования растения.
Помогите, пожалуйста! Кажется, что формула должна быть не очень сложная, несколько вложений ЕСЛИ и всё, но никак не могу допереть. Может быть кто-то с похожей задачкой сталкивался?
Большая просьба - без макросов.
Заранее всем спасибо!

Автор - dmitriyaleksandrovichni
Дата добавления - 22.08.2023 в 19:53
прохожий2019 Дата: Вторник, 22.08.2023, 20:10 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1260
Репутация: 320 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ЕСЛИ(СУММЕСЛИ($A$1:A1;A2;$B$1:B1);0;B2)
К сообщению приложен файл: 5686813.xlsx (10.2 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(СУММЕСЛИ($A$1:A1;A2;$B$1:B1);0;B2)

Автор - прохожий2019
Дата добавления - 22.08.2023 в 20:10
cmivadwot Дата: Вторник, 22.08.2023, 20:13 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 459
Репутация: 86 ±
Замечаний: 0% ±

365
dmitriyaleksandrovichni, вот так... но надо проверять.. не работает.. прохожий2019 уже ответил..


Сообщение отредактировал cmivadwot - Вторник, 22.08.2023, 20:18
 
Ответить
Сообщениеdmitriyaleksandrovichni, вот так... но надо проверять.. не работает.. прохожий2019 уже ответил..

Автор - cmivadwot
Дата добавления - 22.08.2023 в 20:13
Egyptian Дата: Вторник, 22.08.2023, 21:00 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 514
Репутация: 185 ±
Замечаний: 0% ±

Excel 2013/2016
Практически тоже самое
Код
=(COUNTIFS(A$2:A2;A2;B$2:B2;B2)=1)*B2

Код
=(SUMIF($A$1:A1;A2;$B$1:B1)<1)*B2
 
Ответить
СообщениеПрактически тоже самое
Код
=(COUNTIFS(A$2:A2;A2;B$2:B2;B2)=1)*B2

Код
=(SUMIF($A$1:A1;A2;$B$1:B1)<1)*B2

Автор - Egyptian
Дата добавления - 22.08.2023 в 21:00
dmitriyaleksandrovichni Дата: Среда, 23.08.2023, 10:46 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

13
Цитата прохожий2019, 22.08.2023 в 20:10, в сообщении № 2 ()
=ЕСЛИ(СУММЕСЛИ($A$1:A1;A2;$B$1:B1);0;B2)

большое спасибо! можете пояснить, как это работает?


Шлюхогон42
 
Ответить
Сообщение
Цитата прохожий2019, 22.08.2023 в 20:10, в сообщении № 2 ()
=ЕСЛИ(СУММЕСЛИ($A$1:A1;A2;$B$1:B1);0;B2)

большое спасибо! можете пояснить, как это работает?

Автор - dmitriyaleksandrovichni
Дата добавления - 23.08.2023 в 10:46
прохожий2019 Дата: Среда, 23.08.2023, 15:38 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1260
Репутация: 320 ±
Замечаний: 0% ±

365 Beta Channel
Цитата dmitriyaleksandrovichni, 23.08.2023 в 10:46, в сообщении № 5 ()
как это работает?
также как и остальные предложенные формулы - сумма по условию от первой до текущей строки, если сумма уже ненулевая - вернуть ноль, иначе - вернуть значение по текущей строке
 
Ответить
Сообщение
Цитата dmitriyaleksandrovichni, 23.08.2023 в 10:46, в сообщении № 5 ()
как это работает?
также как и остальные предложенные формулы - сумма по условию от первой до текущей строки, если сумма уже ненулевая - вернуть ноль, иначе - вернуть значение по текущей строке

Автор - прохожий2019
Дата добавления - 23.08.2023 в 15:38
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!