Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложная формула сломалась - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложная формула сломалась (Формулы/Formulas)
Сложная формула сломалась
Ragnarrok Дата: Четверг, 24.08.2023, 19:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: -8 ±
Замечаний: 80% ±

Добрый день, уважаемые форумчане.
Долго и упорно мучал формулу, все получилось и без проблем работало, пока не сломалась вроде бы без видимых причин.

Как должна работать:
Проблема в формуле в столбце J (Операционный лист).
Если к примеру в ячейке D2387 (Операционный лист) стоит Списание, то формула ищет шифр из ячейки А2387 (Операционный лист) по всему столбцу А (Операционный лист) и Списание из ячейки D2387 (Операционный лист) по всему столбцу D (Операционный лист), при совпадении обоих условий суммирует значения из столбца Е (Операционный лист). Далее от этой суммы вычитает значение из столбца P (База инструмента), если шифр из ячейки А2387 (Операционный лист) совпадает со значением в столбце G (База инструмента).

Формула работала, но потом что-то пошло не так. Буду благодарен за помощь в поиске ошибки.
ПС К теме не прикладывается из-за большого размера, прикладываю на яндекс диск.
Ссылка удалена администрацией
 
Ответить
СообщениеДобрый день, уважаемые форумчане.
Долго и упорно мучал формулу, все получилось и без проблем работало, пока не сломалась вроде бы без видимых причин.

Как должна работать:
Проблема в формуле в столбце J (Операционный лист).
Если к примеру в ячейке D2387 (Операционный лист) стоит Списание, то формула ищет шифр из ячейки А2387 (Операционный лист) по всему столбцу А (Операционный лист) и Списание из ячейки D2387 (Операционный лист) по всему столбцу D (Операционный лист), при совпадении обоих условий суммирует значения из столбца Е (Операционный лист). Далее от этой суммы вычитает значение из столбца P (База инструмента), если шифр из ячейки А2387 (Операционный лист) совпадает со значением в столбце G (База инструмента).

Формула работала, но потом что-то пошло не так. Буду благодарен за помощь в поиске ошибки.
ПС К теме не прикладывается из-за большого размера, прикладываю на яндекс диск.
Ссылка удалена администрацией

Автор - Ragnarrok
Дата добавления - 24.08.2023 в 19:46
DrMini Дата: Четверг, 24.08.2023, 20:50 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Формула работала, но потом что-то пошло не так

Может так?
Протянул в столбце от J1898 на всю таблицу. Если что то поменяйте диапазон.
Файл тут Ссылка удалена администрацией
 
Ответить
Сообщение
Формула работала, но потом что-то пошло не так

Может так?
Протянул в столбце от J1898 на всю таблицу. Если что то поменяйте диапазон.
Файл тут Ссылка удалена администрацией

Автор - DrMini
Дата добавления - 24.08.2023 в 20:50
Ragnarrok Дата: Четверг, 24.08.2023, 21:48 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: -8 ±
Замечаний: 80% ±

Может так?

Спасибо, Вы меня натолкнули на правильную мысль. Что-то ему там в диапазоне последняя ячейка не нравилась, упростил формулу.

=ЕСЛИ(D2358="Списание";МАКС(СУММЕСЛИМН('Операционный лист'!$E:$E;'Операционный лист'!$A:$A;A2358;'Операционный лист'!$D:$D;"Списание")-ЕСЛИОШИБКА(ИНДЕКС('База инструмента'!P:P;ПОИСКПОЗ(A2358;'База инструмента'!$G:$G;))&"";"");0);"")
 
Ответить
Сообщение
Может так?

Спасибо, Вы меня натолкнули на правильную мысль. Что-то ему там в диапазоне последняя ячейка не нравилась, упростил формулу.

=ЕСЛИ(D2358="Списание";МАКС(СУММЕСЛИМН('Операционный лист'!$E:$E;'Операционный лист'!$A:$A;A2358;'Операционный лист'!$D:$D;"Списание")-ЕСЛИОШИБКА(ИНДЕКС('База инструмента'!P:P;ПОИСКПОЗ(A2358;'База инструмента'!$G:$G;))&"";"");0);"")

Автор - Ragnarrok
Дата добавления - 24.08.2023 в 21:48
DrMini Дата: Пятница, 25.08.2023, 06:13 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
упростил формулу

Не уверен, что это так называется.
Вы увеличили нагрузку на компьютер при расчёте. Так, как задали весь диапазон (A:A;E:E и т.д.) и Excel`у приходится каждый раз "просматривать" эти диапазоны целиком. Лучше задать границы просмотра. Но... Вам виднее.
Вот так будет ещё малость короче:
Код
=ЕСЛИ(D2="Списание";МАКС(СУММЕСЛИМН(E:E;A:A;A2;D:D;"Списание")-ЕСЛИОШИБКА(ИНДЕКС('База инструмента'!P:P;ПОИСКПОЗ(A2;'База инструмента'!G:G;))&"";"");0);"")

[p.s.]в Вашем сообщении №3 оформите формулу тегом.[/p.s.]
 
Ответить
Сообщение
упростил формулу

Не уверен, что это так называется.
Вы увеличили нагрузку на компьютер при расчёте. Так, как задали весь диапазон (A:A;E:E и т.д.) и Excel`у приходится каждый раз "просматривать" эти диапазоны целиком. Лучше задать границы просмотра. Но... Вам виднее.
Вот так будет ещё малость короче:
Код
=ЕСЛИ(D2="Списание";МАКС(СУММЕСЛИМН(E:E;A:A;A2;D:D;"Списание")-ЕСЛИОШИБКА(ИНДЕКС('База инструмента'!P:P;ПОИСКПОЗ(A2;'База инструмента'!G:G;))&"";"");0);"")

[p.s.]в Вашем сообщении №3 оформите формулу тегом.[/p.s.]

Автор - DrMini
Дата добавления - 25.08.2023 в 06:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложная формула сломалась (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!