Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Увеличение на час от предыдущей ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Увеличение на час от предыдущей ячейки (Формулы/Formulas)
Увеличение на час от предыдущей ячейки
Юрий_Ф Дата: Суббота, 26.08.2023, 10:35 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 777
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
Приветствую, знатоки!

Задача, вроде, простая, но что-то у меня не получается!
Из жизни авиации! :D

Дана табличка. Значение ячейки D3 зависит от B8 (а D10 - от D15). А в ячейках E, G, I, K, M, O и Q - в каждой идёт увеличение на час. (Или от B8 идёт увеличение соответственно на час, два, три и т.д.) Обратите внимание, что после 23 часов идёт 0 часов! Формула в ячейке E:
Код
=D3+1 (или D3+1:00)

почему-то не работает. Возможно, нужен другой формат.
В ячейках F, H, J, L, N, и P стоят минуты от ячейки B8. этим получилось.
Обратите внимание: если смена 7 часов, то есть ячейки в столбцах P и Q. При 6-часовой смене и цифры, и обводка исчезают. (С границами я справлюсь в УФ.)
К сообщению приложен файл: kniga12.xlsx (10.5 Kb)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Суббота, 26.08.2023, 10:38
 
Ответить
СообщениеПриветствую, знатоки!

Задача, вроде, простая, но что-то у меня не получается!
Из жизни авиации! :D

Дана табличка. Значение ячейки D3 зависит от B8 (а D10 - от D15). А в ячейках E, G, I, K, M, O и Q - в каждой идёт увеличение на час. (Или от B8 идёт увеличение соответственно на час, два, три и т.д.) Обратите внимание, что после 23 часов идёт 0 часов! Формула в ячейке E:
Код
=D3+1 (или D3+1:00)

почему-то не работает. Возможно, нужен другой формат.
В ячейках F, H, J, L, N, и P стоят минуты от ячейки B8. этим получилось.
Обратите внимание: если смена 7 часов, то есть ячейки в столбцах P и Q. При 6-часовой смене и цифры, и обводка исчезают. (С границами я справлюсь в УФ.)

Автор - Юрий_Ф
Дата добавления - 26.08.2023 в 10:35
Nic70y Дата: Суббота, 26.08.2023, 10:44 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
Код
=D3+1/24


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=D3+1/24

Автор - Nic70y
Дата добавления - 26.08.2023 в 10:44
Юрий_Ф Дата: Суббота, 26.08.2023, 11:43 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 777
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
Nic70y,

Да, спасибо!
А по 2му условию? Как сделать, чтобы в ячейке Q ничего не прописывалось, если разница между C15 и B15 6 часов?
Формула:
Код
=ЕСЛИ(СУММ(C15+1/24-B15+1/24)<7;"";O10+1/24)

удаляет все значения, независимо от разности!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеNic70y,

Да, спасибо!
А по 2му условию? Как сделать, чтобы в ячейке Q ничего не прописывалось, если разница между C15 и B15 6 часов?
Формула:
Код
=ЕСЛИ(СУММ(C15+1/24-B15+1/24)<7;"";O10+1/24)

удаляет все значения, независимо от разности!

Автор - Юрий_Ф
Дата добавления - 26.08.2023 в 11:43
Nic70y Дата: Суббота, 26.08.2023, 11:54 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(ЧАС(((C15<B15)+C15-B15))<7;"";O10+1/24)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(ЧАС(((C15<B15)+C15-B15))<7;"";O10+1/24)

Автор - Nic70y
Дата добавления - 26.08.2023 в 11:54
Юрий_Ф Дата: Суббота, 26.08.2023, 12:28 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 777
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
Nic70y

Замечательно! То, что нужно!
hands


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеNic70y

Замечательно! То, что нужно!
hands

Автор - Юрий_Ф
Дата добавления - 26.08.2023 в 12:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Увеличение на час от предыдущей ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!