Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/аналог СУММЕСЛИ без диапазона суммирования - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » аналог СУММЕСЛИ без диапазона суммирования (Формулы/Formulas)
аналог СУММЕСЛИ без диапазона суммирования
DrMini Дата: Вторник, 29.08.2023, 11:34 | Сообщение № 1
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте форумчане и гости форума!
Нужно подсчитать сумму ночных часов которые входят в общее число часов работы.
Если 17 часов то надо суммировать 2 часа.
Если 7 часов то суммировать нужно 6 часов.
[offtop]может потом ещё, чего придумают.[/offtop]
Доп. столбец делать не хочу.
Накидал вот такой вариант:
Код
=СУММЕСЛИ(A2:H2;17)/17*2+СУММЕСЛИ(A2:H2;7)/7*6

Получилось, как-то громоздко и некрасиво.
Подскажите, что можно сделать. Или оставить так?
К сообщению приложен файл: summesli_bez_diapazona_summiro.xlsx (9.2 Kb)
 
Ответить
СообщениеЗдравствуйте форумчане и гости форума!
Нужно подсчитать сумму ночных часов которые входят в общее число часов работы.
Если 17 часов то надо суммировать 2 часа.
Если 7 часов то суммировать нужно 6 часов.
[offtop]может потом ещё, чего придумают.[/offtop]
Доп. столбец делать не хочу.
Накидал вот такой вариант:
Код
=СУММЕСЛИ(A2:H2;17)/17*2+СУММЕСЛИ(A2:H2;7)/7*6

Получилось, как-то громоздко и некрасиво.
Подскажите, что можно сделать. Или оставить так?

Автор - DrMini
Дата добавления - 29.08.2023 в 11:34
Nic70y Дата: Вторник, 29.08.2023, 11:45 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
Или оставить так?
да норм, зачем усложнять
Код
=СЧЁТЕСЛИ(A2:H2;17)*2+СЧЁТЕСЛИ(A2:H2;7)*6


ЮMoney 41001841029809
 
Ответить
Сообщение
Или оставить так?
да норм, зачем усложнять
Код
=СЧЁТЕСЛИ(A2:H2;17)*2+СЧЁТЕСЛИ(A2:H2;7)*6

Автор - Nic70y
Дата добавления - 29.08.2023 в 11:45
DrMini Дата: Вторник, 29.08.2023, 11:47 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
норм, зачем усложнять

Спасибо за ответ. Думал можно, как то "укоротить".
Ой, только заметил изменение.
Спасибо.
Нет. Без делителя не правильно.


Сообщение отредактировал DrMini - Вторник, 29.08.2023, 11:52
 
Ответить
Сообщение
норм, зачем усложнять

Спасибо за ответ. Думал можно, как то "укоротить".
Ой, только заметил изменение.
Спасибо.
Нет. Без делителя не правильно.

Автор - DrMini
Дата добавления - 29.08.2023 в 11:47
Serge_007 Дата: Вторник, 29.08.2023, 12:00 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
может потом ещё, чего придумают.
А так?
Код
=СУММПРОИЗВ((A2:H2={17:7})*A1:H1)
Код
=СУММПРОИЗВ((A2:H2={17:7})*{2:6})


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
может потом ещё, чего придумают.
А так?
Код
=СУММПРОИЗВ((A2:H2={17:7})*A1:H1)
Код
=СУММПРОИЗВ((A2:H2={17:7})*{2:6})

Автор - Serge_007
Дата добавления - 29.08.2023 в 12:00
Nic70y Дата: Вторник, 29.08.2023, 12:09 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
Без делителя не правильно.
почему?


ЮMoney 41001841029809
 
Ответить
Сообщение
Без делителя не правильно.
почему?

Автор - Nic70y
Дата добавления - 29.08.2023 в 12:09
DrMini Дата: Вторник, 29.08.2023, 12:14 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS

Потому, что глаз "замылился" и вместо СЧЁТЕСЛИ оставил СУММЕСЛИ.
Спасибо ещё раз. Всё работает.
 
Ответить
Сообщение
Потому, что глаз "замылился" и вместо СЧЁТЕСЛИ оставил СУММЕСЛИ.
Спасибо ещё раз. Всё работает.

Автор - DrMini
Дата добавления - 29.08.2023 в 12:14
DrMini Дата: Вторник, 29.08.2023, 12:15 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
так?

Второй вариант просто бомба!
Спасибо.
 
Ответить
Сообщение
так?

Второй вариант просто бомба!
Спасибо.

Автор - DrMini
Дата добавления - 29.08.2023 в 12:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » аналог СУММЕСЛИ без диапазона суммирования (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!