Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Незаполненные ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Незаполненные ячейки (Формулы/Formulas)
Незаполненные ячейки
olya2084 Дата: Четверг, 31.08.2023, 01:15 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

Здравствуйте! На листе 2 нужна формула (без макроса): чтобы при заполнении хотя бы одной ячейки отображался статус "что-то заполнено", при всех незаполненных ячейках- "все пусто", а при заполнении всех ячеек- "все заполнено". Реально так сделать?
К сообщению приложен файл: 2153996.xls (27.5 Kb)
 
Ответить
СообщениеЗдравствуйте! На листе 2 нужна формула (без макроса): чтобы при заполнении хотя бы одной ячейки отображался статус "что-то заполнено", при всех незаполненных ячейках- "все пусто", а при заполнении всех ячеек- "все заполнено". Реально так сделать?

Автор - olya2084
Дата добавления - 31.08.2023 в 01:15
DrMini Дата: Четверг, 31.08.2023, 04:59 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Реально так сделать?

Да
Ваш (подправленный) вариант:
Код
=ЕСЛИ(СЧИТАТЬПУСТОТЫ(A2:H2)=8;"все пустые";ЕСЛИ(СЧИТАТЬПУСТОТЫ(A2:H2)=0;"все заполнено";"что-то заполнено"))

Как вариант:
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:H2;"")=0;"все заполнено";ЕСЛИ(СЧЁТЕСЛИ(A2:H2;"")=8;"все пусто";"что-то заполнено"))
К сообщению приложен файл: 3975782.xls (32.0 Kb)


Сообщение отредактировал DrMini - Четверг, 31.08.2023, 05:48
 
Ответить
Сообщение
Реально так сделать?

Да
Ваш (подправленный) вариант:
Код
=ЕСЛИ(СЧИТАТЬПУСТОТЫ(A2:H2)=8;"все пустые";ЕСЛИ(СЧИТАТЬПУСТОТЫ(A2:H2)=0;"все заполнено";"что-то заполнено"))

Как вариант:
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:H2;"")=0;"все заполнено";ЕСЛИ(СЧЁТЕСЛИ(A2:H2;"")=8;"все пусто";"что-то заполнено"))

Автор - DrMini
Дата добавления - 31.08.2023 в 04:59
прохожий2019 Дата: Четверг, 31.08.2023, 07:32 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1244
Репутация: 317 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ПРОСМОТР(СЧЁТЗ(A2:H2);{0;1;8};{"все пустые";"что-то заполнено";"все заполнено"})
 
Ответить
Сообщение
Код
=ПРОСМОТР(СЧЁТЗ(A2:H2);{0;1;8};{"все пустые";"что-то заполнено";"все заполнено"})

Автор - прохожий2019
Дата добавления - 31.08.2023 в 07:32
olya2084 Дата: Четверг, 31.08.2023, 07:47 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

DrMini, огромное спасибо!
 
Ответить
СообщениеDrMini, огромное спасибо!

Автор - olya2084
Дата добавления - 31.08.2023 в 07:47
olya2084 Дата: Четверг, 31.08.2023, 07:48 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

DrMini, и за ваш вариант премного благодарна!!
 
Ответить
СообщениеDrMini, и за ваш вариант премного благодарна!!

Автор - olya2084
Дата добавления - 31.08.2023 в 07:48
olya2084 Дата: Четверг, 31.08.2023, 07:49 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

прохожий2019, и вам спасибо!
 
Ответить
Сообщениепрохожий2019, и вам спасибо!

Автор - olya2084
Дата добавления - 31.08.2023 в 07:49
Светлый Дата: Четверг, 31.08.2023, 13:28 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1829
Репутация: 510 ±
Замечаний: 0% ±

Excel 2013, 2016
И мои 5 копеек
Код
=ВПР(СЧЁТЗ(A2:H2);{0;"все пустые":1;"что-то заполнено":8;"все заполнено"};2)
Код
=ТЕКСТ(СУММ((СЧЁТЗ(A2:H2)>{0;7})-0,5);"в\се заполнено;в\се пу\стые;\что-то заполнено")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИ мои 5 копеек
Код
=ВПР(СЧЁТЗ(A2:H2);{0;"все пустые":1;"что-то заполнено":8;"все заполнено"};2)
Код
=ТЕКСТ(СУММ((СЧЁТЗ(A2:H2)>{0;7})-0,5);"в\се заполнено;в\се пу\стые;\что-то заполнено")

Автор - Светлый
Дата добавления - 31.08.2023 в 13:28
olya2084 Дата: Среда, 06.09.2023, 22:54 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

DrMini, а если нужно перепрыгнуть/пропустить одну/две ячейки- как этот разрыв отразить в формуле? Например: с A2 по H2 и с K2 по L2?
К сообщению приложен файл: 3975782_1.xls (32.5 Kb)


Сообщение отредактировал olya2084 - Среда, 06.09.2023, 23:42
 
Ответить
СообщениеDrMini, а если нужно перепрыгнуть/пропустить одну/две ячейки- как этот разрыв отразить в формуле? Например: с A2 по H2 и с K2 по L2?

Автор - olya2084
Дата добавления - 06.09.2023 в 22:54
cmivadwot Дата: Четверг, 07.09.2023, 01:02 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 86 ±
Замечаний: 0% ±

365
olya2084, вариант с условным форматированием.. и другими вариациями...
К сообщению приложен файл: 9501545.xls (134.0 Kb)
 
Ответить
Сообщениеolya2084, вариант с условным форматированием.. и другими вариациями...

Автор - cmivadwot
Дата добавления - 07.09.2023 в 01:02
DrMini Дата: Четверг, 07.09.2023, 05:06 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
а если нужно перепрыгнуть/пропустить одну/две ячейки-

Я так полагаю это означает, что эти ячейки выкидываем из расчёта.
Тогда нужно просто изменить диапазон и поменять количество сравниваемых ячеек.
Например так:
Код
=ЕСЛИ(СЧЁТЗ(A2:H2;K2:L2)=0;"все пустые";ЕСЛИ(СЧЁТЗ(A2:H2;K2:L2)=10;"все заполнено";"что-то заполнено"))
 
Ответить
Сообщение
а если нужно перепрыгнуть/пропустить одну/две ячейки-

Я так полагаю это означает, что эти ячейки выкидываем из расчёта.
Тогда нужно просто изменить диапазон и поменять количество сравниваемых ячеек.
Например так:
Код
=ЕСЛИ(СЧЁТЗ(A2:H2;K2:L2)=0;"все пустые";ЕСЛИ(СЧЁТЗ(A2:H2;K2:L2)=10;"все заполнено";"что-то заполнено"))

Автор - DrMini
Дата добавления - 07.09.2023 в 05:06
olya2084 Дата: Четверг, 07.09.2023, 12:11 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

DrMini, большое спасибо! Очень оперативно выручили!
 
Ответить
СообщениеDrMini, большое спасибо! Очень оперативно выручили!

Автор - olya2084
Дата добавления - 07.09.2023 в 12:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Незаполненные ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!