Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка цен по дням - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка цен по дням (Формулы/Formulas)
Выборка цен по дням
arkadiypetrovichsheshukov Дата: Суббота, 02.09.2023, 15:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2019
Есть список цен по каждому дню, нужно перечислить каждый 6 и 23 день и цену в этот день, как в таблице во вложении
К сообщению приложен файл: struktura.xlsx (84.8 Kb)
 
Ответить
СообщениеЕсть список цен по каждому дню, нужно перечислить каждый 6 и 23 день и цену в этот день, как в таблице во вложении

Автор - arkadiypetrovichsheshukov
Дата добавления - 02.09.2023 в 15:53
прохожий2019 Дата: Суббота, 02.09.2023, 16:23 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1244
Репутация: 317 ±
Замечаний: 0% ±

365 Beta Channel
и вам здрасьте
Код
=ИНДЕКС($B$2:$B$3420;1+(СТРОКА(A1)-1)*6)
К сообщению приложен файл: 1117942.xlsx (86.3 Kb)
 
Ответить
Сообщениеи вам здрасьте
Код
=ИНДЕКС($B$2:$B$3420;1+(СТРОКА(A1)-1)*6)

Автор - прохожий2019
Дата добавления - 02.09.2023 в 16:23
i691198 Дата: Суббота, 02.09.2023, 16:33 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 85 ±
Замечаний: 0% ±

Что то не сходится в вашем примере. Как нужно считать это 6 и 23 дни? Смотрим для 6, если считать календарные дни, то от начальной даты 11.01.2010 это будут 17.01.2010 и 23.01.2010. Если ориентироваться не по дням, а по строкам таблицы, то 19.01.2010 и 27.01.2010 . И такая же картина с 23 днями. Поясняйте.
 
Ответить
СообщениеЧто то не сходится в вашем примере. Как нужно считать это 6 и 23 дни? Смотрим для 6, если считать календарные дни, то от начальной даты 11.01.2010 это будут 17.01.2010 и 23.01.2010. Если ориентироваться не по дням, а по строкам таблицы, то 19.01.2010 и 27.01.2010 . И такая же картина с 23 днями. Поясняйте.

Автор - i691198
Дата добавления - 02.09.2023 в 16:33
arkadiypetrovichsheshukov Дата: Суббота, 02.09.2023, 16:36 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2019
Здравствуйте!
@прохожий2019 Вах, какое изящное и простое решение! А то я думал ща, через индекс формула будет с километр! :D

Можете в личку номер телефона кинуть, я вам на "чай" зашлю в благодарность)

п.с. Извините, если принято здороваться: Я подумал, что это лишнее) Старался писать только по делу.


Сообщение отредактировал arkadiypetrovichsheshukov - Суббота, 02.09.2023, 16:37
 
Ответить
СообщениеЗдравствуйте!
@прохожий2019 Вах, какое изящное и простое решение! А то я думал ща, через индекс формула будет с километр! :D

Можете в личку номер телефона кинуть, я вам на "чай" зашлю в благодарность)

п.с. Извините, если принято здороваться: Я подумал, что это лишнее) Старался писать только по делу.

Автор - arkadiypetrovichsheshukov
Дата добавления - 02.09.2023 в 16:36
arkadiypetrovichsheshukov Дата: Суббота, 02.09.2023, 16:43 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2019
@i691198 Да, я мог напутать. каждый 6 день включая текущий.

прохожий2019 уже сделал, а вы как хотели сделать?) просто любопытно
 
Ответить
Сообщение@i691198 Да, я мог напутать. каждый 6 день включая текущий.

прохожий2019 уже сделал, а вы как хотели сделать?) просто любопытно

Автор - arkadiypetrovichsheshukov
Дата добавления - 02.09.2023 в 16:43
i691198 Дата: Суббота, 02.09.2023, 17:23 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 85 ±
Замечаний: 0% ±

Цитата arkadiypetrovichsheshukov, 02.09.2023 в 16:43, в сообщении № 5 ()
как хотели сделать?

Например так.
К сообщению приложен файл: struktura_1.xlsx (87.3 Kb)
 
Ответить
Сообщение
Цитата arkadiypetrovichsheshukov, 02.09.2023 в 16:43, в сообщении № 5 ()
как хотели сделать?

Например так.

Автор - i691198
Дата добавления - 02.09.2023 в 17:23
arkadiypetrovichsheshukov Дата: Суббота, 02.09.2023, 17:58 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2019
@i691198
Не-не, не так=)

Спасибо за попытку помочь! прохожий2019 сделал, как я хотел)
 
Ответить
Сообщение@i691198
Не-не, не так=)

Спасибо за попытку помочь! прохожий2019 сделал, как я хотел)

Автор - arkadiypetrovichsheshukov
Дата добавления - 02.09.2023 в 17:58
DrMini Дата: Суббота, 02.09.2023, 20:33 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Как вариант:
Код
=СМЕЩ(B$2;(СТРОКА()-2)*5;)

[offtop]без доп. столбцов.
А вдруг понадобится.[/offtop]
К сообщению приложен файл: 9706120.xlsx (85.4 Kb)


Сообщение отредактировал DrMini - Суббота, 02.09.2023, 20:40
 
Ответить
СообщениеКак вариант:
Код
=СМЕЩ(B$2;(СТРОКА()-2)*5;)

[offtop]без доп. столбцов.
А вдруг понадобится.[/offtop]

Автор - DrMini
Дата добавления - 02.09.2023 в 20:33
arkadiypetrovichsheshukov Дата: Суббота, 09.09.2023, 08:33 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2019
DrMini, ого)) круто!! спасибо! Ещё проще формула=) Блин, ребят вы вообще супер!!
 
Ответить
СообщениеDrMini, ого)) круто!! спасибо! Ещё проще формула=) Блин, ребят вы вообще супер!!

Автор - arkadiypetrovichsheshukov
Дата добавления - 09.09.2023 в 08:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка цен по дням (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!