Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Изменение данных на еженельной основе - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение данных на еженельной основе (Формулы/Formulas)
Изменение данных на еженельной основе
franc555kostin Дата: Воскресенье, 03.09.2023, 14:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Office16
Добрый день.
Во вложении привожу таблицу.
В таблице во вкладке "данные" указана информация с учетом недельных периодов.
Во вкладке "операции" данные дублируются но только по одной неделе (берется недельный период с 25.08.23 по 31.08.23)
Подскажите, пожалуйста, возможно ли сделать автоматическое замещение информации во вкладке "операции" учитывая недельный период???
Т.е. информация должна меняться с учетом выполнения операций каждую неделю (следующий должен отобразиться период с 01.09.23 по 07.09.23)
К сообщению приложен файл: svodnaja_tablica.xlsm (36.2 Kb)
 
Ответить
СообщениеДобрый день.
Во вложении привожу таблицу.
В таблице во вкладке "данные" указана информация с учетом недельных периодов.
Во вкладке "операции" данные дублируются но только по одной неделе (берется недельный период с 25.08.23 по 31.08.23)
Подскажите, пожалуйста, возможно ли сделать автоматическое замещение информации во вкладке "операции" учитывая недельный период???
Т.е. информация должна меняться с учетом выполнения операций каждую неделю (следующий должен отобразиться период с 01.09.23 по 07.09.23)

Автор - franc555kostin
Дата добавления - 03.09.2023 в 14:00
alexa1965 Дата: Понедельник, 04.09.2023, 14:15 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 343
Репутация: 55 ±
Замечаний: 0% ±

2003> 2019 >2016
Добрый день! В таблице листа данные добавил в столбце D номер недели по ISO, начиная с 5 строки, а на листе операции... в ячейке D1 соответственно номер недели по ISO на сегодня.
Для столбца В
Код
=ЕСЛИ(ИНДЕКС(Данные!B$1:B$1000;НАИМЕНЬШИЙ(ЕСЛИ((Данные!D$5:D$1000=операции...!D$1);СТРОКА(Данные!B$5:C$1000);1000);СТРОКА(A1)))=0;"";ИНДЕКС(Данные!B$1:B$1000;НАИМЕНЬШИЙ(ЕСЛИ((Данные!D$5:D$1000=операции...!D$1);СТРОКА(Данные!B$5:B$1000);1000);СТРОКА(A1))))
,
Для столбца С
Код
=ЕСЛИ(ИНДЕКС(Данные!C$1:C$1000;НАИМЕНЬШИЙ(ЕСЛИ((Данные!D$5:D$1000=операции...!D$1);СТРОКА(Данные!C$5:C$1000);1000);СТРОКА(A1)))=0;"";ИНДЕКС(Данные!C$1:C$1000;НАИМЕНЬШИЙ(ЕСЛИ((Данные!D$5:D$1000=операции...!D$1);СТРОКА(Данные!C$5:C$1000);1000);СТРОКА(A1))))
соответственно. Формулы массивные.
К сообщению приложен файл: 0176087.xlsm (35.5 Kb)


Главное не быть балабастиком

Сообщение отредактировал alexa1965 - Понедельник, 04.09.2023, 14:18
 
Ответить
СообщениеДобрый день! В таблице листа данные добавил в столбце D номер недели по ISO, начиная с 5 строки, а на листе операции... в ячейке D1 соответственно номер недели по ISO на сегодня.
Для столбца В
Код
=ЕСЛИ(ИНДЕКС(Данные!B$1:B$1000;НАИМЕНЬШИЙ(ЕСЛИ((Данные!D$5:D$1000=операции...!D$1);СТРОКА(Данные!B$5:C$1000);1000);СТРОКА(A1)))=0;"";ИНДЕКС(Данные!B$1:B$1000;НАИМЕНЬШИЙ(ЕСЛИ((Данные!D$5:D$1000=операции...!D$1);СТРОКА(Данные!B$5:B$1000);1000);СТРОКА(A1))))
,
Для столбца С
Код
=ЕСЛИ(ИНДЕКС(Данные!C$1:C$1000;НАИМЕНЬШИЙ(ЕСЛИ((Данные!D$5:D$1000=операции...!D$1);СТРОКА(Данные!C$5:C$1000);1000);СТРОКА(A1)))=0;"";ИНДЕКС(Данные!C$1:C$1000;НАИМЕНЬШИЙ(ЕСЛИ((Данные!D$5:D$1000=операции...!D$1);СТРОКА(Данные!C$5:C$1000);1000);СТРОКА(A1))))
соответственно. Формулы массивные.

Автор - alexa1965
Дата добавления - 04.09.2023 в 14:15
Nic70y Дата: Понедельник, 04.09.2023, 15:05 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
как понял [пт-чт]
К сообщению приложен файл: 234.xlsm (35.7 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениекак понял [пт-чт]

Автор - Nic70y
Дата добавления - 04.09.2023 в 15:05
franc555kostin Дата: Воскресенье, 10.09.2023, 12:09 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Office16
Nic70y, Большое спасибо за помощь, вариант просто в точку!!! specool
 
Ответить
СообщениеNic70y, Большое спасибо за помощь, вариант просто в точку!!! specool

Автор - franc555kostin
Дата добавления - 10.09.2023 в 12:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение данных на еженельной основе (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!