Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество месяцев с момента последней продажи - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество месяцев с момента последней продажи (Формулы/Formulas)
Количество месяцев с момента последней продажи
pertusin Дата: Понедельник, 04.09.2023, 11:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2016
Здравствуйте. Нужна формула для подсчета количества месяцев с билансом оборота фирмьі 0 с момента последней продажи. Например, сейчас август, последняя продажа бьіла в апреле. Ожиданмьій результат: 3. Прикрепляю файл (столбик V - ожидаемьій результат). Спасибо
К сообщению приложен файл: zeszyt1.xlsx (10.9 Kb)
 
Ответить
СообщениеЗдравствуйте. Нужна формула для подсчета количества месяцев с билансом оборота фирмьі 0 с момента последней продажи. Например, сейчас август, последняя продажа бьіла в апреле. Ожиданмьій результат: 3. Прикрепляю файл (столбик V - ожидаемьій результат). Спасибо

Автор - pertusin
Дата добавления - 04.09.2023 в 11:17
Nic70y Дата: Понедельник, 04.09.2023, 11:41 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
Например, сейчас август
например это как?
сейчас сентябрь
Код
=ЕСЛИОШИБКА(РАЗНДАТ(ПРОСМОТР(1;1/B2:T2;B$1:T$1);КОНМЕСЯЦА(СЕГОДНЯ();-2)+1;"m");СЧЁТ(B2:T2))
К сообщению приложен файл: 512.xlsx (12.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Например, сейчас август
например это как?
сейчас сентябрь
Код
=ЕСЛИОШИБКА(РАЗНДАТ(ПРОСМОТР(1;1/B2:T2;B$1:T$1);КОНМЕСЯЦА(СЕГОДНЯ();-2)+1;"m");СЧЁТ(B2:T2))

Автор - Nic70y
Дата добавления - 04.09.2023 в 11:41
китин Дата: Понедельник, 04.09.2023, 11:46 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 7019
Репутация: 1074 ±
Замечаний: 0% ±

Excel 2007;2010;2016
чисто по предложенному примеру
Код
=ЧИСЛСТОЛБ($B2:$T2)-ЕСЛИОШИБКА(ПРОСМОТР(9^99;ЕСЛИ($B2:$T2<>0;$B$2:$T$2);СТОЛБЕЦ($B$1:$T$1)-1);0)

формула массива
К сообщению приложен файл: zeszyt12345.xlsx (11.9 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениечисто по предложенному примеру
Код
=ЧИСЛСТОЛБ($B2:$T2)-ЕСЛИОШИБКА(ПРОСМОТР(9^99;ЕСЛИ($B2:$T2<>0;$B$2:$T$2);СТОЛБЕЦ($B$1:$T$1)-1);0)

формула массива

Автор - китин
Дата добавления - 04.09.2023 в 11:46
прохожий2019 Дата: Понедельник, 04.09.2023, 11:49 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1249
Репутация: 319 ±
Замечаний: 0% ±

365 Beta Channel
Код
=РАЗНДАТ(МАКС(МАКСЕСЛИ($B$1:$T$1;B2:T2;"<>0");ДАТА(2021;12;1));$X$1;"m")-1
К сообщению приложен файл: 1060964.xlsx (11.9 Kb)
 
Ответить
Сообщение
Код
=РАЗНДАТ(МАКС(МАКСЕСЛИ($B$1:$T$1;B2:T2;"<>0");ДАТА(2021;12;1));$X$1;"m")-1

Автор - прохожий2019
Дата добавления - 04.09.2023 в 11:49
Nic70y Дата: Понедельник, 04.09.2023, 12:06 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
ну если чисто по кол-ву столбцов
Код
=СТОЛБЕЦ()-ЕСЛИОШИБКА(ПРОСМОТР(1;1/B2:T2;СТОЛБЕЦ(B2:T2));1)-1
К сообщению приложен файл: 514.xlsx (12.1 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 04.09.2023, 12:08
 
Ответить
Сообщениену если чисто по кол-ву столбцов
Код
=СТОЛБЕЦ()-ЕСЛИОШИБКА(ПРОСМОТР(1;1/B2:T2;СТОЛБЕЦ(B2:T2));1)-1

Автор - Nic70y
Дата добавления - 04.09.2023 в 12:06
pertusin Дата: Понедельник, 04.09.2023, 12:14 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2016
Спасибо всем большое pray
 
Ответить
СообщениеСпасибо всем большое pray

Автор - pertusin
Дата добавления - 04.09.2023 в 12:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество месяцев с момента последней продажи (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!