Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подтягивание данных из другого листа - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтягивание данных из другого листа (Формулы/Formulas)
Подтягивание данных из другого листа
Dion Дата: Понедельник, 04.09.2023, 15:36 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
В продолжение предыдущей темы (согласно правилу одна тема - один вопрос).
Есть выгрузка (файл 1). Как сделать, чтобы при открытии файла 2 данные из ячейки U25:BR26 (файла 1) копировались в аналогичную U45:BS46 (файла 2), то есть проверялось условие "Основание передачи (сдачи) / получения (приемки)" и данные из первого файла подтягивались во второй? Фактически, чтобы номер договора появлялся в нужном месте в файле 2.
К сообщению приложен файл: 7959954.xls (18.0 Kb) · 3078999.xls (25.0 Kb)
 
Ответить
СообщениеВ продолжение предыдущей темы (согласно правилу одна тема - один вопрос).
Есть выгрузка (файл 1). Как сделать, чтобы при открытии файла 2 данные из ячейки U25:BR26 (файла 1) копировались в аналогичную U45:BS46 (файла 2), то есть проверялось условие "Основание передачи (сдачи) / получения (приемки)" и данные из первого файла подтягивались во второй? Фактически, чтобы номер договора появлялся в нужном месте в файле 2.

Автор - Dion
Дата добавления - 04.09.2023 в 15:36
Serge_007 Дата: Понедельник, 04.09.2023, 15:41 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
при открытии файла 2 данные из ячейки ... копировались в аналогичную
Копировать данные может только VBA (ну или пользователь Excel вручную)
Формулы же только возвращают значения, поэтому их (формулы) необходимо предварительно прописывать в нужном месте файла


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
при открытии файла 2 данные из ячейки ... копировались в аналогичную
Копировать данные может только VBA (ну или пользователь Excel вручную)
Формулы же только возвращают значения, поэтому их (формулы) необходимо предварительно прописывать в нужном месте файла

Автор - Serge_007
Дата добавления - 04.09.2023 в 15:41
Dion Дата: Понедельник, 04.09.2023, 15:58 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
У меня сейчас работает так: ='file:///C:/Users/nvsta/Desktop/1.xls'#$Лист_1.J15. Почти все данные хватает из файла 1, но с номером договора проблема: он смещается в зависимости от числа строк и не подтягивается.

Идея была реализовать как в примере ниже, но не хватило ума...
https://ru.extendoffice.com/documen....ok.html
К сообщению приложен файл: 5494351.xls (18.5 Kb) · 7270662.xls (28.0 Kb)


Сообщение отредактировал Dion - Понедельник, 04.09.2023, 16:03
 
Ответить
СообщениеУ меня сейчас работает так: ='file:///C:/Users/nvsta/Desktop/1.xls'#$Лист_1.J15. Почти все данные хватает из файла 1, но с номером договора проблема: он смещается в зависимости от числа строк и не подтягивается.

Идея была реализовать как в примере ниже, но не хватило ума...
https://ru.extendoffice.com/documen....ok.html

Автор - Dion
Дата добавления - 04.09.2023 в 15:58
Serge_007 Дата: Понедельник, 04.09.2023, 16:12 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Если формулой (с функцией ВПР), то нужен анкор - ориентир, который смещается в зависимости от числа строк одинаково с искомым


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЕсли формулой (с функцией ВПР), то нужен анкор - ориентир, который смещается в зависимости от числа строк одинаково с искомым

Автор - Serge_007
Дата добавления - 04.09.2023 в 16:12
MikeVol Дата: Понедельник, 04.09.2023, 20:52 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 315
Репутация: 61 ±
Замечаний: 0% ±

Excel LTSC 2021 EN
Dion, Здравствуйте. Я так понимаю что в дальнейшем будете готовый (заполненый) документ выводить на печать или сохранять их отдельно. Если да, то вот не плохой пример как можно это сделать (образец) но надо будет вам сделать свой цаблон по типу как в данной теме: Создание файлов exel по шаблону
Там ТС подтягивает данные с базы в свой шаблон и сохраняет их как отдельные листы. Скачайте файл пример от туда, поймёте что к чему. Есть и продолжение той темы: Макрос на сохранение выделенных листов в отдельные книги
Там ТС сохраняет заполненый шаблон как отдельные книги. Это как вариант. Надумаете, сделайте шаблон и обращайтесь, чем-то мы тут поможем. Удачи.


Ученик.
 
Ответить
СообщениеDion, Здравствуйте. Я так понимаю что в дальнейшем будете готовый (заполненый) документ выводить на печать или сохранять их отдельно. Если да, то вот не плохой пример как можно это сделать (образец) но надо будет вам сделать свой цаблон по типу как в данной теме: Создание файлов exel по шаблону
Там ТС подтягивает данные с базы в свой шаблон и сохраняет их как отдельные листы. Скачайте файл пример от туда, поймёте что к чему. Есть и продолжение той темы: Макрос на сохранение выделенных листов в отдельные книги
Там ТС сохраняет заполненый шаблон как отдельные книги. Это как вариант. Надумаете, сделайте шаблон и обращайтесь, чем-то мы тут поможем. Удачи.

Автор - MikeVol
Дата добавления - 04.09.2023 в 20:52
cmivadwot Дата: Понедельник, 04.09.2023, 23:52 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 86 ±
Замечаний: 0% ±

365
Dion, по первым двум файлам (сложил в один) ВПР через доп столбцы ..... с объединенными ячейками ВПР не очень....
К сообщению приложен файл: aprprprpaproprolprlprolpro.xls (53.0 Kb)
 
Ответить
СообщениеDion, по первым двум файлам (сложил в один) ВПР через доп столбцы ..... с объединенными ячейками ВПР не очень....

Автор - cmivadwot
Дата добавления - 04.09.2023 в 23:52
Dion Дата: Вторник, 05.09.2023, 10:03 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Большое спасибо всем за помощь!
 
Ответить
СообщениеБольшое спасибо всем за помощь!

Автор - Dion
Дата добавления - 05.09.2023 в 10:03
Dion Дата: Вторник, 05.09.2023, 15:03 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
ВПР через доп столбцы


Небольшое дополнение: как будет выглядеть ваша формула
Код
=ВПР(C26;$исходник.CB:CC;2;ЛОЖЬ())

если необходимо брать не договор, а спецификацию на листе "исходник"? То есть чтобы значения бралось не просто из второго столбца заданного диапазона (как сейчас), а ячейкой выше. Возможно ли тут как-то реализовать смещение?
К сообщению приложен файл: 2931909.xls (38.5 Kb)


Сообщение отредактировал Serge_007 - Вторник, 05.09.2023, 15:19
 
Ответить
Сообщение
ВПР через доп столбцы


Небольшое дополнение: как будет выглядеть ваша формула
Код
=ВПР(C26;$исходник.CB:CC;2;ЛОЖЬ())

если необходимо брать не договор, а спецификацию на листе "исходник"? То есть чтобы значения бралось не просто из второго столбца заданного диапазона (как сейчас), а ячейкой выше. Возможно ли тут как-то реализовать смещение?

Автор - Dion
Дата добавления - 05.09.2023 в 15:03
cmivadwot Дата: Вторник, 05.09.2023, 19:03 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 86 ±
Замечаний: 0% ±

365
Dion, предлагаю спецификацию правее писать, а не сверху.. и по той же схеме...
Код
=ВПР(C26;исходник!CB:CD;3;ЛОЖЬ)
К сообщению приложен файл: 67757ghjghjghj33.xls (53.5 Kb)


Сообщение отредактировал cmivadwot - Вторник, 05.09.2023, 19:20
 
Ответить
СообщениеDion, предлагаю спецификацию правее писать, а не сверху.. и по той же схеме...
Код
=ВПР(C26;исходник!CB:CD;3;ЛОЖЬ)

Автор - cmivadwot
Дата добавления - 05.09.2023 в 19:03
cmivadwot Дата: Вторник, 05.09.2023, 19:09 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 86 ±
Замечаний: 0% ±

365
Небольшое дополнение: как будет выглядеть ваша формула

=ВПР(C26;$исходник.CB:CC;2;ЛОЖЬ())

Код
=ВПР(C26;исходник!CB:CC;2;ЛОЖЬ)
или
Код
=ВПР("Основание передачи (сдачи) / получения (приемки)";исходник!CB:CC;2;ЛОЖЬ)
 
Ответить
Сообщение
Небольшое дополнение: как будет выглядеть ваша формула

=ВПР(C26;$исходник.CB:CC;2;ЛОЖЬ())

Код
=ВПР(C26;исходник!CB:CC;2;ЛОЖЬ)
или
Код
=ВПР("Основание передачи (сдачи) / получения (приемки)";исходник!CB:CC;2;ЛОЖЬ)

Автор - cmivadwot
Дата добавления - 05.09.2023 в 19:09
cmivadwot Дата: Вторник, 05.09.2023, 23:02 | Сообщение № 11
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 86 ±
Замечаний: 0% ±

365
Dion, и вариант через индекс с поискпоз. При сохранении начал ругаться.. наверно в старых версиях не поддерживается.. сохранил в .xlsx
а откуда берется Спецификация.... чтоб ее подтянуть. Да наверно и сами разберетесь.
К сообщению приложен файл: dzhehdzhehdzhehdzheh.xlsx (42.5 Kb)


Сообщение отредактировал cmivadwot - Вторник, 05.09.2023, 23:07
 
Ответить
СообщениеDion, и вариант через индекс с поискпоз. При сохранении начал ругаться.. наверно в старых версиях не поддерживается.. сохранил в .xlsx
а откуда берется Спецификация.... чтоб ее подтянуть. Да наверно и сами разберетесь.

Автор - cmivadwot
Дата добавления - 05.09.2023 в 23:02
Dion Дата: Среда, 06.09.2023, 12:46 | Сообщение № 12
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
вариант через индекс с поискпоз


Огромное спасибо. Никогда этим не пользовался, буду разбираться.
 
Ответить
Сообщение
вариант через индекс с поискпоз


Огромное спасибо. Никогда этим не пользовался, буду разбираться.

Автор - Dion
Дата добавления - 06.09.2023 в 12:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтягивание данных из другого листа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!