Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проставить три уровня родителя строк - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проставить три уровня родителя строк (Формулы/Formulas)
Проставить три уровня родителя строк
sbo Дата: Среда, 06.09.2023, 08:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2019
Есть коды лекарств АТС пять уровней. и нужно проставить родителя каждого уровня не только кодом но и еще и названием.
Кодом уже сделано а вот как еще названия поставить ???
https://www.whocc.no/atc_ddd_index/?code=A01&showdescription=no
сам файл
К сообщению приложен файл: ATC.xlsx (141.9 Kb)
 
Ответить
СообщениеЕсть коды лекарств АТС пять уровней. и нужно проставить родителя каждого уровня не только кодом но и еще и названием.
Кодом уже сделано а вот как еще названия поставить ???
https://www.whocc.no/atc_ddd_index/?code=A01&showdescription=no
сам файл

Автор - sbo
Дата добавления - 06.09.2023 в 08:30
Serge_007 Дата: Среда, 06.09.2023, 09:21 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
нужно проставить родителя
Куда поставить? По какому принципу? В файле руками внесите желаемый результат для примера
Пары строк достаточно, а не полторы тысячи непонятно зачем приложенных к посту


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
нужно проставить родителя
Куда поставить? По какому принципу? В файле руками внесите желаемый результат для примера
Пары строк достаточно, а не полторы тысячи непонятно зачем приложенных к посту

Автор - Serge_007
Дата добавления - 06.09.2023 в 09:21
sbo Дата: Среда, 06.09.2023, 09:24 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2019
В графе родитель руками внес.
 
Ответить
СообщениеВ графе родитель руками внес.

Автор - sbo
Дата добавления - 06.09.2023 в 09:24
sbo Дата: Среда, 06.09.2023, 09:26 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2019
У A01 -родитель с кодом А , и нужно Родителя указать по наименованию ALIMENTARY TRACT AND METABOLISM
у A01A -родитель с кодом A01 - STOMATOLOGICAL PREPARATIONS
 
Ответить
СообщениеУ A01 -родитель с кодом А , и нужно Родителя указать по наименованию ALIMENTARY TRACT AND METABOLISM
у A01A -родитель с кодом A01 - STOMATOLOGICAL PREPARATIONS

Автор - sbo
Дата добавления - 06.09.2023 в 09:26
sbo Дата: Среда, 06.09.2023, 09:30 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2019
Обрезанный файл
К сообщению приложен файл: atc_obrez.xlsx (12.9 Kb)
 
Ответить
СообщениеОбрезанный файл

Автор - sbo
Дата добавления - 06.09.2023 в 09:30
Serge_007 Дата: Среда, 06.09.2023, 09:33 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
У A01 -родитель с кодом А
,
у A01A -родитель с кодом A01

Где это указано в таблице?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
У A01 -родитель с кодом А
,
у A01A -родитель с кодом A01

Где это указано в таблице?

Автор - Serge_007
Дата добавления - 06.09.2023 в 09:33
sbo Дата: Среда, 06.09.2023, 09:39 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2019
По первой букве Кода определяется родитель группа первого уровня. По первой букве и двум цифрам родитель группа второго уровня. По первой букве и двум цифрам и букве родитель группа третьего уровня.
 
Ответить
СообщениеПо первой букве Кода определяется родитель группа первого уровня. По первой букве и двум цифрам родитель группа второго уровня. По первой букве и двум цифрам и букве родитель группа третьего уровня.

Автор - sbo
Дата добавления - 06.09.2023 в 09:39
Serge_007 Дата: Среда, 06.09.2023, 09:47 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Код
=ВПР(ВЫБОР(ДЛСТР(B2);;;ЛЕВБ(B2);ЛЕВБ(B2;3));B$2:C$23;2;)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ВПР(ВЫБОР(ДЛСТР(B2);;;ЛЕВБ(B2);ЛЕВБ(B2;3));B$2:C$23;2;)

Автор - Serge_007
Дата добавления - 06.09.2023 в 09:47
sbo Дата: Среда, 06.09.2023, 09:49 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2019
Большое спасибо !!! сработало.
 
Ответить
СообщениеБольшое спасибо !!! сработало.

Автор - sbo
Дата добавления - 06.09.2023 в 09:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проставить три уровня родителя строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!