Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт ячеек в заданном диапазоне - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт ячеек в заданном диапазоне (Формулы/Formulas)
Подсчёт ячеек в заданном диапазоне
DrMini Дата: Четверг, 07.09.2023, 07:35 | Сообщение № 1
Группа: Проверенные
Ранг: Старожил
Сообщений: 1575
Репутация: 180 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте Форумчане и Гости форума.
Задался вопросом:
Как подсчитать количество ячеек если известен диапазон?
Например:
Для подсчёта количества ячеек в диапазоне A2:E2 применил формулу:
Код
=СЧЁТЗ(A2:E2)+СЧИТАТЬПУСТОТЫ(A2:E2)

Для подсчёта количества ячеек в диапазонах A2:E2 и G2:H2 применил формулу:
Код
=СЧЁТЗ(A2:E2;G2:H2)+СЧИТАТЬПУСТОТЫ(A2:E2)+СЧИТАТЬПУСТОТЫ(G2:H2)

формула получается громоздкая и неудобная.
А если диапазонов будет ещё больше?
Подскажите пожалуйста если есть более удобный вариант.
Макрос неинтересен.
Ячейки могут быть и пустые и не пустые и с формулой.
К сообщению приложен файл: podschjot_jacheek_diapazona.xlsx (9.4 Kb)
 
Ответить
СообщениеЗдравствуйте Форумчане и Гости форума.
Задался вопросом:
Как подсчитать количество ячеек если известен диапазон?
Например:
Для подсчёта количества ячеек в диапазоне A2:E2 применил формулу:
Код
=СЧЁТЗ(A2:E2)+СЧИТАТЬПУСТОТЫ(A2:E2)

Для подсчёта количества ячеек в диапазонах A2:E2 и G2:H2 применил формулу:
Код
=СЧЁТЗ(A2:E2;G2:H2)+СЧИТАТЬПУСТОТЫ(A2:E2)+СЧИТАТЬПУСТОТЫ(G2:H2)

формула получается громоздкая и неудобная.
А если диапазонов будет ещё больше?
Подскажите пожалуйста если есть более удобный вариант.
Макрос неинтересен.
Ячейки могут быть и пустые и не пустые и с формулой.

Автор - DrMini
Дата добавления - 07.09.2023 в 07:35
Serge_007 Дата: Четверг, 07.09.2023, 09:16 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16455
Репутация: 2746 ±
Замечаний: ±

Excel 2016
Привет

Для одномерного горизонтального диапазона можно так:
Код
=ЧИСЛСТОЛБ(A2:E2)+ЧИСЛСТОЛБ(G2:H2)


Макрос неинтересен
А жаль. Макросом можно было бы считать ячейки с границами, т.е. выделяем A2:H2 и получаем 7


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеПривет

Для одномерного горизонтального диапазона можно так:
Код
=ЧИСЛСТОЛБ(A2:E2)+ЧИСЛСТОЛБ(G2:H2)


Макрос неинтересен
А жаль. Макросом можно было бы считать ячейки с границами, т.е. выделяем A2:H2 и получаем 7

Автор - Serge_007
Дата добавления - 07.09.2023 в 09:16
Nic70y Дата: Четверг, 07.09.2023, 09:18 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 8670
Репутация: 2230 ±
Замечаний: 0% ±

Excel 2010
вариант
Код
=СУММПРОИЗВ(СЧЁТЗ(A2:E2&"";G2:H2&""))
или массивная
Код
=СЧЁТЗ(A2:E2&"";G2:H2&"")


ЮMoney 41001841029809
 
Ответить
Сообщениевариант
Код
=СУММПРОИЗВ(СЧЁТЗ(A2:E2&"";G2:H2&""))
или массивная
Код
=СЧЁТЗ(A2:E2&"";G2:H2&"")

Автор - Nic70y
Дата добавления - 07.09.2023 в 09:18
msi2102 Дата: Четверг, 07.09.2023, 12:32 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 410
Репутация: 129 ±
Замечаний: 0% ±

Excel 2007
Для одномерного горизонтального диапазона можно так:
А так для многомерного :D
Код
=ЧИСЛСТОЛБ(A2:E3)*ЧСТРОК(A2:E3)+ЧИСЛСТОЛБ(G2:H3)*ЧСТРОК(G2:H3)
 
Ответить
Сообщение
Для одномерного горизонтального диапазона можно так:
А так для многомерного :D
Код
=ЧИСЛСТОЛБ(A2:E3)*ЧСТРОК(A2:E3)+ЧИСЛСТОЛБ(G2:H3)*ЧСТРОК(G2:H3)

Автор - msi2102
Дата добавления - 07.09.2023 в 12:32
DrMini Дата: Четверг, 07.09.2023, 13:27 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1575
Репутация: 180 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Макросом можно было бы считать ячейки с границами

Большое спасибо за вариант. Как будет нужен вариант на VBA — буду знать к кому обратиться.
:D
 
Ответить
Сообщение
Макросом можно было бы считать ячейки с границами

Большое спасибо за вариант. Как будет нужен вариант на VBA — буду знать к кому обратиться.
:D

Автор - DrMini
Дата добавления - 07.09.2023 в 13:27
DrMini Дата: Четверг, 07.09.2023, 13:28 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1575
Репутация: 180 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Nic70y, и msi2102,
Большое спасибо Вам за Ваши варианты.
 
Ответить
СообщениеNic70y, и msi2102,
Большое спасибо Вам за Ваши варианты.

Автор - DrMini
Дата добавления - 07.09.2023 в 13:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт ячеек в заданном диапазоне (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!