Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма ячеек с привязкой к дате - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма ячеек с привязкой к дате (Формулы/Formulas)
Сумма ячеек с привязкой к дате
Poligraf510 Дата: Воскресенье, 10.09.2023, 08:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем добрый день. Есть простенькая табличка учета прихода и расхода товара. Товар разной даты изготовления. Как с помощью формул подсчитать расход определенной даты. Заранее спасибо
К сообщению приложен файл: uchet.xlsx (16.4 Kb)
 
Ответить
СообщениеВсем добрый день. Есть простенькая табличка учета прихода и расхода товара. Товар разной даты изготовления. Как с помощью формул подсчитать расход определенной даты. Заранее спасибо

Автор - Poligraf510
Дата добавления - 10.09.2023 в 08:46
DrMini Дата: Воскресенье, 10.09.2023, 09:32 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Как с помощью формул подсчитать расход определенной даты

Так?
Код
=СУММПРОИЗВ((Расход!$C$3:$C$7=D3)*(Расход!$A$3:$A$7=A3)*Расход!$B$3:$B$7+(Расход!$E$3:$E$7=D3)*(Расход!$A$3:$A$7=A3)*Расход!$D$3:$D$7+(Расход!$G$3:$G$7=D3)*(Расход!$A$3:$A$7=A3)*Расход!$F$3:$F$7+(Расход!$I$3:$I$7=D3)*(Расход!$A$3:$A$7=A3)*Расход!$H$3:$H$7)

Нули не скрывал. Думаю если так подойдёт то убрать нули в пустых ячейках не сложно.
К сообщению приложен файл: 3154802.xlsx (19.3 Kb)
 
Ответить
Сообщение
Как с помощью формул подсчитать расход определенной даты

Так?
Код
=СУММПРОИЗВ((Расход!$C$3:$C$7=D3)*(Расход!$A$3:$A$7=A3)*Расход!$B$3:$B$7+(Расход!$E$3:$E$7=D3)*(Расход!$A$3:$A$7=A3)*Расход!$D$3:$D$7+(Расход!$G$3:$G$7=D3)*(Расход!$A$3:$A$7=A3)*Расход!$F$3:$F$7+(Расход!$I$3:$I$7=D3)*(Расход!$A$3:$A$7=A3)*Расход!$H$3:$H$7)

Нули не скрывал. Думаю если так подойдёт то убрать нули в пустых ячейках не сложно.

Автор - DrMini
Дата добавления - 10.09.2023 в 09:32
прохожий2019 Дата: Воскресенье, 10.09.2023, 09:39 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1240
Репутация: 317 ±
Замечаний: 0% ±

365 Beta Channel
простенькая
гм, ну какая организация данных, такая и формула
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(ЕСЛИОШИБКА(--ИНДЕКС(Расход!$B$3:$I$7;ПОИСКПОЗ(A3;Расход!$A$3:$A$7;););0)*(ИНДЕКС(Расход!$C$3:$J$7;ПОИСКПОЗ(A3;Расход!$A$3:$A$7;);)=D3));0)
К сообщению приложен файл: uchet_1.xlsx (24.5 Kb)
 
Ответить
Сообщение
простенькая
гм, ну какая организация данных, такая и формула
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(ЕСЛИОШИБКА(--ИНДЕКС(Расход!$B$3:$I$7;ПОИСКПОЗ(A3;Расход!$A$3:$A$7;););0)*(ИНДЕКС(Расход!$C$3:$J$7;ПОИСКПОЗ(A3;Расход!$A$3:$A$7;);)=D3));0)

Автор - прохожий2019
Дата добавления - 10.09.2023 в 09:39
Poligraf510 Дата: Воскресенье, 10.09.2023, 09:45 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
DrMini, прохожий2019, Спасибо, вроде все работает
 
Ответить
СообщениеDrMini, прохожий2019, Спасибо, вроде все работает

Автор - Poligraf510
Дата добавления - 10.09.2023 в 09:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма ячеек с привязкой к дате (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!