Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перечень полей в дату работ - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перечень полей в дату работ (Формулы/Formulas)
Перечень полей в дату работ
zaak88 Дата: Четверг, 14.09.2023, 09:29 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 173
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Добрый день, гуру. Прошу помочь с задачкой: нужно вытянуть перечень полей по дате работ и подразделению, вывести через запятую несколько все позиции в данную дату.
К сообщению приложен файл: 2228274.xlsx (34.2 Kb)


Сообщение отредактировал zaak88 - Четверг, 14.09.2023, 09:30
 
Ответить
СообщениеДобрый день, гуру. Прошу помочь с задачкой: нужно вытянуть перечень полей по дате работ и подразделению, вывести через запятую несколько все позиции в данную дату.

Автор - zaak88
Дата добавления - 14.09.2023 в 09:29
alexa1965 Дата: Четверг, 14.09.2023, 09:34 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 343
Репутация: 55 ±
Замечаний: 0% ±

2003> 2019 >2016
Добрый день! А как и где это должно выглядеть. Покажите в файле что бы Вы хотели получить и на каком листе.


Главное не быть балабастиком
 
Ответить
СообщениеДобрый день! А как и где это должно выглядеть. Покажите в файле что бы Вы хотели получить и на каком листе.

Автор - alexa1965
Дата добавления - 14.09.2023 в 09:34
zaak88 Дата: Четверг, 14.09.2023, 09:59 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 173
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
alexa1965, на листе 1 в 3-ем столбце, данные из листа 2. атрибуты - 1и 2 столбец.
 
Ответить
Сообщениеalexa1965, на листе 1 в 3-ем столбце, данные из листа 2. атрибуты - 1и 2 столбец.

Автор - zaak88
Дата добавления - 14.09.2023 в 09:59
alexa1965 Дата: Четверг, 14.09.2023, 11:01 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 343
Репутация: 55 ±
Замечаний: 0% ±

2003> 2019 >2016
Ну как понял массивная этажерка
Код
=ИНДЕКС(Лист2!C$1:C$10000;НАИМЕНЬШИЙ(ЕСЛИ((Лист2!A$2:N$10000=B1)*(Лист2!B$2:B$10000=A1);СТРОКА(Лист2!C$2:C$10000);10000);СТРОКА(A$1)))&", "&ИНДЕКС(Лист2!C$1:C$10000;НАИМЕНЬШИЙ(ЕСЛИ((Лист2!A$2:N$10000=B1)*(Лист2!B$2:B$10000=A1);СТРОКА(Лист2!C$2:C$10000);10000);СТРОКА(A$2)))&", "&ИНДЕКС(Лист2!C$1:C$10000;НАИМЕНЬШИЙ(ЕСЛИ((Лист2!A$2:N$10000=B1)*(Лист2!B$2:B$10000=A1);СТРОКА(Лист2!C$2:C$10000);10000);СТРОКА(A$3)))&", "&ИНДЕКС(Лист2!C$1:C$10000;НАИМЕНЬШИЙ(ЕСЛИ((Лист2!A$2:N$10000=B1)*(Лист2!B$2:B$10000=A1);СТРОКА(Лист2!C$2:C$10000);10000);СТРОКА(A$4)))&", "&ИНДЕКС(Лист2!C$1:C$10000;НАИМЕНЬШИЙ(ЕСЛИ((Лист2!A$2:N$10000=B1)*(Лист2!B$2:B$10000=A1);СТРОКА(Лист2!C$2:C$10000);10000);СТРОКА(A$5)))
для 5 искомых значений на дату
К сообщению приложен файл: 9525476.xlsx (36.9 Kb)


Главное не быть балабастиком
 
Ответить
СообщениеНу как понял массивная этажерка
Код
=ИНДЕКС(Лист2!C$1:C$10000;НАИМЕНЬШИЙ(ЕСЛИ((Лист2!A$2:N$10000=B1)*(Лист2!B$2:B$10000=A1);СТРОКА(Лист2!C$2:C$10000);10000);СТРОКА(A$1)))&", "&ИНДЕКС(Лист2!C$1:C$10000;НАИМЕНЬШИЙ(ЕСЛИ((Лист2!A$2:N$10000=B1)*(Лист2!B$2:B$10000=A1);СТРОКА(Лист2!C$2:C$10000);10000);СТРОКА(A$2)))&", "&ИНДЕКС(Лист2!C$1:C$10000;НАИМЕНЬШИЙ(ЕСЛИ((Лист2!A$2:N$10000=B1)*(Лист2!B$2:B$10000=A1);СТРОКА(Лист2!C$2:C$10000);10000);СТРОКА(A$3)))&", "&ИНДЕКС(Лист2!C$1:C$10000;НАИМЕНЬШИЙ(ЕСЛИ((Лист2!A$2:N$10000=B1)*(Лист2!B$2:B$10000=A1);СТРОКА(Лист2!C$2:C$10000);10000);СТРОКА(A$4)))&", "&ИНДЕКС(Лист2!C$1:C$10000;НАИМЕНЬШИЙ(ЕСЛИ((Лист2!A$2:N$10000=B1)*(Лист2!B$2:B$10000=A1);СТРОКА(Лист2!C$2:C$10000);10000);СТРОКА(A$5)))
для 5 искомых значений на дату

Автор - alexa1965
Дата добавления - 14.09.2023 в 11:01
китин Дата: Четверг, 14.09.2023, 11:24 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 7014
Репутация: 1073 ±
Замечаний: 0% ±

Excel 2007;2010;2016
PQ всемогущий
К сообщению приложен файл: PQ.xlsx (46.9 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеPQ всемогущий

Автор - китин
Дата добавления - 14.09.2023 в 11:24
NikitaDvorets Дата: Четверг, 14.09.2023, 11:48 | Сообщение № 6
Группа: Авторы
Ранг: Ветеран
Сообщений: 557
Репутация: 126 ±
Замечаний: 0% ±

Excel 2019
zaak88,
Вариант доп. столбца и пользовательской функции.
К сообщению приложен файл: request_agrodata_14_09_2023.xlsm (94.2 Kb)


Сообщение отредактировал NikitaDvorets - Четверг, 14.09.2023, 12:13
 
Ответить
Сообщениеzaak88,
Вариант доп. столбца и пользовательской функции.

Автор - NikitaDvorets
Дата добавления - 14.09.2023 в 11:48
zaak88 Дата: Четверг, 14.09.2023, 14:32 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 173
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Спасибо большое. Воспользовался вариантом китин,
 
Ответить
СообщениеСпасибо большое. Воспользовался вариантом китин,

Автор - zaak88
Дата добавления - 14.09.2023 в 14:32
alexa1965 Дата: Четверг, 14.09.2023, 15:40 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 343
Репутация: 55 ±
Замечаний: 0% ±

2003> 2019 >2016
Воспользовался вариантом китин,

Тоже согласен с Вами, гораздо точнее и удобнее. Немного накосячил в формуле. Надо учиться и еще раз учиться...


Главное не быть балабастиком

Сообщение отредактировал alexa1965 - Четверг, 14.09.2023, 15:40
 
Ответить
Сообщение
Воспользовался вариантом китин,

Тоже согласен с Вами, гораздо точнее и удобнее. Немного накосячил в формуле. Надо учиться и еще раз учиться...

Автор - alexa1965
Дата добавления - 14.09.2023 в 15:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перечень полей в дату работ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!