Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Дополнительные условия(несколько критерий) к поиску значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Дополнительные условия(несколько критерий) к поиску значения
novichok0417 Дата: Вторник, 26.09.2023, 10:13 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.
Нужна помощь по формуле поиска значения(номера строки) условия больше/меньше, причем больше/меньше в разных строках может менятся (в одном случа больше меньше 200, в другом больше меньше 150) Пример в ексель выложил.
Поиск номера строки Я выпонил с помощью команды СУММПРОИЗВ (НО БЕЗ УСЛОВИЯ больше/меньше 200, больше/меньше 150). Как сделать поиск по дополнительным условиям?? Заранее спасибо
К сообщению приложен файл: primer.xlsx (10.5 Kb)


Сообщение отредактировал novichok0417 - Вторник, 26.09.2023, 10:15
 
Ответить
СообщениеЗдравствуйте.
Нужна помощь по формуле поиска значения(номера строки) условия больше/меньше, причем больше/меньше в разных строках может менятся (в одном случа больше меньше 200, в другом больше меньше 150) Пример в ексель выложил.
Поиск номера строки Я выпонил с помощью команды СУММПРОИЗВ (НО БЕЗ УСЛОВИЯ больше/меньше 200, больше/меньше 150). Как сделать поиск по дополнительным условиям?? Заранее спасибо

Автор - novichok0417
Дата добавления - 26.09.2023 в 10:13
Nic70y Дата: Вторник, 26.09.2023, 10:34 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8801
Репутация: 2295 ±
Замечаний: 0% ±

Excel 2010
так
Код
=СУММПРОИЗВ((B15=$A$3:$A$12)*(B16=$B$3:$B$12)*(B18=$D$3:$D$12)*$E$3:$E$12*СЧЁТЕСЛИ(B17;C3:C12))
надо?


ЮMoney 41001841029809
 
Ответить
Сообщениетак
Код
=СУММПРОИЗВ((B15=$A$3:$A$12)*(B16=$B$3:$B$12)*(B18=$D$3:$D$12)*$E$3:$E$12*СЧЁТЕСЛИ(B17;C3:C12))
надо?

Автор - Nic70y
Дата добавления - 26.09.2023 в 10:34
novichok0417 Дата: Вторник, 26.09.2023, 10:42 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Спасибо, поиск работает. А если допустим разные радиусы загиба в строках 200м и 150м? Есть возмождность поиска номера строки??
К сообщению приложен файл: 8092880.xlsx (10.6 Kb)
 
Ответить
СообщениеNic70y, Спасибо, поиск работает. А если допустим разные радиусы загиба в строках 200м и 150м? Есть возмождность поиска номера строки??

Автор - novichok0417
Дата добавления - 26.09.2023 в 10:42
Arti3223 Дата: Вторник, 26.09.2023, 10:46 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 10 ±
Замечаний: 0% ±

2016
Как вариант, сразу расценку вытаскивать

Код
=ИНДЕКС($F$3:$I$12;АГРЕГАТ(15;6;СТРОКА($J$1:$J$10)/СЧЁТЕСЛИ(B17;C3:C12)/($D$3:$D$12=B18)/($B$3:$B$12=B16)/($A$3:$A$12=B15);1);ПОИСКПОЗ(B19;F2:I2;))
 
Ответить
СообщениеКак вариант, сразу расценку вытаскивать

Код
=ИНДЕКС($F$3:$I$12;АГРЕГАТ(15;6;СТРОКА($J$1:$J$10)/СЧЁТЕСЛИ(B17;C3:C12)/($D$3:$D$12=B18)/($B$3:$B$12=B16)/($A$3:$A$12=B15);1);ПОИСКПОЗ(B19;F2:I2;))

Автор - Arti3223
Дата добавления - 26.09.2023 в 10:46
novichok0417 Дата: Среда, 27.09.2023, 09:02 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Arti3223, Спасибо
hands hands hands hands hands
 
Ответить
СообщениеArti3223, Спасибо
hands hands hands hands hands

Автор - novichok0417
Дата добавления - 27.09.2023 в 09:02
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!