Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формула ИНДЕКС не охватывает смежные ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула ИНДЕКС не охватывает смежные ячейки (Формулы/Formulas)
формула ИНДЕКС не охватывает смежные ячейки
sonytsatsa Дата: Пятница, 06.10.2023, 22:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2019
Здравствуйте, формула ИНДЕКС неверно подтягивает значения, выдает ошибку "формула не затрагивает смежные ячейки". Помогите найти ошибку, заранее спасибо.
К сообщению приложен файл: ucheb.xlsx (10.3 Kb)
 
Ответить
СообщениеЗдравствуйте, формула ИНДЕКС неверно подтягивает значения, выдает ошибку "формула не затрагивает смежные ячейки". Помогите найти ошибку, заранее спасибо.

Автор - sonytsatsa
Дата добавления - 06.10.2023 в 22:49
cmivadwot Дата: Пятница, 06.10.2023, 22:52 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 86 ±
Замечаний: 0% ±

365
sonytsatsa,
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$16;НАИМЕНЬШИЙ(ЕСЛИ($D$2=$A$2:$A$16;СТРОКА($A$2:$A$16)-1;"");D5));"")

диапазон не фиксирован был.....$A$2:$A$16
К сообщению приложен файл: 7302345.xlsx (10.8 Kb)
 
Ответить
Сообщениеsonytsatsa,
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$16;НАИМЕНЬШИЙ(ЕСЛИ($D$2=$A$2:$A$16;СТРОКА($A$2:$A$16)-1;"");D5));"")

диапазон не фиксирован был.....$A$2:$A$16

Автор - cmivadwot
Дата добавления - 06.10.2023 в 22:52
sonytsatsa Дата: Пятница, 06.10.2023, 22:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2019
cmivadwot, Спасибо огромное, оказалось все просто)
 
Ответить
Сообщениеcmivadwot, Спасибо огромное, оказалось все просто)

Автор - sonytsatsa
Дата добавления - 06.10.2023 в 22:57
Pelena Дата: Пятница, 06.10.2023, 23:14 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 19179
Репутация: 4418 ±
Замечаний: ±

Excel 365 & Mac Excel
вариант для новых версий Excel
Код
=ФИЛЬТР(B2:B16;A2:A16=D2)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщениевариант для новых версий Excel
Код
=ФИЛЬТР(B2:B16;A2:A16=D2)

Автор - Pelena
Дата добавления - 06.10.2023 в 23:14
i691198 Дата: Суббота, 07.10.2023, 10:46 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 85 ±
Замечаний: 0% ±

Здравствуйте. Можно без дополнительных чисел в столбце D.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$16;НАИМЕНЬШИЙ(ЕСЛИ($D$2=$A$2:$A$16;СТРОКА($A$1:$A$15));СТРОКА(A1)));"")

Или немассивной формулой.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$16;АГРЕГАТ(15;6;СТРОКА($1:$19)/($D$2=$A$2:$A$16);СТРОКА(A1)));"")
 
Ответить
СообщениеЗдравствуйте. Можно без дополнительных чисел в столбце D.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$16;НАИМЕНЬШИЙ(ЕСЛИ($D$2=$A$2:$A$16;СТРОКА($A$1:$A$15));СТРОКА(A1)));"")

Или немассивной формулой.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$16;АГРЕГАТ(15;6;СТРОКА($1:$19)/($D$2=$A$2:$A$16);СТРОКА(A1)));"")

Автор - i691198
Дата добавления - 07.10.2023 в 10:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула ИНДЕКС не охватывает смежные ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!