Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать ячейку с выпадающими месяцами и днями под ней - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать ячейку с выпадающими месяцами и днями под ней (Формулы/Formulas)
Как сделать ячейку с выпадающими месяцами и днями под ней
fintepluha Дата: Суббота, 07.10.2023, 16:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

последний
Привет, как сделать вместо ячейки Октябрь выпадающий список со всеми месяцами и при выборе месяца, под этой ячейкой появлялись все дни как на скрине?
К сообщению приложен файл: 7456143.png (29.2 Kb)


Сообщение отредактировал fintepluha - Суббота, 07.10.2023, 16:48
 
Ответить
СообщениеПривет, как сделать вместо ячейки Октябрь выпадающий список со всеми месяцами и при выборе месяца, под этой ячейкой появлялись все дни как на скрине?

Автор - fintepluha
Дата добавления - 07.10.2023 в 16:47
DrMini Дата: Суббота, 07.10.2023, 17:37 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1635
Репутация: 204 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте.
Можно попробовать вот так:
Код
=ЕСЛИ(B30<ДЕНЬ(КОНМЕСЯЦА($B$2;0));B30+1;"")

в ячейку B31 и протянуть до B32
при желании столбец с месяцами можно скрыть или прописать в Проверке данных.
К сообщению приложен файл: mesjacy.xlsx (9.3 Kb)
 
Ответить
СообщениеЗдравствуйте.
Можно попробовать вот так:
Код
=ЕСЛИ(B30<ДЕНЬ(КОНМЕСЯЦА($B$2;0));B30+1;"")

в ячейку B31 и протянуть до B32
при желании столбец с месяцами можно скрыть или прописать в Проверке данных.

Автор - DrMini
Дата добавления - 07.10.2023 в 17:37
MikeVol Дата: Суббота, 07.10.2023, 18:02 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 308
Репутация: 57 ±
Замечаний: 0% ±

Excel LTSC 2021 EN
fintepluha, Здравствуйте. Ещё как вариант.
К сообщению приложен файл: 07_10_2023_exw_kak_sdelat_jach.xlsx (11.5 Kb)


Ученик.
 
Ответить
Сообщениеfintepluha, Здравствуйте. Ещё как вариант.

Автор - MikeVol
Дата добавления - 07.10.2023 в 18:02
DrMini Дата: Суббота, 07.10.2023, 18:58 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1635
Репутация: 204 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Не обратил внимание, на то, что нужно и месяц прописать в ячейке.
Тогда с ячейки B4 протянуть вниз:
Код
=ЕСЛИ($B$2+СТРОКА(1:1)<=КОНМЕСЯЦА($B$2;0);$B$2+СТРОКА(1:1);"")
К сообщению приложен файл: 6086679.xlsx (10.8 Kb)
 
Ответить
СообщениеНе обратил внимание, на то, что нужно и месяц прописать в ячейке.
Тогда с ячейки B4 протянуть вниз:
Код
=ЕСЛИ($B$2+СТРОКА(1:1)<=КОНМЕСЯЦА($B$2;0);$B$2+СТРОКА(1:1);"")

Автор - DrMini
Дата добавления - 07.10.2023 в 18:58
DrMini Дата: Суббота, 07.10.2023, 19:07 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1635
Репутация: 204 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
MikeVol,
В Вашем варианте нужно в ячейку B3 вставить:
Код
=B2

а потом уже и Ваш вариант протянуть с ячейки B4
А то считает со 2-ого дня месяца.
yes
 
Ответить
СообщениеMikeVol,
В Вашем варианте нужно в ячейку B3 вставить:
Код
=B2

а потом уже и Ваш вариант протянуть с ячейки B4
А то считает со 2-ого дня месяца.
yes

Автор - DrMini
Дата добавления - 07.10.2023 в 19:07
fintepluha Дата: Суббота, 07.10.2023, 19:56 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

последний
MikeVol, То, что нужно, спасибо!
DrMini, Спасибо, отредактировал как вы сказали и теперь с 1 числа.
Тогда еще такой момент, следующий год високосный, как потом отредактировать вариант MikeVol, что бы в феврале было 29 дней?
 
Ответить
СообщениеMikeVol, То, что нужно, спасибо!
DrMini, Спасибо, отредактировал как вы сказали и теперь с 1 числа.
Тогда еще такой момент, следующий год високосный, как потом отредактировать вариант MikeVol, что бы в феврале было 29 дней?

Автор - fintepluha
Дата добавления - 07.10.2023 в 19:56
MikeVol Дата: Суббота, 07.10.2023, 21:10 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 308
Репутация: 57 ±
Замечаний: 0% ±

Excel LTSC 2021 EN
следующий год високосный
Не беда, решаемо. Смотрим файл.
в ячейку B3 вставить
Спасибо, не заметил сразу ошибку.
К сообщению приложен файл: 3558132.xlsx (13.5 Kb)


Ученик.
 
Ответить
Сообщение
следующий год високосный
Не беда, решаемо. Смотрим файл.
в ячейку B3 вставить
Спасибо, не заметил сразу ошибку.

Автор - MikeVol
Дата добавления - 07.10.2023 в 21:10
Egyptian Дата: Суббота, 07.10.2023, 22:22 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 514
Репутация: 185 ±
Замечаний: 0% ±

Excel 2013/2016
fintepluha,
В ячейке B2 делаете выпадающий список с месяцами (в текстовом формате: ...Январь, Февраль и т.д.). В ячейке В1 - с годами.
В ячейку В3 вставляете формулу и тянете вниз.
Код
=IFERROR(--(ROW(A1)&B$2&B$1);"")

Выставляете нужный формат. Все.
Если год всегда текущий, то можно обойтись только выпад. списком для месяцев и слегда изменить формулу:
Код
=IFERROR(--(ROW(A1)&B$2&YEAR(TODAY()));"")


Сообщение отредактировал Egyptian - Воскресенье, 08.10.2023, 01:21
 
Ответить
Сообщениеfintepluha,
В ячейке B2 делаете выпадающий список с месяцами (в текстовом формате: ...Январь, Февраль и т.д.). В ячейке В1 - с годами.
В ячейку В3 вставляете формулу и тянете вниз.
Код
=IFERROR(--(ROW(A1)&B$2&B$1);"")

Выставляете нужный формат. Все.
Если год всегда текущий, то можно обойтись только выпад. списком для месяцев и слегда изменить формулу:
Код
=IFERROR(--(ROW(A1)&B$2&YEAR(TODAY()));"")

Автор - Egyptian
Дата добавления - 07.10.2023 в 22:22
MikeVol Дата: Воскресенье, 08.10.2023, 00:10 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 308
Репутация: 57 ±
Замечаний: 0% ±

Excel LTSC 2021 EN
Egyptian, Приветсвую вас. Ошибочка тоже у вас. Если
В ячейке В1 - с годами.
то формула должна быть такой: [vba]
Код
=ЕСЛИОШИБКА(--(СТРОКА(A1)&B$2&B$1);"")
[/vba] так она взлетит.


Ученик.

Сообщение отредактировал MikeVol - Воскресенье, 08.10.2023, 00:11
 
Ответить
СообщениеEgyptian, Приветсвую вас. Ошибочка тоже у вас. Если
В ячейке В1 - с годами.
то формула должна быть такой: [vba]
Код
=ЕСЛИОШИБКА(--(СТРОКА(A1)&B$2&B$1);"")
[/vba] так она взлетит.

Автор - MikeVol
Дата добавления - 08.10.2023 в 00:10
Egyptian Дата: Воскресенье, 08.10.2023, 01:23 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 514
Репутация: 185 ±
Замечаний: 0% ±

Excel 2013/2016
MikeVol, Точно. Накосячил по невнимательности.
Выше поправил.
 
Ответить
СообщениеMikeVol, Точно. Накосячил по невнимательности.
Выше поправил.

Автор - Egyptian
Дата добавления - 08.10.2023 в 01:23
fintepluha Дата: Воскресенье, 08.10.2023, 06:33 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

последний
Egyptian, MikeVol, Круто, спасибо!
 
Ответить
СообщениеEgyptian, MikeVol, Круто, спасибо!

Автор - fintepluha
Дата добавления - 08.10.2023 в 06:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать ячейку с выпадающими месяцами и днями под ней (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!