Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проставка цифр в определенную ячейку, исходя из прогноза - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проставка цифр в определенную ячейку, исходя из прогноза (Формулы/Formulas)
Проставка цифр в определенную ячейку, исходя из прогноза
ПАМ Дата: Понедельник, 09.10.2023, 13:06 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 282
Репутация: 11 ±
Замечаний: 20% ±

Excel 2010, Excel 2016
Здравствуйте!
Помогите мне пожалуйста решить такую задачу. У меня есть две таблицы на одном листе: календарь и прогноз. мне нужно, чтобы исходя из условий прогноза на определенную дату в столбце F ставилась цифра или 1 или 2 или 3. Например, 1 августа 2023 года цифра 1 должна появиться на 1 августа календаря напротив значения (E10) 07-08 то есть в ячейке F10. Цифра 2 напротив E22 (19-20) в ячейке F22 и так же с ячейкой прогноза три (11-12)
Большая для меня сложность в том, что в таблице прогноза (J-L) может быть задан любой первый интервал, любой второй и любой третий интервал и я не могу разобраться как сделать массив из данных. Столбец I можно не использовать. Он был нужен мне для преобразования столбца Н. Помогите мне пожалуйста разобраться в данном вопросе. Заранее всем спасибо!
К сообщению приложен файл: maket.xlsx (39.6 Kb)


Сообщение отредактировал ПАМ - Понедельник, 09.10.2023, 13:07
 
Ответить
СообщениеЗдравствуйте!
Помогите мне пожалуйста решить такую задачу. У меня есть две таблицы на одном листе: календарь и прогноз. мне нужно, чтобы исходя из условий прогноза на определенную дату в столбце F ставилась цифра или 1 или 2 или 3. Например, 1 августа 2023 года цифра 1 должна появиться на 1 августа календаря напротив значения (E10) 07-08 то есть в ячейке F10. Цифра 2 напротив E22 (19-20) в ячейке F22 и так же с ячейкой прогноза три (11-12)
Большая для меня сложность в том, что в таблице прогноза (J-L) может быть задан любой первый интервал, любой второй и любой третий интервал и я не могу разобраться как сделать массив из данных. Столбец I можно не использовать. Он был нужен мне для преобразования столбца Н. Помогите мне пожалуйста разобраться в данном вопросе. Заранее всем спасибо!

Автор - ПАМ
Дата добавления - 09.10.2023 в 13:06
китин Дата: Понедельник, 09.10.2023, 14:13 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 7014
Репутация: 1073 ±
Замечаний: 0% ±

Excel 2007;2010;2016
как понял
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ($E3;ИНДЕКС($J$3:$L$33;ПОИСКПОЗ(ДАТА($A3;МЕСЯЦ(1&$B3);C3);$H$3:$H$33;0););0);0)
К сообщению приложен файл: 8154827.xlsx (43.0 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениекак понял
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ($E3;ИНДЕКС($J$3:$L$33;ПОИСКПОЗ(ДАТА($A3;МЕСЯЦ(1&$B3);C3);$H$3:$H$33;0););0);0)

Автор - китин
Дата добавления - 09.10.2023 в 14:13
ПАМ Дата: Понедельник, 09.10.2023, 15:50 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 282
Репутация: 11 ±
Замечаний: 20% ±

Excel 2010, Excel 2016
китин, ОГРОМНОЕ Спасибо! Надеюсь и в оригинальном файле будет работать.
 
Ответить
Сообщениекитин, ОГРОМНОЕ Спасибо! Надеюсь и в оригинальном файле будет работать.

Автор - ПАМ
Дата добавления - 09.10.2023 в 15:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проставка цифр в определенную ячейку, исходя из прогноза (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!