Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счетчик со смещением - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счетчик со смещением (Формулы/Formulas)
Счетчик со смещением
graf2001 Дата: Понедельник, 09.10.2023, 13:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2016
Доброго времени суток!
Подскажите, пожалуйста, возможно ли с помощью формул сделать такой счетчик, чтобы он считал следующим образом:
- находим в столбце А значение, соответствующее аргументу из столбца G2:G11
- при нахождении совпадения, смещаемся в столбце А на 1 строку вверх и определяем значение в новой строке
- находим совпадение нового значения со значением в строке «счетчик» (в данном случае это диапазон H1:Q1)
- на пересечении двух этих значений фиксируем "+1"
- продолжаем поиск
В примере заполнил вручную счетчик для «1». Получилось, что, если смотреть снизу по столбцу А, после «1» у нас по одному разу получились числа «2» и «4», и 2 раза встретилась цифра «10».
Буду признателен за любую помощь!
К сообщению приложен файл: kniga.xlsx (8.5 Kb)
 
Ответить
СообщениеДоброго времени суток!
Подскажите, пожалуйста, возможно ли с помощью формул сделать такой счетчик, чтобы он считал следующим образом:
- находим в столбце А значение, соответствующее аргументу из столбца G2:G11
- при нахождении совпадения, смещаемся в столбце А на 1 строку вверх и определяем значение в новой строке
- находим совпадение нового значения со значением в строке «счетчик» (в данном случае это диапазон H1:Q1)
- на пересечении двух этих значений фиксируем "+1"
- продолжаем поиск
В примере заполнил вручную счетчик для «1». Получилось, что, если смотреть снизу по столбцу А, после «1» у нас по одному разу получились числа «2» и «4», и 2 раза встретилась цифра «10».
Буду признателен за любую помощь!

Автор - graf2001
Дата добавления - 09.10.2023 в 13:20
Nic70y Дата: Понедельник, 09.10.2023, 13:46 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
если правильно понял
формула массива
Код
=СУММ(--(ЕСЛИ($A$2:$A$17=$G2;$A$1:$A$16)=H$1))
К сообщению приложен файл: 15.xlsx (11.7 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеесли правильно понял
формула массива
Код
=СУММ(--(ЕСЛИ($A$2:$A$17=$G2;$A$1:$A$16)=H$1))

Автор - Nic70y
Дата добавления - 09.10.2023 в 13:46
graf2001 Дата: Понедельник, 09.10.2023, 14:44 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2016
Nic70y
Какая элегантная формула! А у меня получались трехэтажные конструкции, и все равно не работали...
Спасибо большое!
Ответ получен. Тему можно закрывать.


Сообщение отредактировал graf2001 - Понедельник, 09.10.2023, 14:45
 
Ответить
СообщениеNic70y
Какая элегантная формула! А у меня получались трехэтажные конструкции, и все равно не работали...
Спасибо большое!
Ответ получен. Тему можно закрывать.

Автор - graf2001
Дата добавления - 09.10.2023 в 14:44
Egyptian Дата: Вторник, 10.10.2023, 12:15 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 514
Репутация: 185 ±
Замечаний: 0% ±

Excel 2013/2016
graf2001,
А еще можно так:
Код
=COUNTIFS($A$2:$A$17;$G2;$A$1:$A$16;H$1)
 
Ответить
Сообщениеgraf2001,
А еще можно так:
Код
=COUNTIFS($A$2:$A$17;$G2;$A$1:$A$16;H$1)

Автор - Egyptian
Дата добавления - 10.10.2023 в 12:15
graf2001 Дата: Пятница, 13.10.2023, 10:57 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2016
Egyptian, благодарю, что откликнулись! yes
 
Ответить
СообщениеEgyptian, благодарю, что откликнулись! yes

Автор - graf2001
Дата добавления - 13.10.2023 в 10:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счетчик со смещением (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!