Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Связанный выпадающий список - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Связанный выпадающий список (Формулы/Formulas)
Связанный выпадающий список
Oh_Nick Дата: Вторник, 10.10.2023, 15:30 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
Всем привет!

Подскажите,пожалуйста, как сделать зависимые списки. На листе Общая Мат хочу выбирать корпус и все остальное тянется с Лист1. Условие, что на Лист1 значения будут пополняться
К сообщению приложен файл: shablon_dlja_raboty_s_furnitur.xlsx (16.2 Kb)
 
Ответить
СообщениеВсем привет!

Подскажите,пожалуйста, как сделать зависимые списки. На листе Общая Мат хочу выбирать корпус и все остальное тянется с Лист1. Условие, что на Лист1 значения будут пополняться

Автор - Oh_Nick
Дата добавления - 10.10.2023 в 15:30
Oh_Nick Дата: Вторник, 10.10.2023, 15:54 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
Полазил на интернете и попробовал написать код, чтобы при занесении значения на листе Общая в колонку А макрос шел на Лист1 находил значение и копировал строчку, после возвращался и вставлял ее где значение. Мне кажется так будет более отпимально. Только выдает ошибку на [vba]
Код
Set Общая = ThisWorkbook.Sheets(Общая)
[/vba] , хотя вроде лист правильно записан...
К сообщению приложен файл: 1823259.xlsx (14.2 Kb)
 
Ответить
СообщениеПолазил на интернете и попробовал написать код, чтобы при занесении значения на листе Общая в колонку А макрос шел на Лист1 находил значение и копировал строчку, после возвращался и вставлял ее где значение. Мне кажется так будет более отпимально. Только выдает ошибку на [vba]
Код
Set Общая = ThisWorkbook.Sheets(Общая)
[/vba] , хотя вроде лист правильно записан...

Автор - Oh_Nick
Дата добавления - 10.10.2023 в 15:54
Nic70y Дата: Вторник, 10.10.2023, 16:16 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
[vba]
Код
Set Общая = ThisWorkbook.Sheets("Общая")
[/vba]


ЮMoney 41001841029809
 
Ответить
Сообщение[vba]
Код
Set Общая = ThisWorkbook.Sheets("Общая")
[/vba]

Автор - Nic70y
Дата добавления - 10.10.2023 в 16:16
Oh_Nick Дата: Вторник, 10.10.2023, 16:25 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
Nic70y, спасибо, а теперь светит [vba]
Код
значение = Target.Value
[/vba]
 
Ответить
СообщениеNic70y, спасибо, а теперь светит [vba]
Код
значение = Target.Value
[/vba]

Автор - Oh_Nick
Дата добавления - 10.10.2023 в 16:25
Oh_Nick Дата: Вторник, 10.10.2023, 20:35 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
знает кто-то как реализовать сию задумку?
 
Ответить
Сообщениезнает кто-то как реализовать сию задумку?

Автор - Oh_Nick
Дата добавления - 10.10.2023 в 20:35
bigor Дата: Вторник, 10.10.2023, 21:06 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
Oh_Nick, а где код?
 
Ответить
СообщениеOh_Nick, а где код?

Автор - bigor
Дата добавления - 10.10.2023 в 21:06
Oh_Nick Дата: Вторник, 10.10.2023, 22:34 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
bigor,

приложил файл, без кода мб получится формулами? или мб код свой предложите, мой не сохранился...

На листе общая мат выбираем наименование и копируются значения. для примера сделал одну позицию
К сообщению приложен файл: 8296498.xlsx (20.3 Kb)
 
Ответить
Сообщениеbigor,

приложил файл, без кода мб получится формулами? или мб код свой предложите, мой не сохранился...

На листе общая мат выбираем наименование и копируются значения. для примера сделал одну позицию

Автор - Oh_Nick
Дата добавления - 10.10.2023 в 22:34
gling Дата: Вторник, 10.10.2023, 22:54 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2521
Репутация: 675 ±
Замечаний: 0% ±

2010
мб получится формулами?
Код
=ВПР($A13;Лист1!$A:$G;СТОЛБЕЦ();0)

мой не сохранился..

Макросы не хранятся в книге с расширением .xlsx, нужно при сохранении выбирать расширение .xlsm
К сообщению приложен файл: 3197290.xlsx (20.8 Kb)


ЯД-41001506838083
 
Ответить
Сообщение
мб получится формулами?
Код
=ВПР($A13;Лист1!$A:$G;СТОЛБЕЦ();0)

мой не сохранился..

Макросы не хранятся в книге с расширением .xlsx, нужно при сохранении выбирать расширение .xlsm

Автор - gling
Дата добавления - 10.10.2023 в 22:54
Oh_Nick Дата: Вторник, 10.10.2023, 23:03 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
gling, спасибо, вроде работает)


Сообщение отредактировал Oh_Nick - Вторник, 10.10.2023, 23:05
 
Ответить
Сообщениеgling, спасибо, вроде работает)

Автор - Oh_Nick
Дата добавления - 10.10.2023 в 23:03
DrMini Дата: Среда, 11.10.2023, 07:24 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
СТОЛБЕЦ();0

Вот именно такое и мне нужно было.
Да вот не знал, что так (более изящно) можно было тогда решить эту проблему.
Спасибо Владимир.
 
Ответить
Сообщение
СТОЛБЕЦ();0

Вот именно такое и мне нужно было.
Да вот не знал, что так (более изящно) можно было тогда решить эту проблему.
Спасибо Владимир.

Автор - DrMini
Дата добавления - 11.10.2023 в 07:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Связанный выпадающий список (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!