Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разбиение текста по одному столбцу - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбиение текста по одному столбцу (Формулы/Formulas)
Разбиение текста по одному столбцу
GhostCall Дата: Среда, 11.10.2023, 11:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

19
Доброго времени, скажите пожалуйста, вот имеется такой текст в одну строку: "6.88477 -2.07471 6.87109 -2.05957", я вставляю его в ячейку A1, но мне нужно разбить этот текст по пробелам так, чтобы каждое число расформировалось по каждой ячейке столбца A. Я пробовал играться с функцией "Текст в Колонки", но excel разделяет текст и пихает расформировывает каждое число в новый столбец, а мне необходимо чтобы каждое разделенное число расформировалось по одному столбцу но в разные строки


Исаев
 
Ответить
СообщениеДоброго времени, скажите пожалуйста, вот имеется такой текст в одну строку: "6.88477 -2.07471 6.87109 -2.05957", я вставляю его в ячейку A1, но мне нужно разбить этот текст по пробелам так, чтобы каждое число расформировалось по каждой ячейке столбца A. Я пробовал играться с функцией "Текст в Колонки", но excel разделяет текст и пихает расформировывает каждое число в новый столбец, а мне необходимо чтобы каждое разделенное число расформировалось по одному столбцу но в разные строки

Автор - GhostCall
Дата добавления - 11.10.2023 в 11:31
bigor Дата: Среда, 11.10.2023, 11:52 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1116
Репутация: 212 ±
Замечаний: 0% ±

нет
GhostCall, транспонируйте строку в столбец
 
Ответить
СообщениеGhostCall, транспонируйте строку в столбец

Автор - bigor
Дата добавления - 11.10.2023 в 11:52
msi2102 Дата: Среда, 11.10.2023, 12:04 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 413
Репутация: 129 ±
Замечаний: 0% ±

Excel 2007
Пробуйте так (массивная)
[vba]
Код
=ФИЛЬТР.XML("<t><s>"&ПОДСТАВИТЬ(A1;" ";"</s><s>")&"</s></t>";"//s")
[/vba]
К сообщению приложен файл: kniga1_1.xlsx (8.4 Kb)
 
Ответить
СообщениеПробуйте так (массивная)
[vba]
Код
=ФИЛЬТР.XML("<t><s>"&ПОДСТАВИТЬ(A1;" ";"</s><s>")&"</s></t>";"//s")
[/vba]

Автор - msi2102
Дата добавления - 11.10.2023 в 12:04
DrMini Дата: Среда, 11.10.2023, 12:06 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Как вариант:
в первую ячейку:
Код
=ЛЕВСИМВ(A1; ПОИСК(" ";A1;1)-1)

Во вторую и протянуть:
Код
=ЕСЛИОШИБКА(ЛЕВСИМВ(ПОДСТАВИТЬ(A$1&" "; ОБЪЕДИНИТЬ(" ";ИСТИНА;A$2:A2)&" ";"";1); ПОИСК(" ";ПОДСТАВИТЬ(A$1&" ";ОБЪЕДИНИТЬ(" ";ИСТИНА;A$2:A2)&" ";"";1);1)-1);"")
К сообщению приложен файл: tekst_v_stolbec.xlsx (10.9 Kb)
 
Ответить
СообщениеКак вариант:
в первую ячейку:
Код
=ЛЕВСИМВ(A1; ПОИСК(" ";A1;1)-1)

Во вторую и протянуть:
Код
=ЕСЛИОШИБКА(ЛЕВСИМВ(ПОДСТАВИТЬ(A$1&" "; ОБЪЕДИНИТЬ(" ";ИСТИНА;A$2:A2)&" ";"";1); ПОИСК(" ";ПОДСТАВИТЬ(A$1&" ";ОБЪЕДИНИТЬ(" ";ИСТИНА;A$2:A2)&" ";"";1);1)-1);"")

Автор - DrMini
Дата добавления - 11.10.2023 в 12:06
DrMini Дата: Среда, 11.10.2023, 12:08 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Вариант с Вашими данными.
К сообщению приложен файл: 1734909.xlsx (10.9 Kb)
 
Ответить
СообщениеВариант с Вашими данными.

Автор - DrMini
Дата добавления - 11.10.2023 в 12:08
bmv98rus Дата: Среда, 11.10.2023, 12:29 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4111
Репутация: 768 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=TRIM(MID(SUBSTITUTE(" "&$A$1;" ";REPT(" ";99));(ROW()-1)*99;99))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=TRIM(MID(SUBSTITUTE(" "&$A$1;" ";REPT(" ";99));(ROW()-1)*99;99))

Автор - bmv98rus
Дата добавления - 11.10.2023 в 12:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбиение текста по одному столбцу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!