Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод информации в сторт таблице - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод информации в сторт таблице (Формулы/Formulas)
Вывод информации в сторт таблице
provasilku Дата: Вторник, 17.10.2023, 12:52 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

2019
Добрый день. помогите исправить формулу для вывода результатов
Код
=ЕСЛИ(Y6="";"";ПРОСМОТР(2;1/(AF$12:AF$151=1);C$12:C$151))
(в таблице желтым выделено).
При равенстве мест не выводиться данные второго участника.
К сообщению приложен файл: darts.xlsx (76.4 Kb)


Сообщение отредактировал provasilku - Вторник, 17.10.2023, 12:53
 
Ответить
СообщениеДобрый день. помогите исправить формулу для вывода результатов
Код
=ЕСЛИ(Y6="";"";ПРОСМОТР(2;1/(AF$12:AF$151=1);C$12:C$151))
(в таблице желтым выделено).
При равенстве мест не выводиться данные второго участника.

Автор - provasilku
Дата добавления - 17.10.2023 в 12:52
bigor Дата: Вторник, 17.10.2023, 14:05 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1110
Репутация: 212 ±
Замечаний: 0% ±

нет
При равенстве мест не выводиться данные второго участника
а что протокол говорит, если 2 участника набрали одинаковое количество очков? Будет два первых места и ни одного второго? А если первый набрал 40 очков а остальные по 30, они все на втором будут?
По формуле: во второй строке ищет второе место, его нет, поэтому ошибка
 
Ответить
Сообщение
При равенстве мест не выводиться данные второго участника
а что протокол говорит, если 2 участника набрали одинаковое количество очков? Будет два первых места и ни одного второго? А если первый набрал 40 очков а остальные по 30, они все на втором будут?
По формуле: во второй строке ищет второе место, его нет, поэтому ошибка

Автор - bigor
Дата добавления - 17.10.2023 в 14:05
provasilku Дата: Вторник, 17.10.2023, 15:04 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

2019
bigor, Просто при игре "сектор 20" может быть абсолютно одинаковый результат у участников. Вот и возник вопрос как можно сделать чтобы отражалось два первых места.
Ну и в дальнейшем можно использовать в других видах спорта. Для отображения на втором мониторе лучших на текущий момент.
Может другой вариант формулы есть...


Сообщение отредактировал provasilku - Вторник, 17.10.2023, 15:09
 
Ответить
Сообщениеbigor, Просто при игре "сектор 20" может быть абсолютно одинаковый результат у участников. Вот и возник вопрос как можно сделать чтобы отражалось два первых места.
Ну и в дальнейшем можно использовать в других видах спорта. Для отображения на втором мониторе лучших на текущий момент.
Может другой вариант формулы есть...

Автор - provasilku
Дата добавления - 17.10.2023 в 15:04
bigor Дата: Вторник, 17.10.2023, 21:59 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1110
Репутация: 212 ±
Замечаний: 0% ±

нет
Для второго или первого места
Код
=IF(Y7="";"";INDEX($C$12:$C$151;MATCH(--LEFT(Q7;1);$AF$12:$AF$151;0)))

а если будет 3 первых?
 
Ответить
СообщениеДля второго или первого места
Код
=IF(Y7="";"";INDEX($C$12:$C$151;MATCH(--LEFT(Q7;1);$AF$12:$AF$151;0)))

а если будет 3 первых?

Автор - bigor
Дата добавления - 17.10.2023 в 21:59
provasilku Дата: Среда, 18.10.2023, 10:21 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

2019
bigor, Да может быть и три первых и два вторых
 
Ответить
Сообщениеbigor, Да может быть и три первых и два вторых

Автор - provasilku
Дата добавления - 18.10.2023 в 10:21
Pelena Дата: Среда, 18.10.2023, 19:22 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 19197
Репутация: 4423 ±
Замечаний: ±

Excel 365 & Mac Excel
Можно ещё такой вариант, если версия офиса позволяет
Код
=ОБЪЕДИНИТЬ(", ";ИСТИНА;ФИЛЬТР($C$12:$I$151;$AF$12:$AF$151=Q6;""))
К сообщению приложен файл: 6744136.xlsx (69.8 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеМожно ещё такой вариант, если версия офиса позволяет
Код
=ОБЪЕДИНИТЬ(", ";ИСТИНА;ФИЛЬТР($C$12:$I$151;$AF$12:$AF$151=Q6;""))

Автор - Pelena
Дата добавления - 18.10.2023 в 19:22
bigor Дата: Среда, 18.10.2023, 22:06 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1110
Репутация: 212 ±
Замечаний: 0% ±

нет
Для не старее 2010 офисов
Код
=IF(Y6="";"";INDEX($C$12:$C$36;AGGREGATE(15;6;(ROW($A$12:$A$36)-11)/($AF$12:$AF$36=--LEFT(Q6;1));COUNTIF($Q$6:Q6;Q6))))
 
Ответить
СообщениеДля не старее 2010 офисов
Код
=IF(Y6="";"";INDEX($C$12:$C$36;AGGREGATE(15;6;(ROW($A$12:$A$36)-11)/($AF$12:$AF$36=--LEFT(Q6;1));COUNTIF($Q$6:Q6;Q6))))

Автор - bigor
Дата добавления - 18.10.2023 в 22:06
provasilku Дата: Четверг, 19.10.2023, 06:07 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

2019
bigor,
Спасибо большое. Все заработало
 
Ответить
Сообщениеbigor,
Спасибо большое. Все заработало

Автор - provasilku
Дата добавления - 19.10.2023 в 06:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод информации в сторт таблице (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!