Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое подставление поставщика по минимальной цене - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое подставление поставщика по минимальной цене (Формулы/Formulas)
Автоматическое подставление поставщика по минимальной цене
vitos88 Дата: Среда, 18.10.2023, 17:18 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 5 ±
Замечаний: 0% ±

Добрый день!
Написал формулу для автоматического проставления поставщика, исходя из данных стоимости. Формула, вроде, работает, но почему-то выводит глюк, когда ввожу цену ниже, чем у остальных в жёлтой ячейке. В чем может быть проблема? Форум покурил, возможно не так глубоко, но решения не нашел.
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$C$2;;ПОИСКПОЗ(МИН(A4:C4);A4:C4));"")
К сообщению приложен файл: vybor_postavshhika.xlsx (13.0 Kb)
 
Ответить
СообщениеДобрый день!
Написал формулу для автоматического проставления поставщика, исходя из данных стоимости. Формула, вроде, работает, но почему-то выводит глюк, когда ввожу цену ниже, чем у остальных в жёлтой ячейке. В чем может быть проблема? Форум покурил, возможно не так глубоко, но решения не нашел.
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$C$2;;ПОИСКПОЗ(МИН(A4:C4);A4:C4));"")

Автор - vitos88
Дата добавления - 18.10.2023 в 17:18
Nic70y Дата: Среда, 18.10.2023, 17:21 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
vitos88, файл не смотрел, видно сразу
Код
=ПОИСКПОЗ(МИН(A4:C4);A4:C4;)
не хватает ;


ЮMoney 41001841029809
 
Ответить
Сообщениеvitos88, файл не смотрел, видно сразу
Код
=ПОИСКПОЗ(МИН(A4:C4);A4:C4;)
не хватает ;

Автор - Nic70y
Дата добавления - 18.10.2023 в 17:21
vitos88 Дата: Среда, 18.10.2023, 17:24 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 5 ±
Замечаний: 0% ±

Спасибо! Всё работает.
 
Ответить
СообщениеСпасибо! Всё работает.

Автор - vitos88
Дата добавления - 18.10.2023 в 17:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое подставление поставщика по минимальной цене (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!