Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула с ЕСЛИ для диапазона ячеек с несколькими условиями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с ЕСЛИ для диапазона ячеек с несколькими условиями (Формулы/Formulas)
Формула с ЕСЛИ для диапазона ячеек с несколькими условиями
olya2084 Дата: Пятница, 20.10.2023, 10:25 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

Здравствуйте! Помогите, пожалуйста, скорректировать формулу. Суть следующая: если в диапазоне ячеек внесены все плюсы, то статус "Соответствует", если все минусы, то "Не соответствует", если хоть один минус, то "Требует доработки".
Что-то вроде этого?
Код
ЕСЛИ(СЧЁТЕСЛИ(FH6:FJ6;"'+");"Соответствует";СЧЁТЕСЛИ(FH6:FJ6;"'-");"Не соответствует";"Требует доработки")
 
Ответить
СообщениеЗдравствуйте! Помогите, пожалуйста, скорректировать формулу. Суть следующая: если в диапазоне ячеек внесены все плюсы, то статус "Соответствует", если все минусы, то "Не соответствует", если хоть один минус, то "Требует доработки".
Что-то вроде этого?
Код
ЕСЛИ(СЧЁТЕСЛИ(FH6:FJ6;"'+");"Соответствует";СЧЁТЕСЛИ(FH6:FJ6;"'-");"Не соответствует";"Требует доработки")

Автор - olya2084
Дата добавления - 20.10.2023 в 10:25
bigor Дата: Пятница, 20.10.2023, 10:33 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1086
Репутация: 207 ±
Замечаний: 0% ±

нет
olya2084, попробуйте так
Код
ЕСЛИ(СЧЁТЕСЛИ(FH6:FJ6;"'+")=ЧСТРОК(FH6:FJ6);"Соответствует";СЧЁТЕСЛИ(FH6:FJ6;"'-")=ЧСТРОК(FH6:FJ6);"Не соответствует";"Требует доработки")
 
Ответить
Сообщениеolya2084, попробуйте так
Код
ЕСЛИ(СЧЁТЕСЛИ(FH6:FJ6;"'+")=ЧСТРОК(FH6:FJ6);"Соответствует";СЧЁТЕСЛИ(FH6:FJ6;"'-")=ЧСТРОК(FH6:FJ6);"Не соответствует";"Требует доработки")

Автор - bigor
Дата добавления - 20.10.2023 в 10:33
olya2084 Дата: Пятница, 20.10.2023, 10:42 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

bigor, пишет, что данной функции введено слишком много аргументов.
 
Ответить
Сообщениеbigor, пишет, что данной функции введено слишком много аргументов.

Автор - olya2084
Дата добавления - 20.10.2023 в 10:42
DrMini Дата: Пятница, 20.10.2023, 10:54 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1635
Репутация: 204 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Как вариант:
Код
=ЕСЛИМН(СЧЁТЕСЛИ(A1:F1;"+")=6;"Соответствует";СЧЁТЕСЛИ(A1:F1;"-")=6;"Не соответствует";1;"Требует доработки")

Цифру 6 можно заменить на функцию
Код
=СЧЁТЗ()
К сообщению приложен файл: pljusminus.xlsx (11.5 Kb)


Сообщение отредактировал DrMini - Пятница, 20.10.2023, 11:13
 
Ответить
СообщениеКак вариант:
Код
=ЕСЛИМН(СЧЁТЕСЛИ(A1:F1;"+")=6;"Соответствует";СЧЁТЕСЛИ(A1:F1;"-")=6;"Не соответствует";1;"Требует доработки")

Цифру 6 можно заменить на функцию
Код
=СЧЁТЗ()

Автор - DrMini
Дата добавления - 20.10.2023 в 10:54
Nic70y Дата: Пятница, 20.10.2023, 11:08 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8749
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010
еще вариант
Код
=ВПР((ЧИСЛСТОЛБ(FH6:FJ6)-СЧЁТЕСЛИ(FH6:FJ6;"+"))/ЧИСЛСТОЛБ(FH6:FJ6);{0;"Соответствует":0,0001;"Требует доработки":1;"Не соответствует"};2)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Пятница, 20.10.2023, 11:14
 
Ответить
Сообщениееще вариант
Код
=ВПР((ЧИСЛСТОЛБ(FH6:FJ6)-СЧЁТЕСЛИ(FH6:FJ6;"+"))/ЧИСЛСТОЛБ(FH6:FJ6);{0;"Соответствует":0,0001;"Требует доработки":1;"Не соответствует"};2)

Автор - Nic70y
Дата добавления - 20.10.2023 в 11:08
DrMini Дата: Пятница, 20.10.2023, 11:15 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1635
Репутация: 204 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Спасибо Николай


Сообщение отредактировал DrMini - Пятница, 20.10.2023, 18:35
 
Ответить
СообщениеСпасибо Николай

Автор - DrMini
Дата добавления - 20.10.2023 в 11:15
olya2084 Дата: Пятница, 20.10.2023, 11:37 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

Nic70y, а только с формулой массива варианты? Может можно как-то без комбинации клавиш CTRL+SHIFT+ENTER обойтись? Дело в том,что знаки "+"/"-" ответственный за заполнение файла может изменить и тогда вылетает ошибка "#ИМЯ?".
 
Ответить
СообщениеNic70y, а только с формулой массива варианты? Может можно как-то без комбинации клавиш CTRL+SHIFT+ENTER обойтись? Дело в том,что знаки "+"/"-" ответственный за заполнение файла может изменить и тогда вылетает ошибка "#ИМЯ?".

Автор - olya2084
Дата добавления - 20.10.2023 в 11:37
Nic70y Дата: Пятница, 20.10.2023, 11:50 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 8749
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010
olya2084, это не формула массива


ЮMoney 41001841029809
 
Ответить
Сообщениеolya2084, это не формула массива

Автор - Nic70y
Дата добавления - 20.10.2023 в 11:50
olya2084 Дата: Пятница, 20.10.2023, 12:06 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

Nic70y, не работает формула (((
К сообщению приложен файл: pljusminus_4.xlsx (320.4 Kb)
 
Ответить
СообщениеNic70y, не работает формула (((

Автор - olya2084
Дата добавления - 20.10.2023 в 12:06
Nic70y Дата: Пятница, 20.10.2023, 12:10 | Сообщение № 10
Группа: Друзья
Ранг: Экселист
Сообщений: 8749
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010
работает
К сообщению приложен файл: 5261876.xlsx (10.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеработает

Автор - Nic70y
Дата добавления - 20.10.2023 в 12:10
olya2084 Дата: Пятница, 20.10.2023, 12:13 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

Nic70y, теперь работает!!!!!! Благодарю ВАС!!!!!!!!
 
Ответить
СообщениеNic70y, теперь работает!!!!!! Благодарю ВАС!!!!!!!!

Автор - olya2084
Дата добавления - 20.10.2023 в 12:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с ЕСЛИ для диапазона ячеек с несколькими условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!