Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти Число контроль в одном листе и вставить значение - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Найти Число контроль в одном листе и вставить значение
caind2015 Дата: Суббота, 21.10.2023, 14:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

2016
Доброго дня ,знатоки экселя. Подскажите, как составить формулу для поиска цифрового значения в столбце одной вкладке столбца .)))Точно выразить мысль сложно..
Пример ...В лабораторном журнале в столбце А есть ряд цифр это номер рядовой пробы. Полученный в течении дня результат 1.28 (выделен жёлтым) по этой пробе при взвешивании, заносится в столбец Е. 325799 (выделен жёлтым) 1,28 (выделен жёлтым) во вкладке лабораторный журнал
Как только появился результат в столбце Е ,он переносится в другую вкладку Ведомость БВР в столбец С напротив ряда цифр тех же 325799 что и в лабораторном журнале. Это я смог сделать.
А вот как сделать чтобы из лабораторного журнала вытащить результат повтора 325799K ( Контроль ) обозначил в лабораторном журнале синим для понимания и получившийся результат по контролю поставить в Ведомость БВР в соседнюю колонку рядом со столбцом С в D обозначил цветом так же.
К сообщению приложен файл: 2023.xlsx (195.8 Kb)


Сообщение отредактировал caind2015 - Суббота, 21.10.2023, 15:52
 
Ответить
СообщениеДоброго дня ,знатоки экселя. Подскажите, как составить формулу для поиска цифрового значения в столбце одной вкладке столбца .)))Точно выразить мысль сложно..
Пример ...В лабораторном журнале в столбце А есть ряд цифр это номер рядовой пробы. Полученный в течении дня результат 1.28 (выделен жёлтым) по этой пробе при взвешивании, заносится в столбец Е. 325799 (выделен жёлтым) 1,28 (выделен жёлтым) во вкладке лабораторный журнал
Как только появился результат в столбце Е ,он переносится в другую вкладку Ведомость БВР в столбец С напротив ряда цифр тех же 325799 что и в лабораторном журнале. Это я смог сделать.
А вот как сделать чтобы из лабораторного журнала вытащить результат повтора 325799K ( Контроль ) обозначил в лабораторном журнале синим для понимания и получившийся результат по контролю поставить в Ведомость БВР в соседнюю колонку рядом со столбцом С в D обозначил цветом так же.

Автор - caind2015
Дата добавления - 21.10.2023 в 14:33
Pelena Дата: Суббота, 21.10.2023, 17:52 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19235
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
Здравствуйте.
Собственно, тот же ВПР
Код
=ЕСЛИОШИБКА(ВПР(B17&"К";'Лабораторный журнал'!$A$1:$E$10000;5;0);"")

По поводу формулы в соседней желтой ячейке: не рекомендуется использовать в функции ВПР столбцы целиком, а тем более лист целиком, как у Вас. При большом кол-ве формул будет тормозить. В своей формуле взяла 5 столбцов и 10000 строк
К сообщению приложен файл: 4249048.xlsx (191.1 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Собственно, тот же ВПР
Код
=ЕСЛИОШИБКА(ВПР(B17&"К";'Лабораторный журнал'!$A$1:$E$10000;5;0);"")

По поводу формулы в соседней желтой ячейке: не рекомендуется использовать в функции ВПР столбцы целиком, а тем более лист целиком, как у Вас. При большом кол-ве формул будет тормозить. В своей формуле взяла 5 столбцов и 10000 строк

Автор - Pelena
Дата добавления - 21.10.2023 в 17:52
caind2015 Дата: Воскресенье, 22.10.2023, 08:20 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

2016
Pelena, Спасибо огромное, выручили. А поводу того, что не рекомендуется использовать впр в листе целиком, так по другому я просто не в состоянии сделать.


пыпы
 
Ответить
СообщениеPelena, Спасибо огромное, выручили. А поводу того, что не рекомендуется использовать впр в листе целиком, так по другому я просто не в состоянии сделать.

Автор - caind2015
Дата добавления - 22.10.2023 в 08:20
DrMini Дата: Воскресенье, 22.10.2023, 08:55 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
так по другому я просто не в состоянии сделать.

Читал, что ИНДЕКС быстрее ВПР. Если это правда то можно вот так:
Код
=ЕСЛИОШИБКА(ИНДЕКС('Лабораторный журнал'!E:E;ПОИСКПОЗ(B17&"К";'Лабораторный журнал'!A:A;0));"")

Ну или ограничить диапазоны, как в посте выше у Елены.
 
Ответить
Сообщение
так по другому я просто не в состоянии сделать.

Читал, что ИНДЕКС быстрее ВПР. Если это правда то можно вот так:
Код
=ЕСЛИОШИБКА(ИНДЕКС('Лабораторный журнал'!E:E;ПОИСКПОЗ(B17&"К";'Лабораторный журнал'!A:A;0));"")

Ну или ограничить диапазоны, как в посте выше у Елены.

Автор - DrMini
Дата добавления - 22.10.2023 в 08:55
caind2015 Дата: Воскресенье, 22.10.2023, 10:32 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

2016
DrMini, Спасибо. Попробую поработать с ИНДЕКСОМ.


пыпы

Сообщение отредактировал caind2015 - Воскресенье, 22.10.2023, 10:43
 
Ответить
СообщениеDrMini, Спасибо. Попробую поработать с ИНДЕКСОМ.

Автор - caind2015
Дата добавления - 22.10.2023 в 10:32
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!