Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск рабочих смен по вкладкам и сведение в единую таблицу - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск рабочих смен по вкладкам и сведение в единую таблицу (Формулы/Formulas)
Поиск рабочих смен по вкладкам и сведение в единую таблицу
romanermulin Дата: Суббота, 21.10.2023, 18:03 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

16.66.1
Доброго дня!
Прошу помощи, т.к. самому не вывезти это.)
Есть вкладки с ФИО работников, в них рабочие смены в течении месяца.
Цель собрать все эти фио и их смены в единой таблице, чтобы видеть ситуацию.
Но важно следующее, чтобы в сводной таблице можно было вбить фио самому, и формула сама нашла нужную вкладку с этим фио и подгрузила смены из этой вкладки.
Пример прилагаю.
К сообщению приложен файл: 9619385.xlsx (13.4 Kb)


Роман
 
Ответить
СообщениеДоброго дня!
Прошу помощи, т.к. самому не вывезти это.)
Есть вкладки с ФИО работников, в них рабочие смены в течении месяца.
Цель собрать все эти фио и их смены в единой таблице, чтобы видеть ситуацию.
Но важно следующее, чтобы в сводной таблице можно было вбить фио самому, и формула сама нашла нужную вкладку с этим фио и подгрузила смены из этой вкладки.
Пример прилагаю.

Автор - romanermulin
Дата добавления - 21.10.2023 в 18:03
Gustav Дата: Суббота, 21.10.2023, 19:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2757
Репутация: 1139 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Например, такая формула для ячейки B2 на листе "Сводная":
Код
=ПОДСТАВИТЬ(ИНДЕКС(ДВССЫЛ($A2&"!B:B"); ПОИСКПОЗ(B$1; ДВССЫЛ($A2&"!A:A"); 0)); "0";"")

И дальше копируем B2 на всю область B2:AF4. Нули, возвращаемые пустыми ячейками фамильных листов, давим функцией ПОДСТАВИТЬ с заменой на пустые строки.

[p.s.]Либо формула может быть даже проще, если все фамильные листы имеют одинаковую структуру:[/p.s.]
Код
=ПОДСТАВИТЬ(ИНДЕКС(ДВССЫЛ($A2&"!B:B"); B$1+1); "0";"")


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Суббота, 21.10.2023, 20:08
 
Ответить
СообщениеНапример, такая формула для ячейки B2 на листе "Сводная":
Код
=ПОДСТАВИТЬ(ИНДЕКС(ДВССЫЛ($A2&"!B:B"); ПОИСКПОЗ(B$1; ДВССЫЛ($A2&"!A:A"); 0)); "0";"")

И дальше копируем B2 на всю область B2:AF4. Нули, возвращаемые пустыми ячейками фамильных листов, давим функцией ПОДСТАВИТЬ с заменой на пустые строки.

[p.s.]Либо формула может быть даже проще, если все фамильные листы имеют одинаковую структуру:[/p.s.]
Код
=ПОДСТАВИТЬ(ИНДЕКС(ДВССЫЛ($A2&"!B:B"); B$1+1); "0";"")

Автор - Gustav
Дата добавления - 21.10.2023 в 19:10
DrMini Дата: Суббота, 21.10.2023, 20:03 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте.
Ещё вариант.
Лист Сводная должен быть всегда первым. Или нужно будет подправить формулу.
К сообщению приложен файл: 9619385.xlsm (17.9 Kb)


Сообщение отредактировал DrMini - Суббота, 21.10.2023, 20:03
 
Ответить
СообщениеЗдравствуйте.
Ещё вариант.
Лист Сводная должен быть всегда первым. Или нужно будет подправить формулу.

Автор - DrMini
Дата добавления - 21.10.2023 в 20:03
romanermulin Дата: Суббота, 21.10.2023, 22:23 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

16.66.1
DrMini, большое спасибо! Это именно то, что нужно!


Роман

Сообщение отредактировал romanermulin - Суббота, 21.10.2023, 23:00
 
Ответить
СообщениеDrMini, большое спасибо! Это именно то, что нужно!

Автор - romanermulin
Дата добавления - 21.10.2023 в 22:23
DrMini Дата: Воскресенье, 22.10.2023, 05:53 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Это именно то, что нужно!

Раз так, то немного подправьте формулу:
Код
=ЕСЛИ(A2="";"";ПОДСТАВИТЬ(ТРАНСП(ДВССЫЛ("'"&A2&"'!B2:B32"));0;"";1))

и протяните вниз.
Формат ячейки сделайте Общий.
К сообщению приложен файл: 9619385_podstavit.xlsm (17.9 Kb)
 
Ответить
Сообщение
Это именно то, что нужно!

Раз так, то немного подправьте формулу:
Код
=ЕСЛИ(A2="";"";ПОДСТАВИТЬ(ТРАНСП(ДВССЫЛ("'"&A2&"'!B2:B32"));0;"";1))

и протяните вниз.
Формат ячейки сделайте Общий.

Автор - DrMini
Дата добавления - 22.10.2023 в 05:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск рабочих смен по вкладкам и сведение в единую таблицу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!