Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование графика работы на конкретный месяц из годового - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Формирование графика работы на конкретный месяц из годового
romanermulin Дата: Воскресенье, 22.10.2023, 18:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

16.66.1
Всем здравия! Пытаюсь создать график работы на месяц для учета и планирования персонала.
Есть общий график на год в отдельной вкладке, а есть вкладка с графиком на месяц.
Так вот, когда вбиваем нужный месяц, строка с датами заполняется автоматически, теперь нужно, чтобы для каждой из бригад заполнились строки с планируемым графиком работы в соответствии с датами из годового графика.
Строки, в которых должно быть автозаполнение выделены желтым.
Возможно ли это реализовать формулами?
Пример приложил
К сообщению приложен файл: 6860769.xlsx (18.7 Kb)


Роман
 
Ответить
СообщениеВсем здравия! Пытаюсь создать график работы на месяц для учета и планирования персонала.
Есть общий график на год в отдельной вкладке, а есть вкладка с графиком на месяц.
Так вот, когда вбиваем нужный месяц, строка с датами заполняется автоматически, теперь нужно, чтобы для каждой из бригад заполнились строки с планируемым графиком работы в соответствии с датами из годового графика.
Строки, в которых должно быть автозаполнение выделены желтым.
Возможно ли это реализовать формулами?
Пример приложил

Автор - romanermulin
Дата добавления - 22.10.2023 в 18:30
DrMini Дата: Воскресенье, 22.10.2023, 18:59 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1679
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте.
Может так:
Код
=ПОДСТАВИТЬ(ИНДЕКС('График на год'!$B$2:$NB$6;ПОИСКПОЗ($B4;'График на год'!$A$2:$A$6;0);ПОИСКПОЗ(D$2;'График на год'!$B$1:$NB$1;0));0;"")

[p.s.]и между бригадами я бы пустую строку убрал. Формулы "тянуть" легче и на читаемость не влияют. ИМХО[/p.s.]
К сообщению приложен файл: 9070410.xlsx (20.2 Kb)
 
Ответить
СообщениеЗдравствуйте.
Может так:
Код
=ПОДСТАВИТЬ(ИНДЕКС('График на год'!$B$2:$NB$6;ПОИСКПОЗ($B4;'График на год'!$A$2:$A$6;0);ПОИСКПОЗ(D$2;'График на год'!$B$1:$NB$1;0));0;"")

[p.s.]и между бригадами я бы пустую строку убрал. Формулы "тянуть" легче и на читаемость не влияют. ИМХО[/p.s.]

Автор - DrMini
Дата добавления - 22.10.2023 в 18:59
DrMini Дата: Воскресенье, 22.10.2023, 19:06 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1679
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Чтобы в месяцах меньше 31 дня небыло ошибки подправьте формулу вот так:
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(ИНДЕКС('График на год'!$B$2:$NB$6;ПОИСКПОЗ($B4;'График на год'!$A$2:$A$6;0);ПОИСКПОЗ(D$2;'График на год'!$B$1:$NB$1;0));0;"");"")


Сообщение отредактировал DrMini - Воскресенье, 22.10.2023, 19:08
 
Ответить
СообщениеЧтобы в месяцах меньше 31 дня небыло ошибки подправьте формулу вот так:
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(ИНДЕКС('График на год'!$B$2:$NB$6;ПОИСКПОЗ($B4;'График на год'!$A$2:$A$6;0);ПОИСКПОЗ(D$2;'График на год'!$B$1:$NB$1;0));0;"");"")

Автор - DrMini
Дата добавления - 22.10.2023 в 19:06
romanermulin Дата: Воскресенье, 22.10.2023, 19:19 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

16.66.1
DrMini, Супер! Спасибо!!


Роман
 
Ответить
СообщениеDrMini, Супер! Спасибо!!

Автор - romanermulin
Дата добавления - 22.10.2023 в 19:19
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!