Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сделать сортировку данных в зависимости от веса и результата - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сделать сортировку данных в зависимости от веса и результата (Формулы/Formulas)
Сделать сортировку данных в зависимости от веса и результата
nbiryulina2012 Дата: Понедельник, 23.10.2023, 07:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 20% ±

Всем привет)

Дано: нужно отсортировать данные в столбцах "S" (Весовая категория) и "T" (Результат) и вывести буквенный результат в столбец "X" (Разряд). Если минимальный результат ( для третьего разряда не выполнен строка остается пустой.
Например в строке 10: Спортсмен категории 67,5 кг поднял 75 кг - этот результат в его категории равен "3 РАЗРЯД"

Таблица соответствий весовой категории и результата в столбцах AB:AD

Спасибо!
К сообщению приложен файл: strogij_biceps_28_10_23.xls (348.0 Kb)
 
Ответить
СообщениеВсем привет)

Дано: нужно отсортировать данные в столбцах "S" (Весовая категория) и "T" (Результат) и вывести буквенный результат в столбец "X" (Разряд). Если минимальный результат ( для третьего разряда не выполнен строка остается пустой.
Например в строке 10: Спортсмен категории 67,5 кг поднял 75 кг - этот результат в его категории равен "3 РАЗРЯД"

Таблица соответствий весовой категории и результата в столбцах AB:AD

Спасибо!

Автор - nbiryulina2012
Дата добавления - 23.10.2023 в 07:31
bigor Дата: Понедельник, 23.10.2023, 11:17 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1110
Репутация: 212 ±
Замечаний: 0% ±

нет
Добрый день
Выводит разряд. (с последними более 14?) неправильно. Так как в S у вас текст, а в AB числа, привел все к тексту.
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС($AB$10:$AD$93;ПОИСКПОЗ(S10;$AB$10:$AB$93;0);3):ИНДЕКС($AB$10:$AD$93;ПОИСКПОЗ(S10;$AB$10:$AB$93;1);3);ПОИСКПОЗ(--T10;ИНДЕКС($AB$10:$AD$93;ПОИСКПОЗ(S10;$AB$10:$AB$93;0);2):ИНДЕКС($AB$10:$AD$93;ПОИСКПОЗ(S10;$AB$10:$AB$93;1);2);1));"")
 
Ответить
СообщениеДобрый день
Выводит разряд. (с последними более 14?) неправильно. Так как в S у вас текст, а в AB числа, привел все к тексту.
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС($AB$10:$AD$93;ПОИСКПОЗ(S10;$AB$10:$AB$93;0);3):ИНДЕКС($AB$10:$AD$93;ПОИСКПОЗ(S10;$AB$10:$AB$93;1);3);ПОИСКПОЗ(--T10;ИНДЕКС($AB$10:$AD$93;ПОИСКПОЗ(S10;$AB$10:$AB$93;0);2):ИНДЕКС($AB$10:$AD$93;ПОИСКПОЗ(S10;$AB$10:$AB$93;1);2);1));"")

Автор - bigor
Дата добавления - 23.10.2023 в 11:17
nbiryulina2012 Дата: Понедельник, 23.10.2023, 13:17 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 20% ±

bigor, У меня не получается все равно... <_<
 
Ответить
Сообщениеbigor, У меня не получается все равно... <_<

Автор - nbiryulina2012
Дата добавления - 23.10.2023 в 13:17
bigor Дата: Понедельник, 23.10.2023, 13:36 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1110
Репутация: 212 ±
Замечаний: 0% ±

нет
nbiryulina2012, смотрите файл
К сообщению приложен файл: kopija_strogij_biceps_28_10_23.xlsm (117.8 Kb)
 
Ответить
Сообщениеnbiryulina2012, смотрите файл

Автор - bigor
Дата добавления - 23.10.2023 в 13:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сделать сортировку данных в зависимости от веса и результата (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!